source: projects/specs/trunk/lib/libX/libXinerama/libXinerama-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXinerama runtime library
4Summary(ja): X.Org X11 libXinerama ランタイムライブラリ
5Name: libXinerama
6Version: 1.1
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/X11R7.0-RC4/everything/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXau-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libXinerama runtime library
24
25%package devel
26Summary: X.Org X11 libXinerama development package
27Summary(ja): X.Org X11 libXinerama 開発パッケージ
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXinerama development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXinerama runtime library
40Summary(ja): X.Org X11 libXinerama ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXinerama runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXinerama development package
48Summary(ja): X.Org X11 libXinerama 開発パッケージ
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53
54%description -n compat32-%{name}-devel
55X.Org X11 libXinerama development package
56
57%prep
58%setup -q
59
60%build
61
62%configure --disable-static
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68make install DESTDIR=$RPM_BUILD_ROOT
69
70# We intentionally don't ship *.la files
71rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post -p /sbin/ldconfig
77%postun -p /sbin/ldconfig
78
79%post -n compat32-%{name} -p /sbin/ldconfig
80%postun -n compat32-%{name} -p /sbin/ldconfig
81
82%files
83%defattr(-,root,root,-)
84%doc AUTHORS COPYING README ChangeLog
85%{_libdir}/libXinerama.so.1
86%{_libdir}/libXinerama.so.1.*
87
88%files devel
89%defattr(-,root,root,-)
90%{_includedir}/X11/extensions/*.h
91%{_libdir}/libXinerama.so
92%{_libdir}/pkgconfig/xinerama.pc
93%{_mandir}/man3/*.3*
94
95# compat32
96%if %{build_compat32}
97%files -n compat32-%{name}
98%defattr(-,root,root,-)
99%{_libdir}/libXinerama.so.1
100%{_libdir}/libXinerama.so.1.*
101
102%files -n compat32-%{name}-devel
103%defattr(-,root,root,-)
104%{_libdir}/libXinerama.so
105%{_libdir}/pkgconfig/xinerama.pc
106%endif
107
108%changelog
109* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-2
110- add Xinerama.h/panoramiXext.h
111
112* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
113- new upstream release
114
115* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.3-2
116- added compat32 package for x86_64 arch support
117
118* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
119- new upstream release
120
121* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
122- new versioning policy
123
124* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
125- initial build for Vine Linux
126
127* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-3
128- Rebuild for build id
129
130* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-2
131- Don't install INSTALL
132
133* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-1
134- libXinerama 1.0.2
135
136* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
137- rebuild
138
139* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
140- Replace "makeinstall" with "make install DESTDIR=..."
141- Added "Requires: xorg-x11-proto-devel" to devel for xinerama.pc
142- Remove package ownership of mandir/libdir/etc.
143
144* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
145- bump again for double-long bug on ppc(64)
146
147* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
148- rebuilt for new gcc4.1 snapshot and glibc changes
149
150* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
151- Updated libXinerama to version 1.0.1 from X11R7.0
152
153* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
154- Updated libXinerama to version 1.0.0 from X11R7 RC4
155
156* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
157- Updated libXinerama to version 0.99.2 from X11R7 RC3
158- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
159  that /usr/lib/X11 and /usr/include/X11 pre-exist.
160- Removed 'x' suffix from manpage directories to match RC3 upstream.
161
162* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
163- Added "BuildRequires: libXau-devel", as twm fails without it, but does not
164  check for it with ./configure.  Bug (fdo#5065)
165
166* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
167- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
168- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
169
170* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
171- Updated libXinerama to version 0.99.1 from X11R7 RC1
172
173* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
174- Renamed package to remove xorg-x11 from the name due to unanimous decision
175  between developers.
176- Use Fedora Extras style BuildRoot tag.
177- Disable static library creation by default.
178- Add missing defattr to devel subpackage
179- Add missing documentation files to doc macro
180
181* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
182- Renamed package to prepend "xorg-x11" to the name for consistency with
183  the rest of the X11R7 packages.
184- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
185  subpackage to ensure the devel package matches the installed shared libs.
186- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
187  allow applications to use implementation agnostic dependencies.
188- Added post/postun scripts which call ldconfig.
189- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
190  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
191
192* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
193- Initial build.
Note: See TracBrowser for help on using the repository browser.