source: projects/specs/trunk/lib/libX/libXi/libXi-vl.spec @ 8064

Revision 8064, 8.0 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXi runtime library
4Summary(ja): X.Org X11 libXi ランタイムライブラリ
5Name: libXi
6Version: 1.7.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: xorg-x11-proto-devel
18BuildRequires: libX11-devel
19BuildRequires: libXext-devel
20BuildRequires: libXau-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28X.Org X11 libXi runtime library
29
30%package devel
31Summary: X.Org X11 libXi development package
32Summary(ja): X.Org X11 libXi 開発パッケージ
33Group: Development/Libraries
34Requires(pre): xorg-x11-filesystem
35Requires: %{name} = %{version}-%{release}
36Requires: xorg-x11-proto-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXi development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXi runtime library
45Summary(ja): X.Org X11 libXi ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49X.Org X11 libXi runtime library
50
51%package -n compat32-%{name}-devel
52Summary: X.Org X11 libXi development package
53Summary(ja): X.Org X11 libXi 開発パッケージ
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58
59%description -n compat32-%{name}-devel
60X.Org X11 libXi development package
61
62%prep
63%setup -q
64
65# Disable static library creation by default.
66%define with_static 0
67
68%build
69%configure \
70%if ! %{with_static}
71        --disable-static
72%endif
73make
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install DESTDIR=$RPM_BUILD_ROOT
79
80# We intentionally don't ship *.la files
81rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
82
83# remove xml and txt file
84rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
85rm -rf $RPM_BUILD_ROOT%{_mandir}
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc COPYING README ChangeLog
99%{_libdir}/libXi.so.6
100%{_libdir}/libXi.so.6.*
101
102%files devel
103%defattr(-,root,root,-)
104%{_includedir}/X11/extensions/*.h
105%if %{with_static}
106%{_libdir}/libXi.a
107%endif
108%{_libdir}/libXi.so
109%{_libdir}/pkgconfig/xi.pc
110
111# compat32
112%if %{build_compat32}
113%files -n compat32-%{name}
114%defattr(-,root,root,-)
115%{_libdir}/libXi.so.6
116%{_libdir}/libXi.so.6.*
117
118%files -n compat32-%{name}-devel
119%defattr(-,root,root,-)
120%if %{with_static}
121%{_libdir}/libXi.a
122%endif
123%{_libdir}/libXi.so
124%endif
125
126%changelog
127* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.2-2
128- rebuild with VineSeed environment
129
130* Mon Aug 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.2-1
131- new upstream release
132- remove Patch0 (libXi-1.7.1-git20130524.patch)
133
134* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-2
135- add Patch0 (libXi-1.7.1-git20130524.patch)
136  (including security fix for CVE-2013-1984,1995,1998)
137
138* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-1
139- new upstream release
140
141* Fri May 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
142- new upstream release
143
144* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
145- new upstream release
146
147* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.0-1
148- new upstream release
149
150* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
151- new upstream release
152
153* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
154- new upstream release
155
156* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
157- new upstream release
158
159* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
160- new upstream release
161
162* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
163- new upstream release
164- fix %%install
165
166* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-2
167- rebuild with rpm-4.8.1 for pkg-config file
168- fix %files (remove AUTHOR, man3)
169
170* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-1
171- new upstream release
172
173* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.1-2
174- added compat32 package for x86_64 arch support
175
176* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
177- new upstream release
178
179* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
180- new upstream release
181
182* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-1
183- new upstream release
184
185* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
186- new versioning policy
187
188* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-0vl1
189- initial build for Vine Linux
190
191* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.1.3-1
192- libXi 1.1.3
193
194* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.1.1-2
195- Rebuild for build id
196
197* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 1.1.1-1
198- libXi 1.1.1
199
200* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
201- Don't install INSTALL
202
203* Wed Apr 11 2007 Adam Jackson <ajax@redhat.com> 1.0.4-1
204- libXi 1.0.4
205
206* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
207- Update to 1.0.2
208
209* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
210- rebuild
211
212* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
213- Added "Requires: xorg-x11-proto-devel" to devel package for xi.pc
214- Remove package ownership of mandir/libdir/etc.
215
216* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
217- Replace "makeinstall" with "make install DESTDIR=..." for (#192721)
218- Remove package ownership of mandir/libdir/etc.
219
220* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
221- Update to 1.0.1
222
223* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
224- bump again for double-long bug on ppc(64)
225
226* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
227- rebuilt for new gcc4.1 snapshot and glibc changes
228
229* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
230- Bumped and rebuilt
231
232* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
233- Updated libXi to version 1.0.0 from X11R7 RC4
234
235* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
236- Updated libXi to version 0.99.2 from X11R7 RC3
237- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
238  that /usr/lib/X11 and /usr/include/X11 pre-exist.
239- Removed 'x' suffix from manpage directories to match RC3 upstream.
240
241* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
242- Added "BuildRequires: libXau-devel", as build fails without it, but does
243  not check for it with ./configure.  Bug (fdo#5065)
244
245* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
246- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
247- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
248
249* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
250- Updated libXi to version 0.99.1 from X11R7 RC1
251- Updated file manifest to find manpages in "man3x"
252
253* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
254- Renamed package to remove xorg-x11 from the name due to unanimous decision
255  between developers.
256- Use Fedora Extras style BuildRoot tag.
257- Disable static library creation by default.
258- Add missing defattr to devel subpackage
259- Add missing documentation files to doc macro
260
261* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
262- Renamed package to prepend "xorg-x11" to the name for consistency with
263  the rest of the X11R7 packages.
264- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
265  subpackage to ensure the devel package matches the installed shared libs.
266- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
267  allow applications to use implementation agnostic dependencies.
268- Added post/postun scripts which call ldconfig.
269- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
270  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
271
272* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
273- Initial build.
Note: See TracBrowser for help on using the repository browser.