source: projects/specs/trunk/lib/libX/libXi/libXi-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXi runtime library
4Summary(ja): X.Org X11 libXi ランタイムライブラリ
5Name: libXi
6Version: 1.3
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXau-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libXi runtime library
24
25%package devel
26Summary: X.Org X11 libXi development package
27Summary(ja): X.Org X11 libXi 開発パッケージ
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXi development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXi runtime library
40Summary(ja): X.Org X11 libXi ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXi runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXi development package
48Summary(ja): X.Org X11 libXi 開発パッケージ
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53
54%description -n compat32-%{name}-devel
55X.Org X11 libXi development package
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64%configure \
65%if ! %{with_static}
66        --disable-static
67%endif
68make
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75# We intentionally don't ship *.la files
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
84%post -n compat32-%{name} -p /sbin/ldconfig
85%postun -n compat32-%{name} -p /sbin/ldconfig
86
87%files
88%defattr(-,root,root,-)
89%doc AUTHORS COPYING README ChangeLog
90%{_libdir}/libXi.so.6
91%{_libdir}/libXi.so.6.*
92
93%files devel
94%defattr(-,root,root,-)
95%{_includedir}/X11/extensions/*.h
96%if %{with_static}
97%{_libdir}/libXi.a
98%endif
99%{_libdir}/libXi.so
100%{_libdir}/pkgconfig/xi.pc
101#%dir %{_mandir}/man3x
102%{_mandir}/man3/*.3*
103
104# compat32
105%if %{build_compat32}
106%files -n compat32-%{name}
107%defattr(-,root,root,-)
108%{_libdir}/libXi.so.6
109%{_libdir}/libXi.so.6.*
110
111%files -n compat32-%{name}-devel
112%defattr(-,root,root,-)
113%if %{with_static}
114%{_libdir}/libXi.a
115%endif
116%{_libdir}/libXi.so
117%{_libdir}/pkgconfig/xi.pc
118%endif
119
120%changelog
121* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-1
122- new upstream release
123
124* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.1-2
125- added compat32 package for x86_64 arch support
126
127* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
128- new upstream release
129
130* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
131- new upstream release
132
133* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-1
134- new upstream release
135
136* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
137- new versioning policy
138
139* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-0vl1
140- initial build for Vine Linux
141
142* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.1.3-1
143- libXi 1.1.3
144
145* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.1.1-2
146- Rebuild for build id
147
148* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 1.1.1-1
149- libXi 1.1.1
150
151* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
152- Don't install INSTALL
153
154* Wed Apr 11 2007 Adam Jackson <ajax@redhat.com> 1.0.4-1
155- libXi 1.0.4
156
157* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
158- Update to 1.0.2
159
160* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
161- rebuild
162
163* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
164- Added "Requires: xorg-x11-proto-devel" to devel package for xi.pc
165- Remove package ownership of mandir/libdir/etc.
166
167* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
168- Replace "makeinstall" with "make install DESTDIR=..." for (#192721)
169- Remove package ownership of mandir/libdir/etc.
170
171* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
172- Update to 1.0.1
173
174* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
175- bump again for double-long bug on ppc(64)
176
177* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
178- rebuilt for new gcc4.1 snapshot and glibc changes
179
180* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
181- Bumped and rebuilt
182
183* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
184- Updated libXi to version 1.0.0 from X11R7 RC4
185
186* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
187- Updated libXi to version 0.99.2 from X11R7 RC3
188- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
189  that /usr/lib/X11 and /usr/include/X11 pre-exist.
190- Removed 'x' suffix from manpage directories to match RC3 upstream.
191
192* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
193- Added "BuildRequires: libXau-devel", as build fails without it, but does
194  not check for it with ./configure.  Bug (fdo#5065)
195
196* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
197- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
198- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
199
200* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
201- Updated libXi to version 0.99.1 from X11R7 RC1
202- Updated file manifest to find manpages in "man3x"
203
204* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
205- Renamed package to remove xorg-x11 from the name due to unanimous decision
206  between developers.
207- Use Fedora Extras style BuildRoot tag.
208- Disable static library creation by default.
209- Add missing defattr to devel subpackage
210- Add missing documentation files to doc macro
211
212* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
213- Renamed package to prepend "xorg-x11" to the name for consistency with
214  the rest of the X11R7 packages.
215- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
216  subpackage to ensure the devel package matches the installed shared libs.
217- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
218  allow applications to use implementation agnostic dependencies.
219- Added post/postun scripts which call ldconfig.
220- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
221  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
222
223* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
224- Initial build.
Note: See TracBrowser for help on using the repository browser.