source: projects/specs/trunk/lib/libX/libXft/libXft-vl.spec @ 8064

Revision 8064, 7.8 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXft runtime library
4Summary(ja): X.Org X11 libXft ランタイムライブラリ
5Name: libXft
6Version: 2.3.1
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14Patch0:         libXft-2.3.1-freetype-2.5.x.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: pkgconfig
18BuildRequires: xorg-x11-proto-devel
19BuildRequires: xorg-x11-util-macros
20BuildRequires: libX11-devel
21BuildRequires: libXrender-devel
22BuildRequires: freetype2-devel >= 2.3
23BuildRequires: fontconfig-devel
24Requires: fontconfig
25Obsoletes: XFree86-libs, XOrg-libs
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31%description
32X.Org X11 libXft runtime library
33
34%package devel
35Summary: X.Org X11 libXft development package
36Summary(ja): X.Org X11 libXft 開発パッケージ
37Group: Development/Libraries
38Requires(pre): xorg-x11-filesystem
39Requires: %{name} = %{version}-%{release}
40Requires: xorg-x11-proto-devel
41Requires: libXrender-devel
42Requires: fontconfig-devel
43Requires: freetype2-devel
44Obsoletes: XFree86-devel, XOrg-devel
45
46%description devel
47X.Org X11 libXft development package
48
49# compat32
50%package -n compat32-%{name}
51Summary: X.Org X11 libXft runtime library
52Summary(ja): X.Org X11 libXft ランタイムライブラリ
53Group: System Environment/Libraries
54
55%description -n compat32-%{name}
56X.Org X11 libXft runtime library
57
58%package  -n compat32-%{name}-devel
59Summary: X.Org X11 libXft development package
60Summary(ja): X.Org X11 libXft 開発パッケージ
61Group: Development/Libraries
62Requires(pre): xorg-x11-filesystem
63Requires: compat32-%{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65Requires: compat32-libXrender-devel
66Requires: compat32-fontconfig-devel
67Requires: compat32-freetype2-devel
68
69%description -n compat32-%{name}-devel
70X.Org X11 libXft development package
71
72%prep
73%setup -q
74%patch0 -p1 -b .ft
75
76# Disable static library creation by default.
77%define with_static 0
78
79%build
80
81%configure \
82%if ! %{with_static}
83        --disable-static
84%endif
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT
91
92# FIXME: There's no real good reason to ship these anymore, as pkg-config
93# is the official way to detect flags, etc. now.
94rm -f $RPM_BUILD_ROOT%{_bindir}/xft-config
95rm -f $RPM_BUILD_ROOT%{_mandir}/man1/xft-config*
96
97# We intentionally don't ship *.la files
98rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%post -n compat32-%{name} -p /sbin/ldconfig
107%postun -n compat32-%{name} -p /sbin/ldconfig
108
109%files
110%defattr(-,root,root,-)
111%doc AUTHORS COPYING README ChangeLog NEWS
112%{_libdir}/libXft.so.*
113
114%files devel
115%defattr(-,root,root,-)
116#%{_bindir}/xft-config
117%dir %{_includedir}/X11
118%dir %{_includedir}/X11/Xft
119%{_includedir}/X11/Xft/Xft.h
120%{_includedir}/X11/Xft/XftCompat.h
121%if %{with_static}
122%{_libdir}/libXft.a
123%endif
124%{_libdir}/libXft.so
125%{_libdir}/pkgconfig/xft.pc
126#%{_mandir}/man1/xft-config.1.gz
127%{_mandir}/man3/Xft.3*
128
129# compat32
130%if %{build_compat32}
131%files -n compat32-%{name}
132%defattr(-,root,root,-)
133%{_libdir}/libXft.so.*
134
135%files -n compat32-%{name}-devel
136%defattr(-,root,root,-)
137%if %{with_static}
138%{_libdir}/libXft.a
139%endif
140%{_libdir}/libXft.so
141%endif
142
143%changelog
144* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.1-2
145- rebuild with VineSeed environment
146- add Patch0 (libXft-2.3.1-freetype-2.5.x.patch)
147
148* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.1-1
149- new upstream release
150
151* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.0-1
152- new upstream release
153- add BuildRequires: xorg-x11-util-macros
154
155* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
156- new upstream release
157
158* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.1.14-2
159- build with rpm-4.8.1-1 for pkg-config file
160
161* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.14-1
162- new upstream release
163
164* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.13-2
165- added compat32 package for x86_64 arch support
166
167* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.13-1
168- new upstream release
169
170* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.12-1
171- new versioning policy
172
173* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.12-0vl1
174- initial build for Vine Linux
175
176* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 2.1.12-3
177- Rebuild for build id
178
179* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 2.1.12-2
180- Don't install INSTALL
181
182* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 2.1.12-1.fc7
183- Update to 2.1.12
184
185* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
186- rebuild
187
188* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 2.1.10
189- Updated libXft to version 2.1.10
190- Specify freetype dependencies as >= 2.1.9-1
191- Futureproof builds by adding release number to fontconfig dependencies.
192
193* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-4
194- Replace "makeinstall" with "make install DESTDIR=..."
195
196* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 2.1.8.2-3.2
197- bump again for double-long bug on ppc(64)
198
199* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 2.1.8.2-3.1
200- rebuilt for new gcc4.1 snapshot and glibc changes
201
202* Thu Feb 02 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-3
203- Added missing dependencies to devel subpackage to fix (#176744)
204
205* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-2
206- Bumped and rebuilt
207
208* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 2.1.8.2-1
209- Updated libXft to version 2.1.8.2 from X11R7 RC4
210
211* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 2.1.8.1-1
212- Updated libXft to version 2.1.8.1 from X11R7 RC3
213- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
214  that /usr/lib/X11 and /usr/include/X11 pre-exist.
215- Removed 'x' suffix from manpage directories to match RC3 upstream.
216- Added "Requires: libXrender-devel" to -devel subpackage for (#175465)
217
218* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
219- rebuilt
220
221* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 2.1.8-2
222- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
223- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
224
225* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 2.1.8-1
226- Updated libXft to version 2.1.8 from X11R7 RC1
227
228* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-5
229- Renamed package to remove xorg-x11 from the name due to unanimous decision
230  between developers.
231- Use Fedora Extras style BuildRoot tag.
232- Disable static library creation by default.
233- Add missing defattr to devel subpackage
234- Add missing documentation files to doc macro
235- Fix BuildRequires to use new style X library package names
236
237* Sun Sep 04 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-4
238- Added "BuildRequires: fontconfig-devel >= 2.2" dependency that was
239  previously missed.  Also added "Requires: fontconfig >= 2.2" runtime
240  dependency.
241- Added missing defattr to devel subpackage.
242
243* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-3
244- Added freetype-devel build dependency.
245
246* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-2
247- Renamed package to prepend "xorg-x11" to the name for consistency with
248  the rest of the X11R7 packages.
249- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
250  subpackage to ensure the devel package matches the installed shared libs.
251- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
252  allow applications to use implementation agnostic dependencies.
253- Added post/postun scripts which call ldconfig.
254- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
255  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
256
257* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-1
258- Initial build.
Note: See TracBrowser for help on using the repository browser.