source: projects/specs/trunk/lib/libX/libXft/libXft-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXft runtime library
4Summary(ja): X.Org X11 libXft ランタイムライブラリ
5Name: libXft
6Version: 2.1.14
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXrender-devel
19BuildRequires: freetype2-devel >= 2.3
20BuildRequires: fontconfig-devel
21Requires: fontconfig
22Obsoletes: XFree86-libs, XOrg-libs
23
24%description
25X.Org X11 libXft runtime library
26
27%package devel
28Summary: X.Org X11 libXft development package
29Summary(ja): X.Org X11 libXft 開発パッケージ
30Group: Development/Libraries
31Requires(pre): xorg-x11-filesystem
32Requires: %{name} = %{version}-%{release}
33Requires: xorg-x11-proto-devel
34Requires: libXrender-devel
35Requires: fontconfig-devel
36Requires: freetype2-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXft development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXft runtime library
45Summary(ja): X.Org X11 libXft ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49X.Org X11 libXft runtime library
50
51%package  -n compat32-%{name}-devel
52Summary: X.Org X11 libXft development package
53Summary(ja): X.Org X11 libXft 開発パッケージ
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-libXrender-devel
59Requires: compat32-fontconfig-devel
60Requires: compat32-freetype2-devel
61
62%description -n compat32-%{name}-devel
63X.Org X11 libXft development package
64
65%prep
66%setup -q
67
68# Disable static library creation by default.
69%define with_static 0
70
71%build
72
73%configure \
74%if ! %{with_static}
75        --disable-static
76%endif
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# FIXME: There's no real good reason to ship these anymore, as pkg-config
85# is the official way to detect flags, etc. now.
86rm -f $RPM_BUILD_ROOT%{_bindir}/xft-config
87rm -f $RPM_BUILD_ROOT%{_mandir}/man1/xft-config*
88
89# We intentionally don't ship *.la files
90rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99%postun -n compat32-%{name} -p /sbin/ldconfig
100
101%files
102%defattr(-,root,root,-)
103%doc AUTHORS COPYING README ChangeLog NEWS
104%{_libdir}/libXft.so.*
105
106%files devel
107%defattr(-,root,root,-)
108#%{_bindir}/xft-config
109%dir %{_includedir}/X11
110%dir %{_includedir}/X11/Xft
111%{_includedir}/X11/Xft/Xft.h
112%{_includedir}/X11/Xft/XftCompat.h
113%if %{with_static}
114%{_libdir}/libXft.a
115%endif
116%{_libdir}/libXft.so
117%{_libdir}/pkgconfig/xft.pc
118#%{_mandir}/man1/xft-config.1.gz
119%{_mandir}/man3/Xft.3*
120
121# compat32
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root,-)
125%{_libdir}/libXft.so.*
126
127%files -n compat32-%{name}-devel
128%defattr(-,root,root,-)
129%if %{with_static}
130%{_libdir}/libXft.a
131%endif
132%{_libdir}/libXft.so
133%{_libdir}/pkgconfig/xft.pc
134%endif
135
136%changelog
137* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.14-1
138- new upstream release
139
140* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.13-2
141- added compat32 package for x86_64 arch support
142
143* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.13-1
144- new upstream release
145
146* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.12-1
147- new versioning policy
148
149* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.12-0vl1
150- initial build for Vine Linux
151
152* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 2.1.12-3
153- Rebuild for build id
154
155* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 2.1.12-2
156- Don't install INSTALL
157
158* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 2.1.12-1.fc7
159- Update to 2.1.12
160
161* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
162- rebuild
163
164* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 2.1.10
165- Updated libXft to version 2.1.10
166- Specify freetype dependencies as >= 2.1.9-1
167- Futureproof builds by adding release number to fontconfig dependencies.
168
169* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-4
170- Replace "makeinstall" with "make install DESTDIR=..."
171
172* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 2.1.8.2-3.2
173- bump again for double-long bug on ppc(64)
174
175* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 2.1.8.2-3.1
176- rebuilt for new gcc4.1 snapshot and glibc changes
177
178* Thu Feb 02 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-3
179- Added missing dependencies to devel subpackage to fix (#176744)
180
181* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 2.1.8.2-2
182- Bumped and rebuilt
183
184* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 2.1.8.2-1
185- Updated libXft to version 2.1.8.2 from X11R7 RC4
186
187* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 2.1.8.1-1
188- Updated libXft to version 2.1.8.1 from X11R7 RC3
189- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
190  that /usr/lib/X11 and /usr/include/X11 pre-exist.
191- Removed 'x' suffix from manpage directories to match RC3 upstream.
192- Added "Requires: libXrender-devel" to -devel subpackage for (#175465)
193
194* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
195- rebuilt
196
197* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 2.1.8-2
198- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
199- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
200
201* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 2.1.8-1
202- Updated libXft to version 2.1.8 from X11R7 RC1
203
204* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-5
205- Renamed package to remove xorg-x11 from the name due to unanimous decision
206  between developers.
207- Use Fedora Extras style BuildRoot tag.
208- Disable static library creation by default.
209- Add missing defattr to devel subpackage
210- Add missing documentation files to doc macro
211- Fix BuildRequires to use new style X library package names
212
213* Sun Sep 04 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-4
214- Added "BuildRequires: fontconfig-devel >= 2.2" dependency that was
215  previously missed.  Also added "Requires: fontconfig >= 2.2" runtime
216  dependency.
217- Added missing defattr to devel subpackage.
218
219* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-3
220- Added freetype-devel build dependency.
221
222* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-2
223- Renamed package to prepend "xorg-x11" to the name for consistency with
224  the rest of the X11R7 packages.
225- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
226  subpackage to ensure the devel package matches the installed shared libs.
227- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
228  allow applications to use implementation agnostic dependencies.
229- Added post/postun scripts which call ldconfig.
230- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
231  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
232
233* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 2.1.7-1
234- Initial build.
Note: See TracBrowser for help on using the repository browser.