source: projects/specs/trunk/lib/libX/libXfixes/libXfixes-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXfixes runtime library
4Summary(ja): X.Org X11 libXfixes ランタイムライブラリ
5Name: libXfixes
6Version: 4.0.4
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: libX11-devel
17BuildRequires: xorg-x11-proto-devel
18Obsoletes: XFree86-libs, XOrg-libs
19
20%description
21X.Org X11 libXfixes runtime library
22
23%package devel
24Summary: X.Org X11 libXfixes development package
25Summary(ja): X.Org X11 libXfixes 開発パッケージ
26Group: Development/Libraries
27Requires(pre): xorg-x11-filesystem >= 0.99.2-3
28Requires: %{name} = %{version}-%{release}
29Requires: xorg-x11-proto-devel
30Obsoletes: XFree86-devel, XOrg-devel
31
32%description devel
33X.Org X11 libXfixes development package
34
35# compat32
36%package -n compat32-%{name}
37Summary: X.Org X11 libXfixes runtime library
38Summary(ja): X.Org X11 libXfixes ランタイムライブラリ
39Group: System Environment/Libraries
40
41%description -n compat32-%{name}
42X.Org X11 libXfixes runtime library
43
44%package -n compat32-%{name}-devel
45Summary: X.Org X11 libXfixes development package
46Summary(ja): X.Org X11 libXfixes 開発パッケージ
47Group: Development/Libraries
48Requires(pre): xorg-x11-filesystem >= 0.99.2-3
49Requires: compat32-%{name} = %{version}-%{release}
50Requires: %{name}-devel = %{version}-%{release}
51
52%description -n compat32-%{name}-devel
53X.Org X11 libXfixes development package
54
55%prep
56%setup -q
57
58# Disable static library creation by default.
59%define with_static 0
60
61%build
62%configure \
63%if ! %{with_static}
64        --disable-static
65%endif
66make
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install DESTDIR=$RPM_BUILD_ROOT
72
73# We intentionally don't ship *.la files
74rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
82%post -n compat32-%{name} -p /sbin/ldconfig
83%postun -n compat32-%{name} -p /sbin/ldconfig
84
85%files
86%defattr(-,root,root,-)
87%doc AUTHORS COPYING README ChangeLog
88%{_libdir}/libXfixes.so.3
89%{_libdir}/libXfixes.so.3.1.*
90
91%files devel
92%defattr(-,root,root,-)
93%dir %{_includedir}/X11
94%dir %{_includedir}/X11/extensions
95%{_includedir}/X11/extensions/Xfixes.h
96%if %{with_static}
97%{_libdir}/libXfixes.a
98%endif
99%{_libdir}/libXfixes.so
100%{_libdir}/pkgconfig/xfixes.pc
101#%dir %{_mandir}/man3x
102%{_mandir}/man3/Xfixes.3*
103
104# compat32
105%if %{build_compat32}
106%files -n compat32-%{name}
107%defattr(-,root,root,-)
108%{_libdir}/libXfixes.so.3
109%{_libdir}/libXfixes.so.3.1.*
110
111%files -n compat32-%{name}-devel
112%defattr(-,root,root,-)
113%if %{with_static}
114%{_libdir}/libXfixes.a
115%endif
116%{_libdir}/libXfixes.so
117%{_libdir}/pkgconfig/xfixes.pc
118%endif
119
120%changelog
121* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.4-1
122- new upstream release
123
124* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.3-3
125- added compat32 package for x86_64 arch support
126
127* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-2
128- spec in utf-8
129
130* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-1
131- new versioning policy
132
133* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl1
134- initial build for Vine Linux
135
136* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 4.0.3-2
137- Rebuild for build id
138
139* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 4.0.3-2
140- Don't install INSTALL
141
142* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 4.0.3-1
143- Update to 4.0.3
144
145* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 4.0.1-2.1
146- rebuild
147
148* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 4.0.1-2
149- Added "BuildRequires: xorg-x11-proto-devel >= 7.0-7" for "fixesproto >= 4.0"
150- Added "Requires: xorg-x11-proto-devel >= 7.0-7" for "fixesproto >= 4.0"
151  to devel package, needed by xfixes.pc
152- Replace "makeinstall" with "make install DESTDIR=..."
153- Remove package ownership of mandir/libdir/etc.
154
155* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 4.0.1-1
156- Bump to 4.0.1.
157
158* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0.1.2-2.2
159- bump again for double-long bug on ppc(64)
160
161* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0.1.2-2.1
162- rebuilt for new gcc4.1 snapshot and glibc changes
163
164* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 3.0.1.2-2
165- Bumped and rebuilt
166
167* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 3.0.1.2-1
168- Updated libXfixes to version 3.0.1.2 from X11R7 RC4
169
170* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 3.0.1.1-1
171- Updated libXfixes to version 3.0.1.1 from X11R7 RC3
172- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
173  that /usr/lib/X11 and /usr/include/X11 pre-exist.
174- Removed 'x' suffix from manpage directories to match RC3 upstream.
175
176* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
177- rebuilt
178
179* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 3.0.1-1
180- Updated libXfixes to version 3.0.1 from X11R7 RC2
181- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
182- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
183
184* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 3.0.0-4
185- Updated libXfixes to version 3.0.0 from X11R7 RC1
186
187* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 3.0.0-3
188- Renamed package to remove xorg-x11 from the name due to unanimous decision
189  between developers.
190- Use Fedora Extras style BuildRoot tag.
191- Disable static library creation by default.
192- Add missing defattr to devel subpackage
193- Add missing documentation files to doc macro
194
195* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 3.0.0-2
196- Renamed package to prepend "xorg-x11" to the name for consistency with
197  the rest of the X11R7 packages.
198- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
199  subpackage to ensure the devel package matches the installed shared libs.
200- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
201  allow applications to use implementation agnostic dependencies.
202- Added post/postun scripts which call ldconfig.
203- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
204  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
205
206* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 3.0.0-1
207- Initial build.
Note: See TracBrowser for help on using the repository browser.