source: projects/specs/trunk/lib/libX/libXext/libXext-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXext runtime library
4Summary(ja): X.Org X11 libXext ランタイムライブラリ
5Name: libXext
6Version: 1.1.1
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXau-devel
19
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libXext runtime library
24
25%package devel
26Summary: X.Org X11 libXext development package
27Group: Development/Libraries
28Requires(pre): xorg-x11-filesystem >= 0.99.2-3
29Requires: %{name} = %{version}-%{release}
30Requires: libX11-devel
31Requires: xorg-x11-proto-devel >= 7.5
32Conflicts: xorg-x11-proto-devel < 7.5
33Obsoletes: XFree86-devel, XOrg-devel
34
35%description devel
36X.Org X11 libXext development package
37
38# compat32
39%package -n compat32-%{name}
40Summary: X.Org X11 libXext runtime library
41Summary(ja): X.Org X11 libXext ランタイムライブラリ
42Group: System Environment/Libraries
43
44%description -n compat32-%{name}
45X.Org X11 libXext runtime library
46
47%package -n compat32-%{name}-devel
48Summary: X.Org X11 libXext development package
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem >= 0.99.2-3
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53Requires: compat32-libX11-devel
54
55%description -n compat32-%{name}-devel
56X.Org X11 libXext development package
57
58%prep
59%setup -q
60
61# Disable static library creation by default.
62%define with_static 0
63
64%build
65
66%configure \
67%if ! %{with_static}
68        --disable-static
69%endif
70make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75make install DESTDIR=$RPM_BUILD_ROOT
76
77# We intentionally don't ship *.la files
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%post -n compat32-%{name} -p /sbin/ldconfig
87%postun -n compat32-%{name} -p /sbin/ldconfig
88
89%files
90%defattr(-,root,root,-)
91%doc AUTHORS COPYING README ChangeLog
92%{_libdir}/libXext.so.6
93%{_libdir}/libXext.so.6.4.*
94
95%files devel
96%defattr(-,root,root,-)
97%{_includedir}/X11/extensions/*.h
98%if %{with_static}
99%{_libdir}/libXext.a
100%endif
101%{_libdir}/libXext.so
102%{_libdir}/pkgconfig/xext.pc
103%{_mandir}/man3/*.3*
104
105# compat32
106%if %{build_compat32}
107%files -n compat32-%{name}
108%defattr(-,root,root,-)
109%{_libdir}/libXext.so.6
110%{_libdir}/libXext.so.6.4.*
111
112%files -n compat32-%{name}-devel
113%defattr(-,root,root,-)
114%if %{with_static}
115%{_libdir}/libXext.a
116%endif
117%{_libdir}/libXext.so
118%{_libdir}/pkgconfig/xext.pc
119%endif
120
121%changelog
122* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
123- new upstream release
124
125* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
126- new upstream release
127
128* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
129- added compat32 package for x86_64 arch support
130
131* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
132- new upstream release
133
134* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
135- new versioning policy
136
137* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
138- initial build for Vine Linux
139
140* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
141- Rebuild for build id
142
143* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.1-4
144- Don't install INSTALL
145
146* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
147- Force xorg-x11-proto-devel on >= 7.1-10 (for LBX headers), and rebuild.
148
149* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.1
150- rebuild
151
152* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
153- Replace "makeinstall" with "make install DESTDIR=..."
154- Remove package ownership of mandir/libdir/etc.
155
156* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
157- Update to 1.0.1
158
159* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.2
160- bump again for double-long bug on ppc(64)
161
162* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.1
163- rebuilt for new gcc4.1 snapshot and glibc changes
164
165* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
166- Added "Requires: xorg-x11-proto-devel >= 7.0-1" to devel package (#173713)
167- Added "libX11-devel" to devel package (#176078)
168
169* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
170- Bumped and rebuilt
171
172* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
173- Updated libXext to version 1.0.0 from X11R7 RC4
174
175* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
176- Updated libXext to version 0.99.3 from X11R7 RC3
177- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
178  that /usr/lib/X11 and /usr/include/X11 pre-exist.
179- Removed 'x' suffix from manpage directories to match RC3 upstream.
180
181* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
182- rebuilt
183
184* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
185- Updated libXext to version 0.99.2 from X11R7 RC2
186- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
187- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
188
189* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
190- Updated to libXext-0.99.1 from the X11R7 RC1 release.
191- Added manpages that were absent in X11R7 RC0, and updated the file lists
192  to find them in section "man3x".
193
194* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
195- Renamed package to remove xorg-x11 from the name due to unanimous decision
196  between developers.
197- Use Fedora Extras style BuildRoot tag.
198- Disable static library creation by default.
199- Add missing defattr to devel subpackage
200- Add missing documentation files to doc macro
201
202* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
203- Renamed package to prepend "xorg-x11" to the name for consistency with
204  the rest of the X11R7 packages.
205- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
206  subpackage to ensure the devel package matches the installed shared libs.
207- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
208  allow applications to use implementation agnostic dependencies.
209- Added post/postun scripts which call ldconfig.
210- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
211  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
212
213* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
214- Initial build.
Note: See TracBrowser for help on using the repository browser.