source: projects/specs/trunk/lib/libX/libXdmcp/libXdmcp-vl.spec @ 8064

Revision 8064, 6.5 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXdmcp runtime library
4Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
5Name: libXdmcp
6Version: 1.1.1
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18Obsoletes: XFree86-libs, XOrg-libs
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
23
24%description
25X.Org X11 libXdmcp runtime library
26
27%package devel
28Summary: X.Org X11 libXdmcp development package
29Group: Development/Libraries
30Requires(pre): xorg-x11-filesystem
31Requires: %{name} = %{version}-%{release}
32Requires: xorg-x11-proto-devel
33Obsoletes: XFree86-devel, XOrg-devel
34
35%description devel
36X.Org X11 libXdmcp development package
37
38# compat32
39%package -n compat32-%{name}
40Summary: X.Org X11 libXdmcp runtime library
41Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
42Group: System Environment/Libraries
43
44%description -n compat32-%{name}
45X.Org X11 libXdmcp runtime library
46
47%package -n compat32-%{name}-devel
48Summary: X.Org X11 libXdmcp development package
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53
54%description -n compat32-%{name}-devel
55X.Org X11 libXdmcp development package
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64%configure \
65%if ! %{with_static}
66        --disable-static
67%endif
68make
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75# We intentionally don't ship *.la files
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78# remove xml and txt file
79rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%post -n compat32-%{name} -p /sbin/ldconfig
88%postun -n compat32-%{name} -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%doc AUTHORS COPYING README ChangeLog
93%{_libdir}/libXdmcp.so.6
94%{_libdir}/libXdmcp.so.6.0.0
95
96%files devel
97%defattr(-,root,root,-)
98%dir %{_includedir}/X11/
99%{_includedir}/X11/Xdmcp.h
100%if %{with_static}
101%{_libdir}/libXdmcp.a
102%endif
103%{_libdir}/libXdmcp.so
104%{_libdir}/pkgconfig/xdmcp.pc
105
106# compat32
107%if %{build_compat32}
108%files -n compat32-%{name}
109%defattr(-,root,root,-)
110%{_libdir}/libXdmcp.so.6
111%{_libdir}/libXdmcp.so.6.0.0
112
113%files -n compat32-%{name}-devel
114%defattr(-,root,root,-)
115%if %{with_static}
116%{_libdir}/libXdmcp.a
117%endif
118%{_libdir}/libXdmcp.so
119%endif
120
121%changelog
122* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
123- rebuild with VineSeed environment
124
125* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
126- new upstream release
127- add BuildRequires: xorg-x11-util-macros
128
129* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
130- new upstream release
131
132* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
133- rebuild with rpm-4.8.1 for pkg-config file
134- fix typo
135
136* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
137- new upstream release
138
139* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-3
140- added compat32 package for x86_64 arch support
141
142* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
143- spec in utf-8
144
145* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
146- new versioning policy
147
148* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
149- initial build for Vine Linux
150
151* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-4
152- Rebuild for build id
153
154* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-3
155- Don't install INSTALL
156
157* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-2.fc7
158- libXdmcp-1.0.2-namespace-pollution.patch: Hide Xalloc and friends from the
159  dynamic linker.
160
161* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
162- Update to 1.0.2
163
164* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-2.1
165- rebuild
166
167* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
168- Added "BuildRequires: xorg-x11-proto-devel"
169- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xdmcp.pc
170- Replace "makeinstall" with "make install DESTDIR=..."
171- Remove package ownership of mandir/libdir/etc.
172
173* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
174- Update to 1.0.1
175
176* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
177- bump again for double-long bug on ppc(64)
178
179* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
180- rebuilt for new gcc4.1 snapshot and glibc changes
181
182* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
183- Bumped and rebuilt
184
185* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
186- Updated libXdmcp to version 1.0.0 from X11R7 RC4
187
188* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
189- Updated libXdmcp to version 0.99.2 from X11R7 RC3
190- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
191  that /usr/lib/X11 and /usr/include/X11 pre-exist.
192- Removed 'x' suffix from manpage directories to match RC3 upstream.
193
194* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
195- rebuilt
196
197* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
198- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
199- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
200
201* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
202- Update to libXdmcp-0.99.1 from X11R7 RC1 release.
203
204* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
205- Renamed package to remove xorg-x11 from the name due to unanimous decision
206  between developers.
207- Use Fedora Extras style BuildRoot tag.
208- Disable static library creation by default.
209- Add missing defattr to devel subpackage
210- Add missing documentation files to doc macro
211
212* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
213- Renamed package to prepend "xorg-x11" to the name for consistency with
214  the rest of the X11R7 packages.
215- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
216  subpackage to ensure the devel package matches the installed shared libs.
217- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
218  allow applications to use implementation agnostic dependencies.
219- Added post/postun scripts which call ldconfig.
220- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
221  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
222
223* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
224- Initial build.
Note: See TracBrowser for help on using the repository browser.