source: projects/specs/trunk/lib/libX/libXdmcp/libXdmcp-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXdmcp runtime library
4Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
5Name: libXdmcp
6Version: 1.0.3
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17Obsoletes: XFree86-libs, XOrg-libs
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
22
23%description
24X.Org X11 libXdmcp runtime library
25
26%package devel
27Summary: X.Org X11 libXdmcp development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXdmcp development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXdmcp runtime library
40Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXdmcp runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXdmcp development package
48Group: Development/Libraries
49Requires(pre): xorg-x11-filesystem
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52
53%description -n compat32-%{name}-devel
54X.Org X11 libXdmcp development package
55
56%prep
57%setup -q
58
59# Disable static library creation by default.
60%define with_static 0
61
62%build
63%configure \
64%if ! %{with_static}
65        --disable-static
66%endif
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install DESTDIR=$RPM_BUILD_ROOT
73
74# We intentionally don't ship *.la files
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%post -n compat32-%{name} -p /sbin/ldconfig
84%postun -n compat32-%{name} -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc AUTHORS COPYING README ChangeLog
89%{_libdir}/libXdmcp.so.6
90%{_libdir}/libXdmcp.so.6.0.0
91
92%files devel
93%defattr(-,root,root,-)
94%dir %{_includedir}/X11/
95%{_includedir}/X11/Xdmcp.h
96%if %{with_static}
97%{_libdir}/libXdmcp.a
98%endif
99%{_libdir}/libXdmcp.so
100%{_libdir}/pkgconfig/xdmcp.pc
101
102# compat32
103%if %{build_compat32}
104%files -n compat32-%{name}
105%defattr(-,root,root,-)
106%{_libdir}/libXdmcp.so.6
107%{_libdir}/libXdmcp.so.6.0.0
108
109%files -n compat32-%{name}-devel
110%defattr(-,root,root,-)
111%if %{with_static}
112%{_libdir}/libXdmcp.a
113%endif
114%{_libdir}/libXdmcp.so
115%{_libdir}/pkgconfig/xdmcp.pc
116%endif
117
118%changelog
119* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-1
120- new upstream release
121
122* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-3
123- added compat32 package for x86_64 arch support
124
125* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
126- spec in utf-8
127
128* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
129- new versioning policy
130
131* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
132- initial build for Vine Linux
133
134* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-4
135- Rebuild for build id
136
137* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-3
138- Don't install INSTALL
139
140* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-2.fc7
141- libXdmcp-1.0.2-namespace-pollution.patch: Hide Xalloc and friends from the
142  dynamic linker.
143
144* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
145- Update to 1.0.2
146
147* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-2.1
148- rebuild
149
150* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
151- Added "BuildRequires: xorg-x11-proto-devel"
152- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xdmcp.pc
153- Replace "makeinstall" with "make install DESTDIR=..."
154- Remove package ownership of mandir/libdir/etc.
155
156* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
157- Update to 1.0.1
158
159* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
160- bump again for double-long bug on ppc(64)
161
162* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
163- rebuilt for new gcc4.1 snapshot and glibc changes
164
165* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
166- Bumped and rebuilt
167
168* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
169- Updated libXdmcp to version 1.0.0 from X11R7 RC4
170
171* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
172- Updated libXdmcp to version 0.99.2 from X11R7 RC3
173- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
174  that /usr/lib/X11 and /usr/include/X11 pre-exist.
175- Removed 'x' suffix from manpage directories to match RC3 upstream.
176
177* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
178- rebuilt
179
180* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
181- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
182- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
183
184* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
185- Update to libXdmcp-0.99.1 from X11R7 RC1 release.
186
187* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
188- Renamed package to remove xorg-x11 from the name due to unanimous decision
189  between developers.
190- Use Fedora Extras style BuildRoot tag.
191- Disable static library creation by default.
192- Add missing defattr to devel subpackage
193- Add missing documentation files to doc macro
194
195* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
196- Renamed package to prepend "xorg-x11" to the name for consistency with
197  the rest of the X11R7 packages.
198- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
199  subpackage to ensure the devel package matches the installed shared libs.
200- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
201  allow applications to use implementation agnostic dependencies.
202- Added post/postun scripts which call ldconfig.
203- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
204  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
205
206* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
207- Initial build.
Note: See TracBrowser for help on using the repository browser.