source: projects/specs/trunk/lib/libX/libXcursor/libXcursor-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXcursor runtime library
4Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
5Name: libXcursor
6Version: 1.1.10
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: xorg-x11-proto-devel
18BuildRequires: libX11-devel
19BuildRequires: libXfixes-devel
20BuildRequires: libXrender-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23%description
24X.Org X11 libXcursor runtime library
25
26%package devel
27Summary: X.Org X11 libXcursor development package
28Summary(ja): X.Org X11 libXcursor 開発パッケージ
29Group: Development/Libraries
30Requires(pre): xorg-x11-filesystem
31Requires: %{name} = %{version}-%{release}
32Requires: pkgconfig
33Requires: xorg-x11-proto-devel
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libXcursor development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libXcursor runtime library
42Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46X.Org X11 libXcursor runtime library
47
48%package -n compat32-%{name}-devel
49Summary: X.Org X11 libXcursor development package
50Summary(ja): X.Org X11 libXcursor 開発パッケージ
51Group: Development/Libraries
52Requires(pre): xorg-x11-filesystem
53Requires: compat32-%{name} = %{version}-%{release}
54Requires: %{name}-devel = %{version}-%{release}
55
56%description -n compat32-%{name}-devel
57X.Org X11 libXcursor development package
58
59%prep
60%setup -q
61
62# Disable static library creation by default.
63%define with_static 0
64
65%build
66#export CFLAGS="$RPM_OPT_FLAGS -DICONDIR=\"/usr/share/icons\""
67%configure \
68%if ! %{with_static}
69        --disable-static
70%endif
71make
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install DESTDIR=$RPM_BUILD_ROOT
77
78mkdir -p $RPM_BUILD_ROOT/usr/share/icons/default
79cat <<EOF > $RPM_BUILD_ROOT/usr/share/icons/default/index.theme
80[Icon Theme]
81Inherits=Vine
82EOF
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc AUTHORS COPYING README ChangeLog
99%{_libdir}/libXcursor.so.1
100%{_libdir}/libXcursor.so.1.0.*
101%dir %{_datadir}/icons/default
102%config(noreplace) %verify(not md5 size mtime) %{_datadir}/icons/default/index.theme
103
104%files devel
105%defattr(-,root,root,-)
106%dir %{_includedir}/X11
107%dir %{_includedir}/X11/Xcursor
108%{_includedir}/X11/Xcursor/Xcursor.h
109%if %{with_static}
110%{_libdir}/libXcursor.a
111%endif
112%{_libdir}/libXcursor.so
113%{_libdir}/pkgconfig/xcursor.pc
114#%dir %{_mandir}/man3x
115%{_mandir}/man3/Xcursor*.3*
116
117# compat32
118%if %{build_compat32}
119%files -n compat32-%{name}
120%defattr(-,root,root,-)
121%{_libdir}/libXcursor.so.1
122%{_libdir}/libXcursor.so.1.0.*
123
124%files -n compat32-%{name}-devel
125%defattr(-,root,root,-)
126%if %{with_static}
127%{_libdir}/libXcursor.a
128%endif
129%{_libdir}/libXcursor.so
130%{_libdir}/pkgconfig/xcursor.pc
131%endif
132
133%changelog
134* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1
135- new upstream release
136
137* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.9-3
138- added compat32 package for x86_64 arch support
139
140* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-2
141- set default cursor theme to Vine
142- spec in utf8
143
144* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
145- new versioning policy
146
147* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-0vl1
148- initial build for Vine Linux
149
150* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.1.9-1
151- libXcursor 1.1.9
152
153* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.1.8-3
154- Rebuild for PPC toolchain bug
155
156* Sat Jul  7 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-3
157- Don't own /usr/share/icons
158- Require pkgconfig in -devel
159
160* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-2
161- Don't install INSTALL
162
163* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.1.8-1
164- Update to 1.1.8
165
166* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.1.7-1.1
167- rebuild
168
169* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.7-1
170- Update to 1.1.7 from X11R7.1
171
172* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.6-2
173- Added "BuildRequires: xorg-x11-proto-devel"
174- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xcursor.pc
175- Replace "makeinstall" with "make install DESTDIR=..."
176- Remove package ownership of mandir/libdir/etc.
177
178* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.1.6-1
179- Update to 1.1.6
180
181* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.2
182- bump again for double-long bug on ppc(64)
183
184* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.1
185- rebuilt for new gcc4.1 snapshot and glibc changes
186
187* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.1.5.2-2
188- Bumped and rebuilt
189
190* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.2-1
191- Updated libXcursor to version 1.1.5.2 from X11R7 RC4
192
193* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.1-1
194- Updated libXcursor to version 1.1.5.1 from X11R7 RC3
195- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
196  that /usr/lib/X11 and /usr/include/X11 pre-exist.
197- Removed 'x' suffix from manpage directories to match RC3 upstream.
198- Added default index.theme file to set BlueCurve as the default cursor theme
199  to fix bug (#175532).
200
201* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
202- rebuilt
203
204* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1.1.5-1
205- Updated libXcursor to version 1.1.5 from X11R7 RC2
206- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
207- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
208
209* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 1.1.4-1
210- Updated libXcursor to version 1.1.4 from X11R7 RC1
211
212* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-3
213- Renamed package to remove xorg-x11 from the name due to unanimous decision
214  between developers.
215- Use Fedora Extras style BuildRoot tag.
216- Disable static library creation by default.
217- Add missing defattr to devel subpackage
218- Add missing documentation files to doc macro
219
220* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-2
221- Renamed package to prepend "xorg-x11" to the name for consistency with
222  the rest of the X11R7 packages.
223- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
224  subpackage to ensure the devel package matches the installed shared libs.
225- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
226  allow applications to use implementation agnostic dependencies.
227- Added post/postun scripts which call ldconfig.
228- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
229  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
230
231* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-1
232- Initial build.
Note: See TracBrowser for help on using the repository browser.