source: projects/specs/trunk/lib/libX/libXcursor/libXcursor-vl.spec @ 8064

Revision 8064, 7.6 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXcursor runtime library
4Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
5Name: libXcursor
6Version: 1.1.14
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: xorg-x11-proto-devel
18BuildRequires: libX11-devel
19BuildRequires: libXfixes-devel
20BuildRequires: libXrender-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28X.Org X11 libXcursor runtime library
29
30%package devel
31Summary: X.Org X11 libXcursor development package
32Summary(ja): X.Org X11 libXcursor 開発パッケージ
33Group: Development/Libraries
34Requires(pre): xorg-x11-filesystem
35Requires: %{name} = %{version}-%{release}
36Requires: pkgconfig
37Requires: xorg-x11-proto-devel
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXcursor development package
42
43# compat32
44%package -n compat32-%{name}
45Summary: X.Org X11 libXcursor runtime library
46Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
47Group: System Environment/Libraries
48
49%description -n compat32-%{name}
50X.Org X11 libXcursor runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXcursor development package
54Summary(ja): X.Org X11 libXcursor 開発パッケージ
55Group: Development/Libraries
56Requires(pre): xorg-x11-filesystem
57Requires: compat32-%{name} = %{version}-%{release}
58Requires: %{name}-devel = %{version}-%{release}
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXcursor development package
62
63%prep
64%setup -q
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70#export CFLAGS="$RPM_OPT_FLAGS -DICONDIR=\"/usr/share/icons\""
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82mkdir -p $RPM_BUILD_ROOT/usr/share/icons/default
83cat <<EOF > $RPM_BUILD_ROOT/usr/share/icons/default/index.theme
84[Icon Theme]
85Inherits=Vine
86EOF
87
88# We intentionally don't ship *.la files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc AUTHORS COPYING README ChangeLog
103%{_libdir}/libXcursor.so.1
104%{_libdir}/libXcursor.so.1.0.*
105%dir %{_datadir}/icons/default
106%config(noreplace) %verify(not md5 size mtime) %{_datadir}/icons/default/index.theme
107
108%files devel
109%defattr(-,root,root,-)
110%dir %{_includedir}/X11
111%dir %{_includedir}/X11/Xcursor
112%{_includedir}/X11/Xcursor/Xcursor.h
113%if %{with_static}
114%{_libdir}/libXcursor.a
115%endif
116%{_libdir}/libXcursor.so
117%{_libdir}/pkgconfig/xcursor.pc
118#%dir %{_mandir}/man3x
119%{_mandir}/man3/Xcursor*.3*
120
121# compat32
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root,-)
125%{_libdir}/libXcursor.so.1
126%{_libdir}/libXcursor.so.1.0.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root,-)
130%if %{with_static}
131%{_libdir}/libXcursor.a
132%endif
133%{_libdir}/libXcursor.so
134%{_libdir}/pkgconfig/xcursor.pc
135%endif
136
137%changelog
138* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.14-2
139- rebuild with VineSeed environment
140
141* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.14-1
142- new upstream release
143  (including security fix for CVE-2013-2003)
144
145* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.13-1
146- new upstream release
147
148* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.12-1
149- new upstream release
150
151* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.11-1
152- new upstream release
153
154* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.10-2
155- rebuild with rpm-4.8.1 for pkg-config file
156
157* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1
158- new upstream release
159
160* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.9-3
161- added compat32 package for x86_64 arch support
162
163* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-2
164- set default cursor theme to Vine
165- spec in utf8
166
167* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
168- new versioning policy
169
170* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-0vl1
171- initial build for Vine Linux
172
173* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.1.9-1
174- libXcursor 1.1.9
175
176* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.1.8-3
177- Rebuild for PPC toolchain bug
178
179* Sat Jul  7 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-3
180- Don't own /usr/share/icons
181- Require pkgconfig in -devel
182
183* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-2
184- Don't install INSTALL
185
186* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.1.8-1
187- Update to 1.1.8
188
189* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.1.7-1.1
190- rebuild
191
192* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.7-1
193- Update to 1.1.7 from X11R7.1
194
195* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.6-2
196- Added "BuildRequires: xorg-x11-proto-devel"
197- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xcursor.pc
198- Replace "makeinstall" with "make install DESTDIR=..."
199- Remove package ownership of mandir/libdir/etc.
200
201* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.1.6-1
202- Update to 1.1.6
203
204* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.2
205- bump again for double-long bug on ppc(64)
206
207* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.1
208- rebuilt for new gcc4.1 snapshot and glibc changes
209
210* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.1.5.2-2
211- Bumped and rebuilt
212
213* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.2-1
214- Updated libXcursor to version 1.1.5.2 from X11R7 RC4
215
216* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.1-1
217- Updated libXcursor to version 1.1.5.1 from X11R7 RC3
218- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
219  that /usr/lib/X11 and /usr/include/X11 pre-exist.
220- Removed 'x' suffix from manpage directories to match RC3 upstream.
221- Added default index.theme file to set BlueCurve as the default cursor theme
222  to fix bug (#175532).
223
224* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
225- rebuilt
226
227* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1.1.5-1
228- Updated libXcursor to version 1.1.5 from X11R7 RC2
229- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
230- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
231
232* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 1.1.4-1
233- Updated libXcursor to version 1.1.4 from X11R7 RC1
234
235* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-3
236- Renamed package to remove xorg-x11 from the name due to unanimous decision
237  between developers.
238- Use Fedora Extras style BuildRoot tag.
239- Disable static library creation by default.
240- Add missing defattr to devel subpackage
241- Add missing documentation files to doc macro
242
243* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-2
244- Renamed package to prepend "xorg-x11" to the name for consistency with
245  the rest of the X11R7 packages.
246- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
247  subpackage to ensure the devel package matches the installed shared libs.
248- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
249  allow applications to use implementation agnostic dependencies.
250- Added post/postun scripts which call ldconfig.
251- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
252  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
253
254* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-1
255- Initial build.
Note: See TracBrowser for help on using the repository browser.