source: projects/specs/trunk/lib/libX/libXau/libXau-vl.spec @ 8064

Revision 8064, 6.7 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXau runtime library
4Summary(ja): X.Org X11 libXau ランタイムライブラリ
5Name: libXau
6Version: 1.0.8
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18Obsoletes: XFree86-libs, XOrg-libs
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: Takemikaduchi
23
24%description
25X.Org X11 libXau runtime library
26
27%package devel
28Summary: X.Org X11 libXau development package
29Group: Development/Libraries
30Requires(pre): xorg-x11-filesystem
31Requires: %{name} = %{version}-%{release}
32
33# xorg-x11-proto-devel needed by xau.pc
34BuildRequires: xorg-x11-proto-devel
35
36Obsoletes: XFree86-devel, XOrg-devel
37
38%description devel
39X.Org X11 libXau development package
40
41# compat32
42%package -n compat32-%{name}
43Summary: X.Org X11 libXau runtime library
44Summary(ja): X.Org X11 libXau ランタイムライブラリ
45Group: System Environment/Libraries
46
47%description -n compat32-%{name}
48X.Org X11 libXau runtime library
49
50%package -n compat32-%{name}-devel
51Summary: X.Org X11 libXau development package
52Group: Development/Libraries
53Requires(pre): xorg-x11-filesystem
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: %{name}-devel = %{version}-%{release}
56
57%description -n compat32-%{name}-devel
58X.Org X11 libXau development package
59
60%prep
61%setup -q
62
63# Disable static library creation by default.
64%define with_static 0
65
66%build
67
68%configure \
69%if ! %{with_static}
70        --disable-static
71%endif
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77make install DESTDIR=$RPM_BUILD_ROOT
78
79# We intentionally don't ship *.la files
80rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%post -n compat32-%{name} -p /sbin/ldconfig
89%postun -n compat32-%{name} -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHORS COPYING README ChangeLog
94%{_libdir}/libXau.so.6
95%{_libdir}/libXau.so.6.0.0
96
97%files devel
98%defattr(-,root,root,-)
99%dir %{_includedir}/X11
100%{_includedir}/X11/Xauth.h
101%if %{with_static}
102%{_libdir}/libXau.a
103%endif
104%{_libdir}/libXau.so
105%{_libdir}/pkgconfig/xau.pc
106#%dir %{_mandir}/man3x
107%{_mandir}/man3/*.3*
108
109# compat32
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-,root,root,-)
113%{_libdir}/libXau.so.6
114%{_libdir}/libXau.so.6.0.0
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root,-)
118%if %{with_static}
119%{_libdir}/libXau.a
120%endif
121%{_libdir}/libXau.so
122%endif
123
124%changelog
125* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
126- rebuild with VineSeed environment
127
128* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
129- new upstream release
130
131* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
132- new upstream release
133- add BuildRequires: xorg-x11-util-macros
134
135* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-2
136- rebuild with rpm-4.8.1 for pkg-config file
137
138* Sat Jul 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
139- new upstream release
140
141* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
142- new upstream release
143
144* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
145- added compat32 package for x86_64 arch support
146
147* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
148- new upstream release
149
150* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
151- new versioning policy
152
153* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
154- initial build for Vine Linux
155
156* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
157- Rebuild for build id
158
159* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
160- Don't install INSTALL
161
162* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
163- Update to 1.0.3
164
165* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
166- Update to 1.0.2
167
168* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
169- rebuild
170
171* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
172- Remove package ownership of mandir/libdir/etc.
173- Added "BuildRequires: xorg-x11-proto-devel" needed by xau.pc
174
175* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
176- Added "BuildRequires: pkgconfig" for (#193422)
177- Replace "makeinstall" with "make install DESTDIR=..." to fix (#192718)
178
179* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
180- Bump to 1.0.1
181
182* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
183- bump again for double-long bug on ppc(64)
184
185* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
186- rebuilt for new gcc4.1 snapshot and glibc changes
187
188* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
189- Bumped and rebuilt
190
191* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
192- Updated libXau to version 1.0.0 from X11R7 RC4
193
194* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
195- Updated libXau to version 0.99.2 from X11R7 RC3
196- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
197  that /usr/lib/X11 and /usr/include/X11 pre-exist.
198- Removed 'x' suffix from manpage directories to match RC3 upstream.
199
200* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
201- rebuilt
202
203* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
204- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
205- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
206
207* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
208- Update to libXau-0.99.1 from X11R7 RC1 release.
209- Added manpages that were absent in X11R7 RC0, and updated the file lists
210  to find them in section "man3x".
211
212* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
213- Renamed package to remove xorg-x11 from the name due to unanimous decision
214  between developers.
215- Use Fedora Extras style BuildRoot tag.
216- Disable static library creation by default.
217- Add missing defattr to devel subpackage
218- Add missing documentation files to doc macro
219
220* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
221- Renamed package to prepend "xorg-x11" to the name for consistency with
222  the rest of the X11R7 packages.
223- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
224  subpackage to ensure the devel package matches the installed shared libs.
225- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
226  allow applications to use implementation agnostic dependencies.
227- Added post/postun scripts which call ldconfig.
228- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
229  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
230
231* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
232- Initial build.
Note: See TracBrowser for help on using the repository browser.