source: projects/specs/trunk/lib/libX/libXScrnSaver/libXScrnSaver-vl.spec @ 8064

Revision 8064, 7.7 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXss runtime library
4Summary(ja): X.Org X11 libXss ランタイムライブラリ
5Name: libXScrnSaver
6Version: 1.2.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libXext-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27X.Org X11 libXss runtime library
28
29%package devel
30Summary: X.Org X11 libXScrnSaver development package
31Summary(ja): X.Org X11 libXScrnSaver 開発パッケージ
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires(pre): xorg-x11-filesystem
35Requires: xorg-x11-proto-devel
36Requires: libX11-devel
37Requires: libXext-devel
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXss development package
42
43# compat32
44%package -n compat32-%{name}
45Summary: X.Org X11 libXss runtime library
46Summary(ja): X.Org X11 libXss ランタイムライブラリ
47Group: System Environment/Libraries
48
49%description -n compat32-%{name}
50X.Org X11 libXss runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXss development package
54Summary(ja): X.Org X11 libXss 開発パッケージ
55Group: Development/Libraries
56Requires(pre): xorg-x11-filesystem
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: compat32-libX11-devel, compat32-libXext-devel
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXss development package
63
64%prep
65%setup -q
66
67# Disable static library creation by default.
68%define with_static 0
69
70%build
71# FIXME: XScrnSaver.c:429: warning: dereferencing type-punned pointer will break strict-aliasing rules
72export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
73%configure \
74%if ! %{with_static}
75        --disable-static
76%endif
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc COPYING README ChangeLog
99%{_libdir}/libXss.so.1
100%{_libdir}/libXss.so.1.*
101
102%files devel
103%defattr(-,root,root,-)
104%{_includedir}/X11/extensions/*.h
105%if %{with_static}
106%{_libdir}/libXss.a
107%endif
108%{_libdir}/libXss.so
109%dir %{_libdir}/pkgconfig
110%{_libdir}/pkgconfig/xscrnsaver.pc
111%{_mandir}/man3/*.3*
112
113%if %{build_compat32}
114%files -n compat32-%{name}
115%defattr(-,root,root,-)
116%{_libdir}/libXss.so.*
117
118%files -n compat32-%{name}-devel
119%defattr(-,root,root,-)
120%{_libdir}/libXss.so
121%endif
122
123%changelog
124* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
125- rebuild with VineSeed environment
126
127* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
128- new upstream release
129- add BuildRequires: xorg-x11-util-macros
130
131* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
132- new upstream release
133
134* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-3
135- rebuild with rpm-4.8.1 for pkg-config file
136
137* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-2
138- add scrnsaver.h
139
140* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
141- new upstream release
142
143* Mon Aug 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-2
144- add compat32 package for x86_64 arch support
145
146* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
147- new upstream release
148
149* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
150- new versioning policy
151
152* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-0vl1
153- initial build for Vine Linux
154
155* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.1.2-3
156- Rebuild for build id
157
158* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.1.2-2
159- Don't install INSTALL
160
161* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.1.2-1
162- Update to 1.1.2
163
164* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.1.1-1
165- Update to 1.1.1
166
167* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.1.0-3.1
168- rebuild
169
170* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.0-3
171- Update build dep to "xorg-x11-proto-devel >= 7.0-9" for scrnsaverproto 1.1
172- Added "Requires: xorg-x11-proto-devel >= 7.0-9" to devel package, to match
173  what is listed as required in xscrnsaver.pc
174
175* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.1.0-2
176- Added "BuildRequires: pkgconfig" for (#193424)
177- Replace "makeinstall" with "make install DESTDIR=..."
178- Remove package ownership of mandir/libdir/etc.
179
180* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.1.0-1
181- Update to 1.1.0, new Suspend request.
182
183* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-1.2
184- bump again for double-long bug on ppc(64)
185
186* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-1.1
187- rebuilt for new gcc4.1 snapshot and glibc changes
188
189* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
190- Updated libXScrnSaver to version 1.0.1 from X11R7.0
191
192* Mon Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
193- Added "Requires: libX11-devel, libXext-devel" to work around bug (#176674).
194
195* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
196- Updated libXScrnSaver to version 1.0.0 from X11R7 RC4
197
198* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
199- Updated libXScrnSaver to version 0.99.3 from X11R7 RC3
200- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
201  that /usr/lib/X11 and /usr/include/X11 pre-exist.
202- Removed 'x' suffix from manpage directories to match RC3 upstream.
203
204* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
205- rebuilt
206
207* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
208- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
209- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
210
211* Wed Nov 2 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
212- Actually spell RPM_OPT_FLAGS correctly this time.
213
214* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
215- Build with -fno-strict-aliasing to work around possible pointer aliasing
216  issue
217
218* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
219- Updated libXScrnSaver to version 0.99.2 from X11R7 RC1
220- Updated file manifest to find manpages in "man3x"
221
222* Mon Oct  3 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
223- Updated to new upstream libXScrnSaver-0.99.1 which changes the .so name back
224  to libXss, but keeps the inconsistent package name.  This may change again
225  in the future.
226
227* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
228- Renamed package to remove xorg-x11 from the name due to unanimous decision
229  between developers.
230- Use Fedora Extras style BuildRoot tag.
231- Disable static library creation by default.
232- Add missing defattr to devel subpackage
233- Add missing documentation files to doc macro
234
235* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
236- Renamed package to prepend "xorg-x11" to the name for consistency with
237  the rest of the X11R7 packages.
238- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
239  subpackage to ensure the devel package matches the installed shared libs.
240- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
241  allow applications to use implementation agnostic dependencies.
242- Added post/postun scripts which call ldconfig.
243- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
244  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
245
246* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
247- Initial build.
Note: See TracBrowser for help on using the repository browser.