source: projects/specs/trunk/lib/libS/libSM/libSM-vl.spec @ 8064

Revision 8064, 7.1 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libSM runtime library
4Summary(ja): X.Org X11 libSM ランタイムライブラリ
5Name: libSM
6Version: 1.2.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-xtrans-devel >= 1.0.3
18BuildRequires: libICE-devel
19BuildRequires: e2fsprogs-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27X.Org X11 libSM runtime library
28
29%package devel
30Summary: X.Org X11 libSM development package
31Group: Development/Libraries
32Requires(pre): xorg-x11-filesystem >= 0.99.2
33Requires: %{name} = %{version}-%{release}
34Requires: libICE-devel
35Requires: xorg-x11-proto-devel
36Obsoletes: XFree86-devel, XOrg-devel
37
38%description devel
39X.Org X11 libSM development package
40
41# compat32
42%package -n compat32-%{name}
43Summary: X.Org X11 libSM runtime library
44Summary(ja): X.Org X11 libSM ランタイムライブラリ
45Group: System Environment/Libraries
46
47%description -n compat32-%{name}
48X.Org X11 libSM runtime library
49
50%package -n compat32-%{name}-devel
51Summary: X.Org X11 libSM development package
52Group: Development/Libraries
53Requires(pre): xorg-x11-filesystem >= 0.99.2
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: %{name}-devel = %{version}-%{release}
56Requires: compat32-libICE-devel
57
58%description -n compat32-%{name}-devel
59X.Org X11 libSM development package
60
61%prep
62%setup -q
63
64# Disable static library creation by default.
65%define with_static 0
66
67%build
68
69%configure \
70%if ! %{with_static}
71        --disable-static
72%endif
73make
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install DESTDIR=$RPM_BUILD_ROOT
79
80# We intentionally don't ship *.la files
81rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
82
83# remove xml and txt file
84rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%post -n compat32-%{name} -p /sbin/ldconfig
93%postun -n compat32-%{name} -p /sbin/ldconfig
94
95%files
96%defattr(-,root,root,-)
97%doc AUTHORS COPYING README ChangeLog
98%{_libdir}/libSM.so.6
99%{_libdir}/libSM.so.6.0.*
100
101%files devel
102%defattr(-,root,root,-)
103%dir %{_includedir}/X11
104%dir %{_includedir}/X11/SM
105%{_includedir}/X11/SM/SM.h
106%{_includedir}/X11/SM/SMlib.h
107%{_includedir}/X11/SM/SMproto.h
108%if %{with_static}
109%{_libdir}/libSM.a
110%endif
111%{_libdir}/libSM.so
112%{_libdir}/pkgconfig/sm.pc
113
114# compat32
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root,-)
118%{_libdir}/libSM.so.6
119%{_libdir}/libSM.so.6.0.*
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root,-)
123%if %{with_static}
124%{_libdir}/libSM.a
125%endif
126%{_libdir}/libSM.so
127%endif
128
129%changelog
130* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
131- rebuild with VineSeed environment
132
133* Mon Sep 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
134- new upstream release
135
136* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
137- new upstream release
138
139* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
140- new upstream release
141
142* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.1-2
143- build with rpm-4.8.1-1 for pkg-config file
144
145* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
146- new upstream release
147
148* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.0-2
149- added compat32 package for x86_64 arch support
150
151* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
152- new upstream release
153
154* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
155- new versioning policy
156
157* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
158- initial build for Vine Linux
159
160* Thu Sep 20 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
161- Update xtrans dep and rebuild.
162
163* Mon Sep 17 2007 Adam Jackson <ajax@redhat.com> 1.0.2-3
164- Rebuild for abstract socket support.
165
166* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-2
167- Rebuild for build id
168
169* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-2
170- Don't install INSTALL
171
172* Mon Nov 20 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
173- Update to 1.0.2
174
175* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
176- rebuild
177
178* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
179- Added "Requires: xorg-x11-proto-devel" to devel package.
180
181* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
182- Added "BuildRequires: pkgconfig" for (#193421)
183- Replace "makeinstall" with "make install DESTDIR=..."
184
185* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
186- Update to 1.0.1
187
188* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
189- bump again for double-long bug on ppc(64)
190
191* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
192- rebuilt for new gcc4.1 snapshot and glibc changes
193
194* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
195- Bumped and rebuilt
196
197* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
198- Updated libSM to version 1.0.0 from X11R7 RC4
199
200* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
201- Updated libSM to version 0.99.3 from X11R7 RC3
202- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
203  that /usr/lib/X11 and /usr/include/X11 pre-exist.
204- Removed 'x' suffix from manpage directories to match RC3 upstream.
205
206* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
207- rebuilt
208
209* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
210- Updated libSM to version 0.99.2 from X11R7 RC2
211- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
212- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
213
214* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
215- Updated libSM to version 0.99.1 from X11R7 RC1
216
217* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
218- Renamed package to remove xorg-x11 from the name due to unanimous decision
219  between developers.
220- Use Fedora Extras style BuildRoot tag.
221- Disable static library creation by default.
222- Add missing defattr to devel subpackage
223- Add missing documentation files to doc macro
224
225* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
226- Renamed package to remove "xorg-x11" from the name due to unanimous decision
227  between developers.
228- Use Fedora Extras style BuildRoot tag.
229- Disable static library creation by default.
230- Add missing defattr to devel subpackage
231- Add missing documentation files to doc macro
232
233* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
234- Renamed package to prepend "xorg-x11" to the name for consistency with
235  the rest of the X11R7 packages.
236- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
237  subpackage to ensure the devel package matches the installed shared libs.
238- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
239  allow applications to use implementation agnostic dependencies.
240- Added post/postun scripts which call ldconfig.
241- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
242  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
243
244* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
245- Initial build.
Note: See TracBrowser for help on using the repository browser.