source: projects/specs/trunk/lib/libS/libSM/libSM-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libSM runtime library
4Summary(ja): X.Org X11 libSM ランタイムライブラリ
5Name: libSM
6Version: 1.1.1
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-xtrans-devel >= 1.0.3
18BuildRequires: libICE-devel
19BuildRequires: e2fsprogs-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libSM runtime library
24
25%package devel
26Summary: X.Org X11 libSM development package
27Group: Development/Libraries
28Requires(pre): xorg-x11-filesystem >= 0.99.2
29Requires: %{name} = %{version}-%{release}
30Requires: libICE-devel
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libSM development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libSM runtime library
40Summary(ja): X.Org X11 libSM ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libSM runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libSM development package
48Group: Development/Libraries
49Requires(pre): xorg-x11-filesystem >= 0.99.2
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52Requires: compat32-libICE-devel
53
54%description -n compat32-%{name}-devel
55X.Org X11 libSM development package
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64
65%configure \
66%if ! %{with_static}
67        --disable-static
68%endif
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# We intentionally don't ship *.la files
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83%postun -p /sbin/ldconfig
84
85%post -n compat32-%{name} -p /sbin/ldconfig
86%postun -n compat32-%{name} -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root,-)
90%doc AUTHORS COPYING README ChangeLog
91%{_libdir}/libSM.so.6
92%{_libdir}/libSM.so.6.0.*
93
94%files devel
95%defattr(-,root,root,-)
96%dir %{_includedir}/X11
97%dir %{_includedir}/X11/SM
98%{_includedir}/X11/SM/SM.h
99%{_includedir}/X11/SM/SMlib.h
100%{_includedir}/X11/SM/SMproto.h
101%if %{with_static}
102%{_libdir}/libSM.a
103%endif
104%{_libdir}/libSM.so
105%{_libdir}/pkgconfig/sm.pc
106
107# compat32
108%if %{build_compat32}
109%files -n compat32-%{name}
110%defattr(-,root,root,-)
111%{_libdir}/libSM.so.6
112%{_libdir}/libSM.so.6.0.*
113
114%files -n compat32-%{name}-devel
115%defattr(-,root,root,-)
116%if %{with_static}
117%{_libdir}/libSM.a
118%endif
119%{_libdir}/libSM.so
120%{_libdir}/pkgconfig/sm.pc
121%endif
122
123%changelog
124* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
125- new upstream release
126
127* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.0-2
128- added compat32 package for x86_64 arch support
129
130* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
131- new upstream release
132
133* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
134- new versioning policy
135
136* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
137- initial build for Vine Linux
138
139* Thu Sep 20 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
140- Update xtrans dep and rebuild.
141
142* Mon Sep 17 2007 Adam Jackson <ajax@redhat.com> 1.0.2-3
143- Rebuild for abstract socket support.
144
145* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-2
146- Rebuild for build id
147
148* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-2
149- Don't install INSTALL
150
151* Mon Nov 20 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
152- Update to 1.0.2
153
154* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
155- rebuild
156
157* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
158- Added "Requires: xorg-x11-proto-devel" to devel package.
159
160* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
161- Added "BuildRequires: pkgconfig" for (#193421)
162- Replace "makeinstall" with "make install DESTDIR=..."
163
164* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
165- Update to 1.0.1
166
167* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
168- bump again for double-long bug on ppc(64)
169
170* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
171- rebuilt for new gcc4.1 snapshot and glibc changes
172
173* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
174- Bumped and rebuilt
175
176* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
177- Updated libSM to version 1.0.0 from X11R7 RC4
178
179* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
180- Updated libSM to version 0.99.3 from X11R7 RC3
181- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
182  that /usr/lib/X11 and /usr/include/X11 pre-exist.
183- Removed 'x' suffix from manpage directories to match RC3 upstream.
184
185* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
186- rebuilt
187
188* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
189- Updated libSM to version 0.99.2 from X11R7 RC2
190- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
191- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
192
193* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
194- Updated libSM to version 0.99.1 from X11R7 RC1
195
196* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
197- Renamed package to remove xorg-x11 from the name due to unanimous decision
198  between developers.
199- Use Fedora Extras style BuildRoot tag.
200- Disable static library creation by default.
201- Add missing defattr to devel subpackage
202- Add missing documentation files to doc macro
203
204* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
205- Renamed package to remove "xorg-x11" from the name due to unanimous decision
206  between developers.
207- Use Fedora Extras style BuildRoot tag.
208- Disable static library creation by default.
209- Add missing defattr to devel subpackage
210- Add missing documentation files to doc macro
211
212* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
213- Renamed package to prepend "xorg-x11" to the name for consistency with
214  the rest of the X11R7 packages.
215- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
216  subpackage to ensure the devel package matches the installed shared libs.
217- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
218  allow applications to use implementation agnostic dependencies.
219- Added post/postun scripts which call ldconfig.
220- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
221  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
222
223* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
224- Initial build.
Note: See TracBrowser for help on using the repository browser.