source: projects/specs/trunk/lib/libI/libICE/libICE-vl.spec @ 8064

Revision 8064, 6.8 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libICE runtime library
4Summary(ja): X.Org X11 libICE ランタイムライブラリ
5Name: libICE
6Version: 1.0.8
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-xtrans-devel
18BuildRequires: xorg-x11-util-macros
19Obsoletes: XFree86-libs, XOrg-libs
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: Takemikaduchi
24
25%description
26X.Org X11 libICE runtime library
27
28%package devel
29Summary: X.Org X11 libICE development package
30Group: Development/Libraries
31Requires(pre): xorg-x11-filesystem
32Requires: %{name} = %{version}-%{release}
33Requires: xorg-x11-proto-devel
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libICE development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libICE runtime library
42Summary(ja): X.Org X11 libICE ランタイムライブラリ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46X.Org X11 libICE runtime library
47
48%package -n compat32-%{name}-devel
49Summary: X.Org X11 libICE development package
50Group: Development/Libraries
51Requires(pre): xorg-x11-filesystem
52Requires: compat32-%{name} = %{version}-%{release}
53Requires: %{name}-devel = %{version}-%{release}
54
55%description -n compat32-%{name}-devel
56X.Org X11 libICE development package
57
58%prep
59%setup -q
60
61# Disable static library creation by default.
62%define with_static 0
63
64%build
65%configure \
66%if ! %{with_static}
67       --disable-static
68%endif
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# We intentionally don't ship *.la files
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78
79# remove xml and txt file
80rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%post -n compat32-%{name} -p /sbin/ldconfig
89%postun -n compat32-%{name} -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHORS COPYING README ChangeLog
94%{_libdir}/libICE.so.6
95%{_libdir}/libICE.so.6.3.0
96
97%files devel
98%dir %{_includedir}/X11
99%dir %{_includedir}/X11/ICE
100%{_includedir}/X11/ICE/*.h
101%if %{with_static}
102%{_libdir}/libICE.a
103%endif
104%{_libdir}/libICE.so
105%{_libdir}/pkgconfig/ice.pc
106
107# compat32
108%if %{build_compat32}
109%files -n compat32-%{name}
110%defattr(-,root,root,-)
111%{_libdir}/libICE.so.6
112%{_libdir}/libICE.so.6.3.0
113
114%files  -n compat32-%{name}-devel
115%if %{with_static}
116%{_libdir}/libICE.a
117%endif
118%{_libdir}/libICE.so
119%endif
120
121%changelog
122* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
123- rebuild with VineSeed environment
124
125* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
126- new upstream release
127- add BuildRequires: xorg-x11-util-macros
128
129* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
130- new upstream release
131
132* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.0.6-2
133- build with rpm-4.8.1-1 for pkg-config file
134
135* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
136- new upstream release
137
138* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
139- added compat32 package for x86_64 arch support
140
141* Thu Jan 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
142- new upstream release
143
144* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
145- new versioning policy
146
147* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
148- initial build for Vine Linux
149
150* Mon Oct 01 2007 Adam Jackson <ajax@redhat.com> 1.0.4-2
151- Rebuild against xtrans 1.0.3-5 to pick up gethostname() avoidance.
152
153* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.4-1
154- libICE 1.0.4
155
156* Thu Sep 20 2007 Adam Jackson <ajax@redhat.com> 1.0.3-5
157- Update xtrans dep and rebuild.
158
159* Mon Sep 17 2007 Adam Jackson <ajax@redhat.com> 1.0.3-4
160- Rebuild for abstract socket support.
161
162* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
163- Rebuild for build id
164
165* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
166- Don't install INSTALL
167
168* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
169- Update to 1.0.3
170
171* Mon Nov 20 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
172- Update to 1.0.2.
173
174* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-2.1
175- rebuild
176
177* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
178- Added "Requires: xorg-x11-proto-devel"
179- Replace "makeinstall" with "make install DESTDIR=..."
180- Remove package ownership of mandir/libdir/etc.
181
182* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
183- Update to 1.0.1
184
185* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
186- bump again for double-long bug on ppc(64)
187
188* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
189- rebuilt for new gcc4.1 snapshot and glibc changes
190
191* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
192- Bumped and rebuilt
193
194* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
195- Updated libICE to version 1.0.0 from X11R7 RC4
196
197* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
198- Updated libICE to version 0.99.2 from X11R7 RC3
199- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
200  that /usr/lib/X11 and /usr/include/X11 pre-exist.
201- Removed 'x' suffix from manpage directories to match RC3 upstream.
202
203* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
204- rebuilt
205
206* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
207- Updated libICE to version 0.99.1 from X11R7 RC2
208- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
209- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
210
211
212* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
213- Updated libICE to version 0.99.0 from X11R7 RC1
214
215* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
216- Added BuildRequires: pkgconfig
217
218* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
219- Renamed package to remove "xorg-x11" from the name due to unanimous decision
220  between developers.
221- Use Fedora Extras style BuildRoot tag.
222- Disable static library creation by default.
223- Add missing defattr to devel subpackage
224- Add missing documentation files to doc macro
225
226* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
227- Renamed package to prepend "xorg-x11" to the name for consistency with
228  the rest of the X11R7 packages.
229- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
230  subpackage to ensure the devel package matches the installed shared libs.
231- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
232  allow applications to use implementation agnostic dependencies.
233- Added post/postun scripts which call ldconfig.
234- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
235  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
236
237* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
238- Initial build.
Note: See TracBrowser for help on using the repository browser.