source: projects/specs/trunk/lib/libI/libICE/libICE-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libICE runtime library
4Summary(ja): X.Org X11 libICE ランタイムライブラリ
5Name: libICE
6Version: 1.0.6
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-xtrans-devel
18Obsoletes: XFree86-libs, XOrg-libs
19
20%description
21X.Org X11 libICE runtime library
22
23%package devel
24Summary: X.Org X11 libICE development package
25Group: Development/Libraries
26Requires(pre): xorg-x11-filesystem
27Requires: %{name} = %{version}-%{release}
28Requires: xorg-x11-proto-devel
29Obsoletes: XFree86-devel, XOrg-devel
30
31%description devel
32X.Org X11 libICE development package
33
34# compat32
35%package -n compat32-%{name}
36Summary: X.Org X11 libICE runtime library
37Summary(ja): X.Org X11 libICE ランタイムライブラリ
38Group: System Environment/Libraries
39
40%description -n compat32-%{name}
41X.Org X11 libICE runtime library
42
43%package -n compat32-%{name}-devel
44Summary: X.Org X11 libICE development package
45Group: Development/Libraries
46Requires(pre): xorg-x11-filesystem
47Requires: compat32-%{name} = %{version}-%{release}
48Requires: %{name}-devel = %{version}-%{release}
49
50%description -n compat32-%{name}-devel
51X.Org X11 libICE development package
52
53%prep
54%setup -q
55
56# Disable static library creation by default.
57%define with_static 0
58
59%build
60%configure \
61%if ! %{with_static}
62       --disable-static
63%endif
64make
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69make install DESTDIR=$RPM_BUILD_ROOT
70
71# We intentionally don't ship *.la files
72rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post -p /sbin/ldconfig
78%postun -p /sbin/ldconfig
79
80%post -n compat32-%{name} -p /sbin/ldconfig
81%postun -n compat32-%{name} -p /sbin/ldconfig
82
83%files
84%defattr(-,root,root,-)
85%doc AUTHORS COPYING README ChangeLog
86%{_libdir}/libICE.so.6
87%{_libdir}/libICE.so.6.3.0
88
89%files devel
90%dir %{_includedir}/X11
91%dir %{_includedir}/X11/ICE
92%{_includedir}/X11/ICE/*.h
93%if %{with_static}
94%{_libdir}/libICE.a
95%endif
96%{_libdir}/libICE.so
97%{_libdir}/pkgconfig/ice.pc
98
99# compat32
100%if %{build_compat32}
101%files -n compat32-%{name}
102%defattr(-,root,root,-)
103%{_libdir}/libICE.so.6
104%{_libdir}/libICE.so.6.3.0
105
106%files  -n compat32-%{name}-devel
107%if %{with_static}
108%{_libdir}/libICE.a
109%endif
110%{_libdir}/libICE.so
111%{_libdir}/pkgconfig/ice.pc
112%endif
113
114%changelog
115* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
116- new upstream release
117
118* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
119- added compat32 package for x86_64 arch support
120
121* Thu Jan 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
122- new upstream release
123
124* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
125- new versioning policy
126
127* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
128- initial build for Vine Linux
129
130* Mon Oct 01 2007 Adam Jackson <ajax@redhat.com> 1.0.4-2
131- Rebuild against xtrans 1.0.3-5 to pick up gethostname() avoidance.
132
133* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.4-1
134- libICE 1.0.4
135
136* Thu Sep 20 2007 Adam Jackson <ajax@redhat.com> 1.0.3-5
137- Update xtrans dep and rebuild.
138
139* Mon Sep 17 2007 Adam Jackson <ajax@redhat.com> 1.0.3-4
140- Rebuild for abstract socket support.
141
142* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
143- Rebuild for build id
144
145* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
146- Don't install INSTALL
147
148* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
149- Update to 1.0.3
150
151* Mon Nov 20 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
152- Update to 1.0.2.
153
154* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-2.1
155- rebuild
156
157* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
158- Added "Requires: xorg-x11-proto-devel"
159- Replace "makeinstall" with "make install DESTDIR=..."
160- Remove package ownership of mandir/libdir/etc.
161
162* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
163- Update to 1.0.1
164
165* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
166- bump again for double-long bug on ppc(64)
167
168* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
169- rebuilt for new gcc4.1 snapshot and glibc changes
170
171* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
172- Bumped and rebuilt
173
174* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
175- Updated libICE to version 1.0.0 from X11R7 RC4
176
177* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
178- Updated libICE to version 0.99.2 from X11R7 RC3
179- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
180  that /usr/lib/X11 and /usr/include/X11 pre-exist.
181- Removed 'x' suffix from manpage directories to match RC3 upstream.
182
183* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
184- rebuilt
185
186* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
187- Updated libICE to version 0.99.1 from X11R7 RC2
188- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
189- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
190
191
192* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
193- Updated libICE to version 0.99.0 from X11R7 RC1
194
195* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
196- Added BuildRequires: pkgconfig
197
198* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
199- Renamed package to remove "xorg-x11" from the name due to unanimous decision
200  between developers.
201- Use Fedora Extras style BuildRoot tag.
202- Disable static library creation by default.
203- Add missing defattr to devel subpackage
204- Add missing documentation files to doc macro
205
206* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
207- Renamed package to prepend "xorg-x11" to the name for consistency with
208  the rest of the X11R7 packages.
209- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
210  subpackage to ensure the devel package matches the installed shared libs.
211- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
212  allow applications to use implementation agnostic dependencies.
213- Added post/postun scripts which call ldconfig.
214- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
215  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
216
217* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
218- Initial build.
Note: See TracBrowser for help on using the repository browser.