source: projects/specs/trunk/l/lz4/lz4-vl.spec @ 11171

Revision 11171, 7.1 KB checked in by tomop, 7 years ago (diff)

lz4-1.8.0-2

Line 
1Name:           lz4
2Version:        1.8.0
3Release:        2%{?_dist_release}
4Summary:        Extremely fast compression algorithm
5
6License:        GPLv2+ and BSD
7URL:            https://lz4.github.io/lz4/
8Source0:        https://github.com/Cyan4973/lz4/archive/v%{version}/%{name}-%{version}.tar.gz
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: tomop
13
14%description
15LZ4 is an extremely fast loss-less compression algorithm, providing compression
16speed at 400 MB/s per core, scalable with multi-core CPU. It also features
17an extremely fast decoder, with speed in multiple GB/s per core, typically
18reaching RAM speed limits on multi-core systems.
19
20%package        libs
21Summary:        Libaries for lz4
22
23%description    libs
24This package contains the libaries for lz4.
25
26%package        devel
27Summary:        Development files for lz4
28Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
29
30%description    devel
31This package contains the header(.h) and library(.so) files required to build
32applications using liblz4 library.
33
34%package        static
35Summary:        Static library for lz4
36
37%description    static
38LZ4 is an extremely fast loss-less compression algorithm. This package
39contains static libraries for static linking of applications.
40
41%prep
42%autosetup
43echo '#!/bin/sh' > ./configure
44chmod +x ./configure
45
46%build
47%configure
48%make_build
49
50%install
51%configure
52%make_install LIBDIR=%{_libdir} PREFIX=%{_prefix} INSTALL="install -p"
53# Someone thinks that plain Makefiles are good for bigger projects than hello world..
54mkdir -p %{buildroot}%{_mandir}/man1
55mv %{buildroot}%{_mandir}/*.1 %{buildroot}%{_mandir}/man1/
56
57%post libs -p /sbin/ldconfig
58%postun libs -p /sbin/ldconfig
59
60%files
61%license programs/COPYING
62%doc NEWS
63%{_bindir}/lz4
64%{_bindir}/lz4c
65%{_bindir}/lz4cat
66%{_bindir}/unlz4
67%{_mandir}/man1/lz4.1*
68%{_mandir}/man1/lz4c.1*
69%{_mandir}/man1/lz4cat.1*
70%{_mandir}/man1/unlz4.1*
71
72%files libs
73%doc lib/LICENSE
74%{_libdir}/liblz4.so.*
75
76%files devel
77%doc lib/LICENSE
78%{_includedir}/lz4*.h
79%{_libdir}/liblz4.so
80%{_libdir}/pkgconfig/liblz4.pc
81
82%files static
83%doc lib/LICENSE
84%{_libdir}/liblz4.a
85
86%changelog
87* Fri Sep 08 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.0-2
88- initial build for Vine Linux.
89
90* Sat Aug 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.8.0-1
91- Update to 1.8.0
92
93* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-6
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
95
96* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-5
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
98
99* Sat Jul 08 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.7.5-4
100- Split libs properly for multilib
101
102* Sat Mar  4 2017 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.5-3
103- Split libs out to a sub package
104
105* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.5-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
107
108* Thu Jan 05 2017 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.5-1
109- Update to 1.7.5
110
111* Fri Nov 25 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.4.2-1
112- Update to 1.7.4.2 (RHBZ #1397373)
113
114* Sat Nov 19 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.7.3-1
115- Update to 1.7.3 (RHBZ #1395458)
116
117* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - r131-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
119
120* Mon Jul 06 2015 pjp <pjp@fedoraproject.org> - r131-1
121- New: Dos/DJGPP target #114.
122- Added: Example using lz4frame library #118.
123- Changed: liblz4.a no longer compiled with -fPIC by default.
124
125* Thu Jun 18 2015 pjp <pjp@fedoraproject.org> - r130-1
126- Fixed: incompatibility sparse mode vs console.
127- Fixed: LZ4IO exits too early when frame crc not present.
128- Fixed: incompatibility sparse mode vs append mode.
129- Performance fix: big compression speed boost for clang(+30%).
130
131* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r129-2
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
133
134* Wed May 27 2015 pjp <pjp@fedoraproject.org> - r129-1
135- New LZ4_compress_fast() API.
136- New LZ4 CLI improved performance with multiple files.
137- Other bug fix and documentation updates.
138
139* Mon Apr 06 2015 pjp <pjp@fedoraproject.org> - r128-2
140- Update files section to install unlz4 & its manual
141
142* Wed Apr 01 2015 pjp <pjp@fedoraproject.org> - r128-1
143- lz4cli sparse file support
144- Restored lz4hc compression ratio
145- lz4 cli supports long commands
146- Introduced lz4-static sub package BZ#1208203
147
148* Thu Jan 08 2015 pjp <pjp@fedoraproject.org> - r127-2
149- Bump dist to override an earlier build.
150
151* Wed Jan 07 2015 pjp <pjp@fedoraproject.org> - r127-1
152- Fixed a bug in LZ4 HC streaming mode
153- New lz4frame API integrated into liblz4
154- Fixed a GCC 4.9 bug on highest performance settings
155
156* Thu Nov 13 2014 pjp <pjp@fedoraproject.org> - r124-1
157- New LZ4 HC Streaming mode
158
159* Tue Sep 30 2014 pjp <pjp@fedoraproject.org> - r123-1
160- Added experimental lz4frame API.
161- Fix s390x support.
162
163* Sat Aug 30 2014 pjp <pjp@fedoraproject.org> - r122-1
164- new release
165- Fixed AIX & AIX64 support (SamG)
166- Fixed mips 64-bits support (lew van)
167
168* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r121-3
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
170
171* Fri Aug 08 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - r121-2
172- fix destdir
173
174* Fri Aug 08 2014 pjp <pjp@fedoraproject.org> - r121-1
175- new release
176- Added a pkg-config file.
177- Fixed a LZ4 streaming crash bug.
178
179* Thu Jul 03 2014 pjp <pjp@fedoraproject.org> - r119-1
180- new release
181- Fixed a high Address allocation issue in 32-bits mode.
182
183* Sat Jun 28 2014 pjp <pjp@fedoraproject.org> - r118-1
184- new release
185- install libraries under appropriate _libdir directories.
186
187* Sat Jun 14 2014 pjp <pjp@fedoraproject.org> - r117-3
188- Move shared library object to -devel package.
189
190* Sat Jun 07 2014 pjp <pjp@fedoraproject.org> - r117-2
191- Skip static library from installation.
192
193* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - r117-2
194- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
195
196* Fri Jun 06 2014 pjp <pjp@fedoraproject.org> - r117-1
197- new release
198- added lz4c & lz4cat manual pages.
199
200* Sun Apr 13 2014 pjp <pjp@fedoraproject.org> - r116-1
201- new release 116
202- added lz4cat utility for posix systems
203
204* Sat Mar 15 2014 pjp <pjp@fedoraproject.org> - r114-1
205- new release r114
206- added RPM_OPT_FLAGS to CFLAGS
207- introduced a devel package to build liblz4
208
209* Thu Jan 02 2014 pjp <pjp@fedoraproject.org> - r110-1
210- new release r110
211
212* Sun Nov 10 2013 pjp <pjp@fedoraproject.org> - r108-1
213- new release r108
214
215* Wed Oct 23 2013 pjp <pjp@fedoraproject.org> - r107-1
216- new release r107
217
218* Mon Oct 07 2013 pjp <pjp@fedoraproject.org> - r106-3
219- fixed install section to replace /usr/ with a macro.
220  -> https://bugzilla.redhat.com/show_bug.cgi?id=1015263#c5
221
222* Sat Oct 05 2013 pjp <pjp@fedoraproject.org> - r106-2
223- fixed install section above as suggested in the review.
224  -> https://bugzilla.redhat.com/show_bug.cgi?id=1015263#c1
225
226* Sun Sep 22 2013 pjp <pjp@fedoraproject.org> - r106-1
227- Initial RPM release of lz4-r106
Note: See TracBrowser for help on using the repository browser.