source: projects/specs/trunk/l/lxc/lxc-vl.spec @ 12364

Revision 12364, 13.0 KB checked in by tomop, 4 years ago (diff)

updated 13 packages

acpid-2.0.32-1

at-3.1.23-1

autofs-5.1.6-1

dracut-050-3

fcgi-2.4.2-1

fcgiwrap-1.1.0.git20200404-2

firefox-68.6.1-1

initscripts-8.91.16-3

iptables-1.8.4-2

lxc-4.0.0-1

libnftnl-1.1.6-1

smp_utils-0.99-1

util-linux-2.35.1-1

RevLine 
[12364]1%bcond_with systemd
[12019]2%bcond_with lua
3%global with_python3 0
[12364]4%if %{with systemd}
[9811]5%global with_systemd 0
[12364]6%endif
[9811]7
8%global luaver 5.1
9%global lualibdir %{_libdir}/lua/%{luaver}
10%global luapkgdir %{_datadir}/lua/%{luaver}
11
[10393]12%define _unpackaged_files_terminate_build 1
13
[3720]14Name:           lxc
[12364]15Version:        4.0.0
16Release:        1%{?_dist_release}%{?with_systemd:.systemd}
[3720]17Summary:        Linux Resource Containers
18Summary(ja):    Linux リソースコンテナ
19Group:          Applications/System
[9811]20License:        LGPLv2+ and GPLv2
[12334]21URL:            https://linuxcontainers.org
[10393]22Vendor:         Project Vine
23Distribution:   Vine Linux
[6027]24
[12334]25Source0:        https://linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
[12364]26Source10:       lxc-vinelinux
27Source11:       vinelinux.common.conf
28Source12:       vinelinux.userns.conf
[3720]29
[12019]30Patch0:         0001-fix-initscript.patch
31Patch100:       0002-fix-launching-dnsmasq.patch
[9811]32
[3720]33BuildRequires:  docbook-utils
[12364]34BuildRequires:  docbook2X
35BuildRequires:  doxygen
[10401]36BuildRequires:  glibc-static
[3720]37BuildRequires:  kernel-headers
[10401]38BuildRequires:  libcap-static
[3720]39BuildRequires:  libtool
[12019]40%if %{with lua}
[9811]41BuildRequires:  lua-devel
[12019]42%endif
[9811]43BuildRequires:  perl-XML-SAX
44%if 0%{?with_python3}
45BuildRequires:  python3-devel >= 3.2
[12019]46BuildRequires:  python3-rpm-macros
[9811]47%endif # with_python3
48%if 0%{?with_systemd}
49BuildRequires:  systemd
50%endif # with_systemd
51# for lxc-top
[12019]52%if %{with lua}
[9811]53Requires:       lua-%{name}%{?_isa} = %{version}-%{release}
54Requires:       lua-alt-getopt
[12019]55%endif
[12364]56%if !0%{?with_systemd}
[12019]57Requires:       libcgroup
[12364]58%endif
[12019]59Obsoletes:      lxc-extra < 3.0.0
60Obsoletes:      lxc-lua < 3.0.0
61Obsoletes:      python3-lxc < 3.0.0
[3720]62
[9811]63%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
[3720]64
65%description
66Linux Resource Containers provide process and resource isolation without the
67overhead of full virtualization.
68
[9811]69
[3720]70%package        libs
71Summary:        Runtime library files for %{name}
[9811]72Summary(ja):    %{name}のランタイムライブラリ
[3720]73Group:          System Environment/Libraries
[9811]74%if 0%{?with_systemd}
75Requires(post): systemd
76Requires(preun): systemd
77Requires(postun): systemd
78%else
79Requires(post): chkconfig
80Requires(preun): initscripts, chkconfig
81Requires(postun): initscripts
82%endif # with_systemd
[10416]83Obsoletes: compat32-lxc-init-static.32bit < 2.0.1-3
[3720]84
[10401]85%description libs
[3720]86Linux Resource Containers provide process and resource isolation without the
87overhead of full virtualization.
88
89The %{name}-libs package contains libraries for running %{name} applications.
90
[9811]91
92%if 0%{?with_python3}
93%package        -n python3-%{name}
94Summary:        Python binding for %{name}
95Summary(ja):    %{name} の Python バインディング
96Group:          System Environment/Libraries
97
98%description    -n python3-%{name}
99Linux Resource Containers provide process and resource isolation without the
100overhead of full virtualization.
101
102The python3-%{name} package contains the Python3 binding for %{name}.
103
104%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}_lxc\\..*\\.so
105
106
107%package        extra
108Summary:        Extra tools for %{name}
109Summary(ja):    %{name} の追加ツール
110Group:          Applications/System
[9815]111Requires:       python3-%{name} = %{version}-%{release}
[9811]112
113%description    extra
114Linux Resource Containers provide process and resource isolation without the
115overhead of full virtualization.
116
117This package contains tools needing the Python3 bindings.
118%endif # with_python3
119
120
[12019]121%if %{with lua}
[9811]122%package        -n lua-%{name}
123Summary:        Lua binding for %{name}
124Summary(ja):    %{name} の Lua バインディング
125Group:          System Environment/Libraries
126
127%description    -n lua-%{name}
128Linux Resource Containers provide process and resource isolation without the
129overhead of full virtualization.
130
131The lua-%{name} package contains the Lua binding for %{name}.
132
[12019]133%endif
134
[9811]135%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}core\\.so\\.0
136
137
[3720]138%package        templates
139Summary:        Templates for %{name}
[9811]140Summary(ja):    %{name} のテンプレート
[3720]141Group:          System Environment/Libraries
[9811]142Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
143# Note: Requirements for the template scripts (busybox, dpkg,
144# debootstrap, vbootstrap, rsync, openssh-server, dhclient, apt, pacman, zypper,
145# ubuntu-cloudimg-query etc...) are not explicitly mentioned here:
146# their presence varies wildly on supported Fedora/EPEL releases and
147# archs, and they are in most cases needed for a single template
148# only. Also, the templates normally fail graciously when such a tool
149# is missing. Moving each template to its own subpackage on the other
150# hand would be overkill.
[3720]151
[9811]152
[3720]153%description    templates
154Linux Resource Containers provide process and resource isolation without the
155overhead of full virtualization.
156
[9811]157The %{name}-templates package contains templates for creating containers.
[3720]158
[9811]159
[3720]160%package        devel
161Summary:        Development files for %{name}
[9811]162Summary(ja):    %{name}の開発ファイル
[3720]163Group:          Development/Libraries
[9811]164Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
[3720]165Requires:       pkgconfig
166
167%description    devel
168Linux Resource Containers provide process and resource isolation without the
169overhead of full virtualization.
170
171The %{name}-devel package contains libraries and header files for
172developing applications that use %{name}.
173
[9811]174
[3720]175%package        doc
176Summary:        Documentation for %{name}
177Summary(ja):    %{name} のドキュメント
178Group:          Documentation
[9811]179BuildArch:      noarch
[3720]180
181%description    doc
182This package contains documentation for %{name}.
183
[9811]184
[3720]185%prep
[7134]186%setup -q -n %{name}-%{version}
[12364]187%if !0%{?with_systemd}
[9811]188%patch0 -p1
[12364]189%endif
[10416]190%patch100 -p1
[3720]191
[9811]192
[3720]193%build
[10393]194./autogen.sh
[9811]195%configure --with-distro=centos \
196           --enable-doc \
197           --enable-api-docs \
198           --disable-silent-rules \
199           --docdir=%{_pkgdocdir} \
[11166]200           --disable-werror \
[9811]201           --disable-rpath \
[12334]202           --disable-static \
[9811]203           --disable-apparmor \
204           --disable-selinux \
[10393]205           --enable-capabilities \
206           --enable-examples \
[9811]207           --enable-bash \
[12019]208%if %{with lua}
[9811]209           --enable-lua \
[12019]210%endif
[9811]211%if 0%{?with_python3}
212           --enable-python \
213%endif # with_python3
214%if 0%{?with_systemd}
215           --with-init-script=systemd \
216%else
217           --with-init-script=sysvinit \
218%endif # with_systemd
219# intentionally blank line
220make %{?_smp_mflags}
[3720]221
222
223%install
[9811]224%{make_install}
225make DESTDIR=%{buildroot} install
226mkdir -p %{buildroot}%{_sharedstatedir}/%{name}
[12019]227%if %{with lua}
[9811]228chmod -x %{buildroot}%{luapkgdir}/lxc.lua
[12019]229%endif
[3720]230
[9811]231mkdir -p %{buildroot}%{_pkgdocdir}
232cp -a AUTHORS COPYING README %{buildroot}%{_pkgdocdir}
233mkdir -p %{buildroot}%{_pkgdocdir}/api
234cp -a doc/api/html/* %{buildroot}%{_pkgdocdir}/api/
[3720]235
[9811]236# cache dir
237mkdir -p %{buildroot}%{_localstatedir}/cache/%{name}
[3720]238
[9811]239rm -rf %{buildroot}%{_datadir}/lxc/selinux
[3720]240
[9811]241# install vinelinux template
242install -m775 %{SOURCE10} %{buildroot}%{_datadir}/lxc/templates/
[9815]243install -m775 %{SOURCE11} %{buildroot}%{_datadir}/lxc/config/
244install -m775 %{SOURCE12} %{buildroot}%{_datadir}/lxc/config/
[9811]245
[12019]246rm -f %{buildroot}%{_libdir}/liblxc.{a,la}
[9811]247
[11166]248
[9811]249%check
250make check
251
252
253%post libs
254/sbin/ldconfig
255%if 0%{?with_systemd}
256%systemd_post %{name}.service
257%else
258/sbin/chkconfig --add %{name}
259%endif # with_systemd
260
261
262%preun libs
263%if 0%{?with_systemd}
264%systemd_preun %{name}.service
265%else
266if [ $1 -eq 0 ]; then
267        /sbin/service %{name} stop > /dev/null 2>&1
268        /sbin/chkconfig --del %{name}
269fi
270%endif # with_systemd
271
272
273%postun libs
274/sbin/ldconfig
275%if 0%{?with_systemd}
276%systemd_postun %{name}.service
277%else
278if [ $1 -ge 1 ]; then
279        /sbin/service %{name} condrestart > /dev/null 2>&1 || :
280fi
281%endif # with_systemd
282
283
[3720]284%files
[12019]285%license COPYING
286%doc README*
[3720]287%{_bindir}/%{name}-*
[12364]288%{_bindir}/run-coccinelle.sh
[9811]289%{_mandir}/man1/%{name}*
290%{_mandir}/*/man1/%{name}*
291# in lxc-libs:
292%exclude %{_bindir}/%{name}-autostart
293%exclude %{_mandir}/man1/%{name}-autostart*
294%exclude %{_mandir}/*/man1/%{name}-autostart*
295%exclude %{_mandir}/man1/%{name}-user-nic*
296%exclude %{_mandir}/*/man1/%{name}-user-nic*
297%{_datadir}/%{name}/%{name}.functions
298%if 0%{?with_python3}
299%exclude %{_bindir}/%{name}-device
300%exclude %{_bindir}/%{name}-ls
301%exclude %{_mandir}/man1/%{name}-device*
302%exclude %{_mandir}/man1/%{name}-ls*
303%exclude %{_mandir}/*/man1/%{name}-device*
304%exclude %{_mandir}/*/man1/%{name}-ls*
305%endif
306%dir %{_sysconfdir}/bash_completion.d/
307%{_sysconfdir}/bash_completion.d/%{name}
[3720]308
[9811]309
[3720]310%files libs
[9811]311%dir %{_datadir}/%{name}
312%dir %{_datadir}/%{name}/templates
313%dir %{_datadir}/%{name}/config
314%{_datadir}/%{name}/hooks
315%{_datadir}/%{name}/%{name}-patch.py*
[3720]316%{_libdir}/liblxc.so.*
[9811]317%{_libdir}/%{name}
318%{_libexecdir}/%{name}
319%{_sbindir}/init.%{name}
[10401]320%{_sbindir}/init.%{name}.static
[9811]321%{_bindir}/%{name}-autostart
322%{_sharedstatedir}/%{name}
323%dir %{_sysconfdir}/%{name}
324%config(noreplace) %{_sysconfdir}/%{name}/default.conf
325%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
326%{_mandir}/man1/%{name}-autostart*
327%{_mandir}/*/man1/%{name}-autostart*
328%{_mandir}/man1/%{name}-user-nic*
329%{_mandir}/*/man1/%{name}-user-nic*
330%{_mandir}/man5/%{name}*
331%{_mandir}/man7/%{name}*
332%{_mandir}/*/man5/%{name}*
333%{_mandir}/*/man7/%{name}*
334%dir %{_pkgdocdir}
335%{_pkgdocdir}/AUTHORS
336%{_pkgdocdir}/COPYING
337%{_pkgdocdir}/README
338%if 0%{?with_systemd}
339%{_unitdir}/%{name}.service
340%else
341%{_sysconfdir}/rc.d/init.d/%{name}
342%{_sysconfdir}/rc.d/init.d/%{name}-net
343%endif # with_systemd
344%dir %{_localstatedir}/cache/%{name}
[3720]345
[9811]346
347%if 0%{?with_python3}
348%files -n python3-%{name}
349%{python3_sitearch}/*
350
351
352%files extra
353%{_bindir}/%{name}-device
354%{_bindir}/%{name}-ls
355%{_mandir}/man1/%{name}-device*
356%{_mandir}/man1/%{name}-ls*
357%{_mandir}/*/man1/%{name}-device*
358%{_mandir}/*/man1/%{name}-ls*
359%endif # with_python3
360
361
[12019]362%if %{with lua}
[9811]363%files -n lua-%{name}
364%{lualibdir}/%{name}
365%{luapkgdir}/%{name}.lua
[12019]366%endif
[9811]367
368
[3720]369%files templates
[9811]370%{_datadir}/%{name}/templates/lxc-*
371%{_datadir}/%{name}/config/*
[3720]372
[9811]373
[3720]374%files devel
[7134]375%{_libdir}/pkgconfig/%{name}.pc
[9811]376%{_includedir}/lxc
[3720]377%{_libdir}/liblxc.so
378
[9811]379
[3720]380%files doc
[9811]381%dir %{_pkgdocdir}
382# README, AUTHORS and COPYING intentionally duplicated because -doc
383# can be installed on its own.
384%{_pkgdocdir}/*
[3720]385
[9811]386
[3720]387%changelog
[12364]388* Sat Apr 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
389- updated to 4.0.0.
390- updated lxc-vinelinux.
391
[12334]392* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.4-1
393- updated to 3.0.4.
394- disabled cgmanager.
395
[12062]396* Tue Apr 09 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-2
397- updated the Vine Linux template for lxc-3.0.x.
398
[12019]399* Fri Jan 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
400- updated to 3.0.3.
401- updated Patch0.
402- updated Patch100.
403- disabled lua.
404- disabled python.
405- added R:libcgroup.
406
[11166]407* Wed Aug 30 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-2
408- enabled cgmanager.
409
410* Tue Aug 29 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
411- updated to 2.0.8.
412- updated Patch0.
413- dropped Patch1: added an option to get same effect.
414
[10416]415* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.1-3
416- made lxc-net to be able to disable dnsmasq.
417- dropped compat32-lxc-init-static.
418
[10401]419* Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.1-2
420- enabled init.lxc.static for lxc-execute.
421
[10393]422* Thu Jun 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.1-1
423- updated to 2.0.1.
424- replaced all patches.
425
[9815]426* Tue Nov 17 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.5-2
427- enable python3 support by default
428
429* Sun Nov 15 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.5-1
430- update vinelinux template
431  - add vinelinux.{common,userns}.conf
432- add patch1 to disable setproctitle error message,
433  cherry picked from upstream git.
434
[9811]435* Sun Nov 15 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.4-1
436- update to 1.1.4-1
437- add vinelinux template
438
439* Wed Apr 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-3
440- add patch10 to not fail on failure to link kmsg
441
[7134]442* Wed Nov 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-2
443- update to 0.8.0 release
444
[6231]445* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1.20120525
446- update to git master
447
[6027]448* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0.rc1
449- new upstream release
450
[5495]451* Thu Jan 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1.20120105
452- update to git current (20120105)
453
[4061]454* Mon Jun 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4.2-1
455- update to 0.7.4.2
456
[3720]457* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4.1-2
458- include all templates
459
460* Wed Apr 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4.1-1
461- initial build for Vine Linux
462
463* Fri Mar 25 2011 Silas Sewell <silas@sewell.ch> - 0.7.4.1-1
464- Update to 0.7.4.1
465
466* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
467- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
468
469* Mon Jul 26 2010 Silas Sewell <silas@sewell.ch> - 0.7.2-1
470- Update to 0.7.2
471- Remove templates
472
473* Tue Jul 06 2010 Silas Sewell <silas@sewell.ch> - 0.7.1-1
474- Update to 0.7.1
475
476* Wed Feb 17 2010 Silas Sewell <silas@sewell.ch> - 0.6.5-1
477- Update to latest release
478- Add /var/lib/lxc directory
479- Patch for sys/stat.h
480
481* Fri Nov 27 2009 Silas Sewell <silas@sewell.ch> - 0.6.4-1
482- Update to latest release
483- Add documentation sub-package
484
485* Mon Jul 27 2009 Silas Sewell <silas@sewell.ch> - 0.6.3-2
486- Apply patch for rawhide kernel
487
488* Sat Jul 25 2009 Silas Sewell <silas@sewell.ch> - 0.6.3-1
489- Initial package
Note: See TracBrowser for help on using the repository browser.