source: projects/specs/trunk/l/lv/lv-vl.spec @ 12330

Revision 12330, 4.3 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

cifs-utils-6.10-1

less-551-1

lv-4.51.d-1

ruby-2.4.9-17

vim-8.2.0365-1

Line 
1%global srcver 4.51
2%global shortsrcver %(echo %{srcver} | sed -e 's/\\.//')
3%global _configure ../configure
4
5Summary: a powerful multilingual file viewer
6Summary(ja): パワフルな多言語対応ファイルビュウワー
7Name: lv
8Epoch: 1
9Version: %{srcver}.d
10Release: 1%{?_dist_release}
11License: GPL
12Group: Applications/Text
13Source: http://www.ff.iij4u.or.jp/~nrt/freeware/lv%{shortsrcver}.tar.gz
14URL: http://www.ff.iij4u.or.jp/~nrt/lv/
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17# from https://github.com/k-takata/lv-mod
18Patch1: lv-mod-4.51.d.patch
19
20Provides: pager
21Requires(post,preun): alternatives
22BuildRequires: ncurses-devel >= 5.6
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28lv is a powerful file viewer like less.  lv can decode and encode
29multilingual streams through many coding systems: ISO-8859, ISO-2022,
30EUC, SJIS, Big5, HZ, Unicode.  It recognizes multi-bytes patterns as
31regular expressions, lv also provides multilingual grep.  In addition,
32lv can recognize ANSI escape sequences for text devoration.
33
34%description -l ja
35lv は less に似たパワフルなファイルビュウワーです。lv は多言語文字列を
36ISO-8859, ISO-2022, EUC, SJIS, Big5, HZ, Unicode といった様々な文字コー
37ドにエンコード・デコードできます。また多バイト正規表現をサポートしてお
38り、多言語 grep としての機能も備えています。さらに lv は ANSI エスケー
39プシーケンスによるテキスト装飾を扱うこともできます。
40
41
42%prep
43%setup -q -n lv%{shortsrcver}
44
45%patch1 -p1
46autoreconf -ivf
47
48%build
49pushd build
50%configure
51make %{_smp_mflags}
52popd
53
54
55%install
56rm -rf %{buildroot}
57mkdir -p %{buildroot}%{_bindir}
58mkdir -p %{buildroot}%{_mandir}/man1
59
60# installing binaries ...
61pushd build
62%makeinstall
63popd
64
65# listing all files in drb-all.files
66(find \
67  %{buildroot}%{_bindir} \
68  %{buildroot}%{_mandir} \
69      -type f -o -type l) |
70 sort | sed -e "s,^%{buildroot},," \
71            -e "s,\(/man/man./.*\)$,\1*," > lv-all.files
72
73
74%clean
75rm -rf %{buildroot}
76rm -f *.files
77
78
79#%post -p /sbin/ldconfig -n lv
80%post
81%{_syssbindir}/update-alternatives --install %{_bindir}/pager pager %{_bindir}/lv 20
82
83%preun
84if [ "$1" = "0" ]; then
85  %{_syssbindir}/update-alternatives --remove pager %{_bindir}/lv
86fi
87
88#%postun -p /sbin/ldconfig -n lv
89
90
91%files -f lv-all.files
92%defattr(-, root, root)
93%license GPL.txt
94%doc README
95%doc hello.sample
96%doc hello.sample.gif
97%doc index.html
98%doc relnote.html
99%{_libdir}/lv
100
101
102%changelog
103* Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.51.d-1
104- added Patch1: from https://github.com/k-takata/lv-mod
105
106* Sun Jan 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.51.0-3
107- rebuild with current VineSeed
108
109* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-2
110- rebuild for Vine 6
111
112* Sun Aug 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-1
113- new versioning policy
114- build with ncurses-5.6
115
116* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl6
117- add Provides: pager
118- add Requires(post,preun): alternatives
119
120* Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl5
121- add update-alternatives: pager in %%post and %%preun scriptlet
122
123* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl4
124- rebuild on VineSeed
125
126* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl3
127- add (Build)Requires: libtermcap(-devel)
128- add Vendor/Distribution tag
129- add GPL.txt
130
131* Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl2
132- rebuild on VineSeed
133
134* Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl1
135- upstream release
136- drop obsolete patch lv-Makefile.in.patch (Patch1)
137
138* Sat Jan 10 2004 KAZUKI SHIMURA <rito@pos.to> 4.50.0-0vl1
139- upstream release
140- define %%{srcname}
141- s/Copyright/License/
142
143* Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl2
144- rebuild on VineSeed
145
146* Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl1
147- SECURITY FIX - upstream release
148   - fix CAN-2003-0188: possible local root exploit using config files
149
150* Mon Mar 24 2003 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl4
151- rebuild with new toolchain
152
153* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.49.4-0vl3
154- URL was incorrect (http was hhttp)... Fixed the typo.
155
156* Sun Jul 21 2002 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl2
157- added the help file for executing with h option
158
159* Wed Jan 10 2001 akira yamada <akira@vinelinux.org>
160- Initial packaging.
Note: See TracBrowser for help on using the repository browser.