source: projects/specs/trunk/l/lua/lua-vl.spec @ 9052

Revision 9052, 5.5 KB checked in by inagaki, 9 years ago (diff)

2014-11-02 Ryoichi INAGAKI <ryo1@…>

  • freeciv, imake, lasem, lua, mate-icon-theme: changed Group


Line 
1%define name lua
2%define version 5.1.4
3%define release 6%{?_dist_release}
4
5Summary: Lua is a powerful, light-weight programming language designed for extending applications.
6Summary(ja): アプリケーション拡張向けに設計された強力かつ軽量なプログラミング言語
7Name: %{name}
8Version: %{version}
9Release: %{release}
10Source0: http://www.lua.org/ftp/%{name}-%{version}.tar.gz
11Patch0: lua-5.1.4-autotoolize.patch
12License: MIT (Lua 5.0 license)
13Group: Development/Languages
14URL: http://www.lua.org/
15
16#Requires:
17BuildRequires: readline-devel
18BuildRequires: ncurses-devel
19# apt-get remove readline-devel
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22Provides: lua = 5.1
23
24%description
25Lua is an extension programming language designed to support
26general procedural programming with data description facilities.
27It also offers good support for object-oriented programming,
28functional programming, and data-driven programming.
29Lua is intended to be used as a powerful, light-weight configuration language
30for any program that needs one.
31Lua is implemented as a library, written in clean C
32(that is, in the common subset of ANSI C and C++).
33
34%description -l ja
35Luaは拡張プログラミング言語である。データ記述機能を持ち、
36汎用の手続き型プログラミングをサポートするようデザインされた。
37オブジェクト指向プログラミング、関数型プログラミング、
38データ駆動型プログラミングもサポートしている。
39Luaは、パワフルで軽いコンフィギュレーション言語としての意図もあり、
40コンフィギュレーションが必要なあらゆるプログラムに使うことができる。
41Luaはクリーンな C (つまり、ANSI C と C++ の共通のサブセット) で書かれ、
42ライブラリとして実装されている。
43
44
45%package devel
46Summary: Libraries and include files for Lua.
47Summary(ja): Lua の開発用ファイル
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: ncurses-devel
51Requires: pkgconfig
52
53%description devel
54Libraries and include files for Lua.
55
56%package static
57Summary: Static library for Lua
58Summary(ja): Lua の静的ライブラリ
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61
62%description static
63This package contains the static version of liblua for %{name}.
64
65
66%prep
67rm -rf $RPM_BUILD_ROOT
68
69%setup  -q
70%patch0 -p1 -E
71# fix perms on auto files
72chmod u+x \
73    autogen.sh config.guess config.sub configure depcomp install-sh missing
74
75%build
76%configure --with-readline
77sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79# hack so that only /usr/bin/lua gets linked with readline as it is the
80# only one which needs this and otherwise we get License troubles
81make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
82# also remove readline from lua.pc
83sed -i 's/-lreadline -lncurses //g' etc/lua.pc
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88make install DESTDIR=$RPM_BUILD_ROOT
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/5.1
91mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/5.1
92
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101
102%files
103%defattr(-,root,root,-)
104%doc COPYRIGHT HISTORY README doc/*.html doc/*.gif
105%{_bindir}/lua*
106%{_libdir}/liblua-*.so
107%{_mandir}/man1/lua*.1*
108%dir %{_libdir}/lua
109%dir %{_libdir}/lua/5.1
110%dir %{_datadir}/lua
111%dir %{_datadir}/lua/5.1
112
113%files devel
114%defattr(-,root,root,-)
115%{_includedir}/l*.h
116%{_includedir}/l*.hpp
117%{_libdir}/liblua.so
118%{_libdir}/pkgconfig/*.pc
119
120%files static
121%defattr(-,root,root,-)
122%{_libdir}/*.a
123
124
125%changelog
126* Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-6
127- added Japanese summary
128- moved devel and static subpackages to Development/Libraries Group
129
130* Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-5
131- build with current VineSeed
132
133* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.4-4
134- rebuild with rpm-4.8.1 for pkg-config file
135
136* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-3
137- rebuilt with gcc-4.4.3-3 on ppc
138
139* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-2
140- rebuilt with rpm-4.8.0-3 (on ppc)
141
142* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1.4-1
143- new upstream release
144- add lua-static subpackage
145
146* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.2-1vl5
147- applied new versioning policy and spec in utf-8
148
149* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl2
150- rebuild for VineSeed
151
152* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl1
153- initial build for Vine Linux 4.1
154 - source update
155
156* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.1-0vlmp1
157- rebuild for Vine Linux 4.1
158
159* Fri Jan 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-3
160- Remove "-lreadline -lncurses" from lua.pc (bz 213895)
161
162* Sun Oct 15 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-2
163- Only link /usr/bin/lua with readline / do not link %%{_libdir}/liblua-5.1.so
164  with readline so that we don't cause any License troubles for packages
165  linking against liblua-5.1.so, otherwise lua could drag the GPL only readline
166  lib into the linking of non GPL apps.
167
168* Sat Oct 14 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-1
169- New upstream release 5.1.1
170- Fix detection of readline during compile (iow add readline support back)
171
172* Sat Jul 23 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.0.2vlmp1
173- initial build for Vine Linux 3.2
Note: See TracBrowser for help on using the repository browser.