source: projects/specs/trunk/l/lua/lua-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name lua
2%define version 5.1.4
3%define release 3%{?_dist_release}
4
5Summary: Lua is a powerful, light-weight programming language designed for extending applications.
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source0: http://www.lua.org/ftp/%{name}-%{version}.tar.gz
10Patch0: lua-5.1.4-autotoolize.patch
11License: MIT (Lua 5.0 license)
12Group: Development/Languages
13URL: http://www.lua.org/
14
15#Requires:
16BuildRequires: readline-devel, ncurses-devel
17# apt-get remove readline-devel
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Provides: lua = 5.1
21
22%description
23Lua is an extension programming language designed to support
24general procedural programming with data description facilities.
25It also offers good support for object-oriented programming,
26functional programming, and data-driven programming.
27Lua is intended to be used as a powerful, light-weight configuration language
28for any program that needs one.
29Lua is implemented as a library, written in clean C
30(that is, in the common subset of ANSI C and C++).
31
32%description -l ja
33Luaは拡張プログラミング言語である。データ記述機能を持ち、
34汎用の手続き型プログラミングをサポートするようデザインされた。
35オブジェクト指向プログラミング、関数型プログラミング、
36データ駆動型プログラミングもサポートしている。
37Luaは、パワフルで軽いコンフィギュレーション言語としての意図もあり、
38コンフィギュレーションが必要なあらゆるプログラムに使うことができる。
39Luaは クリーンな C (つまり、ANSI C と C++ の共通のサブセット) で書かれ、
40ライブラリとして実装されている。
41
42
43%package devel
44Summary: Libraries and include files for Lua.
45Group: Development/Languages
46Requires: %{name} = %{version}-%{release}
47Requires: ncurses-devel, pkgconfig
48
49%description devel
50Libraries and include files for Lua.
51
52%package static
53Summary:        Static library for %{name}
54Group:          System Environment/Libraries
55Requires:       %{name} = %{version}-%{release}
56
57%description static
58This package contains the static version of liblua for %{name}.
59
60
61%prep
62rm -rf ${RPM_BUILD_ROOT}
63
64%setup  -q
65%patch0 -p1 -E
66# fix perms on auto files
67chmod u+x \
68    autogen.sh config.guess config.sub configure depcomp install-sh missing
69
70%build
71%configure --with-readline
72sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
73sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
74# hack so that only /usr/bin/lua gets linked with readline as it is the
75# only one which needs this and otherwise we get License troubles
76make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
77# also remove readline from lua.pc
78sed -i 's/-lreadline -lncurses //g' etc/lua.pc
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=$RPM_BUILD_ROOT
84rm $RPM_BUILD_ROOT%{_libdir}/*.la
85mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/5.1
86mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/5.1
87
88
89%clean
90rm -rf ${RPM_BUILD_ROOT}
91
92
93%files
94%defattr(-,root,root,-)
95%doc COPYRIGHT HISTORY README doc/*.html doc/*.gif
96%{_bindir}/lua*
97%{_libdir}/liblua-*.so
98%{_mandir}/man1/lua*.1*
99%dir %{_libdir}/lua
100%dir %{_libdir}/lua/5.1
101%dir %{_datadir}/lua
102%dir %{_datadir}/lua/5.1
103
104%files devel
105%defattr(-,root,root,-)
106%{_includedir}/l*.h
107%{_includedir}/l*.hpp
108%{_libdir}/liblua.so
109%{_libdir}/pkgconfig/*.pc
110
111%files static
112%defattr(-,root,root,-)
113%{_libdir}/*.a
114
115
116%changelog
117* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-3
118- rebuilt with gcc-4.4.3-3 on ppc
119
120* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-2
121- rebuilt with rpm-4.8.0-3 (on ppc)
122
123* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1.4-1
124- new upstream release
125- add lua-static subpackage
126
127* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.2-1vl5
128- applied new versioning policy and spec in utf-8
129
130* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl2
131- rebuild for VineSeed
132
133* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl1
134- initial build for Vine Linux 4.1
135 - source update
136
137* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.1-0vlmp1
138- rebuild for Vine Linux 4.1
139
140* Fri Jan 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-3
141- Remove "-lreadline -lncurses" from lua.pc (bz 213895)
142
143* Sun Oct 15 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-2
144- Only link /usr/bin/lua with readline / do not link %%{_libdir}/liblua-5.1.so
145  with readline so that we don't cause any License troubles for packages
146  linking against liblua-5.1.so, otherwise lua could drag the GPL only readline
147  lib into the linking of non GPL apps.
148
149* Sat Oct 14 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-1
150- New upstream release 5.1.1
151- Fix detection of readline during compile (iow add readline support back)
152
153* Sat Jul 23 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.0.2vlmp1
154- initial build for Vine Linux 3.2
Note: See TracBrowser for help on using the repository browser.