source: projects/specs/trunk/l/lua/lua-vl.spec @ 12139

Revision 12139, 5.7 KB checked in by ara_t, 5 years ago (diff)

lua: rebuild with readline-8.0 and ncurses-6.1

Line 
1%define name lua
2%define version 5.1.4
3%define release 8%{?_dist_release}
4
5Summary: Lua is a powerful, light-weight programming language designed for extending applications.
6Summary(ja): アプリケーション拡張向けに設計された強力かつ軽量なプログラミング言語
7Name: %{name}
8Version: %{version}
9Release: %{release}
10
11License: MIT
12Group: Development/Languages
13URL: http://www.lua.org/
14
15Source0: http://www.lua.org/ftp/%{name}-%{version}.tar.gz
16Patch0: lua-5.1.4-autotoolize.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: readline-devel
20BuildRequires: ncurses-devel
21# apt-get remove readline-devel
22
23Provides: lua = 5.1
24
25%description
26Lua is an extension programming language designed to support
27general procedural programming with data description facilities.
28It also offers good support for object-oriented programming,
29functional programming, and data-driven programming.
30Lua is intended to be used as a powerful, light-weight configuration language
31for any program that needs one.
32Lua is implemented as a library, written in clean C
33(that is, in the common subset of ANSI C and C++).
34
35%description -l ja
36Lua は、データ記述機能を備え、汎用の手続き型プログラミングをサポート
37するようデザインされた拡張プログラミング言語です。
38オブジェクト指向プログラミング、関数型プログラミング、データ駆動型
39プログラミングもサポートしています。
40Lua は、コンフィギュレーションが必要なあらゆるプログラムのための、
41パワフルかつ軽いコンフィギュレーション言語としての使用を意図しています。
42Lua は、クリーンな C (つまり、ANSI C と C++ の共通のサブセット) で
43書かれたライブラリとして実装されています。
44
45%package devel
46Summary: Libraries and include files for Lua.
47Summary(ja): Lua の開発用ファイル
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: ncurses-devel
51Requires: pkgconfig
52
53%description devel
54Libraries and include files for Lua.
55
56%package static
57Summary: Static library for Lua
58Summary(ja): Lua の静的ライブラリ
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61
62%description static
63This package contains the static version of liblua for %{name}.
64
65
66%prep
67%setup  -q
68%patch0 -p1 -E
69# fix perms on auto files
70chmod u+x \
71    autogen.sh config.guess config.sub configure depcomp install-sh missing
72
73%build
74%configure --with-readline
75sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
76sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
77# hack so that only /usr/bin/lua gets linked with readline as it is the
78# only one which needs this and otherwise we get License troubles
79make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
80# also remove readline from lua.pc
81sed -i 's/-lreadline -lncurses //g' etc/lua.pc
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
88mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/5.1
89mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/5.1
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99
100%files
101%defattr(-,root,root,-)
102%doc COPYRIGHT HISTORY README doc/*.html doc/*.gif
103%{_bindir}/lua*
104%{_libdir}/liblua-*.so
105%{_mandir}/man1/lua*.1*
106%dir %{_libdir}/lua
107%dir %{_libdir}/lua/5.1
108%dir %{_datadir}/lua
109%dir %{_datadir}/lua/5.1
110
111%files devel
112%defattr(-,root,root,-)
113%{_includedir}/l*.h
114%{_includedir}/l*.hpp
115%{_libdir}/liblua.so
116%{_libdir}/pkgconfig/*.pc
117
118%files static
119%defattr(-,root,root,-)
120%{_libdir}/*.a
121
122
123%changelog
124* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 5.1.4-8
125- rebuild with readline-8.0 and ncurses-6.1
126
127* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.1.4-7
128- rebuilt with readline 6.3
129
130* Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-6
131- added Japanese summary
132- moved devel and static subpackages to Development/Libraries Group
133
134* Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-5
135- build with current VineSeed
136
137* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.4-4
138- rebuild with rpm-4.8.1 for pkg-config file
139
140* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-3
141- rebuilt with gcc-4.4.3-3 on ppc
142
143* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-2
144- rebuilt with rpm-4.8.0-3 (on ppc)
145
146* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1.4-1
147- new upstream release
148- add lua-static subpackage
149
150* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.2-1vl5
151- applied new versioning policy and spec in utf-8
152
153* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl2
154- rebuild for VineSeed
155
156* Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl1
157- initial build for Vine Linux 4.1
158 - source update
159
160* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.1-0vlmp1
161- rebuild for Vine Linux 4.1
162
163* Fri Jan 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-3
164- Remove "-lreadline -lncurses" from lua.pc (bz 213895)
165
166* Sun Oct 15 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-2
167- Only link /usr/bin/lua with readline / do not link %%{_libdir}/liblua-5.1.so
168  with readline so that we don't cause any License troubles for packages
169  linking against liblua-5.1.so, otherwise lua could drag the GPL only readline
170  lib into the linking of non GPL apps.
171
172* Sat Oct 14 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-1
173- New upstream release 5.1.1
174- Fix detection of readline during compile (iow add readline support back)
175
176* Sat Jul 23 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.0.2vlmp1
177- initial build for Vine Linux 3.2
Note: See TracBrowser for help on using the repository browser.