source: projects/specs/trunk/l/lua-rex/lua-rex-vl.spec @ 12212

Revision 12212, 3.0 KB checked in by tomop, 5 years ago (diff)

updated 3 packages


jq-1.6-1

lua-rex-2.9.0-1

oniguruma-6.9.3-1

Line 
1%define luaver %(pkg-config --variable=V lua || echo missing)
2%define lualibdir %{_libdir}/lua/%{luaver}
3
4Name:           lua-rex
5Version:        2.9.0
6Release:        1%{?_dist_release}
7Summary:        Regular expression handling library for Lua
8Summary(ja):    正規表現を扱うための Lua ライブラリ
9Group:          Development/Libraries
10License:        MIT
11URL:            http://rrthomas.github.io/lrexlib/
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16%global         altver %(echo %{version} | sed -e 's/\\./-/g')
17Source0:        https://github.com/rrthomas/lrexlib/archive/rel-%{altver}.tar.gz
18Source1:        Makefile
19Source2:        common.mak
20Source3:        defaults.mak
21Source4:        rex_onig.mak
22Source5:        rex_pcre.mak
23Source6:        rex_posix.mak
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  oniguruma-devel
27BuildRequires:  pcre-devel
28BuildRequires:  lua-devel
29BuildRequires:  pkgconfig
30BuildRequires:  unzip
31Requires:       lua = %{luaver}
32Provides:       lrexlib = %{version}
33
34%description
35Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
36and Oniguruma) to Lua.
37
38
39%prep
40%setup -q -n lrexlib-rel-%{altver}
41
42cp -f %{SOURCE1} ./
43cp -f %{SOURCE2} src/
44cp -f %{SOURCE3} src/
45cp -f %{SOURCE4} src/oniguruma/
46cp -f %{SOURCE5} src/pcre/
47cp -f %{SOURCE6} src/posix/
48
49%build
50make %{?_smp_mflags} LD=cc MYCFLAGS='%{optflags} -DVERSION=\"%{version}\" -fPIC %(pcre-config --cflags)' build
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT%{lualibdir}
56cp -P */*/rex_{onig,pcre,posix}.so* $RPM_BUILD_ROOT%{lualibdir}
57
58
59%check
60make %{?_smp_mflags} test
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66
67%files
68%defattr(-,root,root,-)
69%{lualibdir}/*
70%license LICENSE
71%doc ChangeLog NEWS README doc
72
73
74%changelog
75* Sat Sep 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.0-7
76- new upstream release.
77- built with oniguruma-6.9.3.
78
79* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-6
80- rebuild with pcre-8.31
81
82* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.4.0-5
83- rebuilt with rpm-4.8.1-3
84
85* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-4
86- rebuilt with gcc-4.4.3-3 on ppc
87
88* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-3
89- rebuilt with rpm-4.8.0-3 (on ppc)
90
91* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-2
92- added BR: unzip
93
94* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
95- initial build for Vine Linux
96
97* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-5
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
99
100* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-4
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
102
103* Tue Dec 23 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-3
104- Compile shared library as PIC
105
106* Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
107- Add doc directory to documentation
108- Allow parallel make runs
109
110* Tue Dec 16 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-1
111- Initial packaging
Note: See TracBrowser for help on using the repository browser.