source: projects/specs/trunk/l/lsyncd/lsyncd-vl.spec @ 1506

Revision 1506, 1.8 KB checked in by daisuke, 14 years ago (diff)

lsyncd: fix typo

Line 
1Summary: Live syncing (mirroring) daemon
2Summary(ja): リアルタイム同期(ミラーリング)デーモン
3Name: lsyncd
4Version: 1.34
5Release: 1%{?_dist_release}
6
7License: GPL
8Group: Applications/File
9URL: http://code.google.com/p/lsyncd/
10
11Source: lsyncd-%{version}.tar.gz
12Source1: lsyncd.init
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15Requires: rsync
16Requires(post): /sbin/chkconfig
17Requires(preun): /sbin/chkconfig
18Requires(preun): /sbin/service
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: daisuke
23
24%description
25Lsyncd uses rsync to synchronize local directories with a remote machine running rsyncd.
26Lsyncd watches multiple directories trees through inotify. The first step after adding
27the watches is to rsync all directories with the remote host, and then sync single file
28by collecting the inotify events. So lsyncd is a light-weight live mirror solution that
29should be easy to install and use while blending well with your system. See lsyncd --help
30for detailed command line options.
31
32%prep
33%setup
34
35%build
36%configure
37%{__make} %{?_smp_mflags}
38
39%install
40%{__rm} -rf %{buildroot}
41%{__make} install DESTDIR=%{buildroot}
42
43mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
44%{__install} -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/lsyncd
45
46%clean
47%{__rm} -rf %{buildroot}
48
49%post
50/sbin/chkconfig --add lsyncd
51
52%preun
53if [ "$1" = "0" ]; then
54    /sbin/service lsyncd stop >/dev/null 2>&1
55    /sbin/chkconfig --del lsyncd
56fi
57
58%postun
59if [ "$1" -ge "1" ]; then
60    /sbin/service lsyncd condrestart >/dev/null 2>&1
61fi
62
63%files
64%defattr(-, root, root, 0755)
65%doc AUTHORS COPYING ChangeLog NEWS TODO lsyncd.conf.xml
66%{_bindir}/lsyncd
67%{_mandir}/man1/lsyncd.1*
68%{_mandir}/man5/lsyncd.conf.xml.5*
69     
70%changelog
71* Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.34-1
72- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.