source: projects/specs/trunk/l/lshw/lshw-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Hardware information listing tool
2Summary(ja): ハードウェア情報表示ツール
3Name:    lshw
4Version: B.02.13
5Release: 1%{?_dist_release}
6License: GPLv2
7Group:   Applications/System
8URL:     http://ezix.org/project/wiki/HardwareLiSter
9Source0: http://www.ezix.org/software/files/%{name}-%{version}.tar.gz
10Source1: lshw.desktop
11Source2: lshw.consolehelper
12Source3: lshw.pam
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15%description
16lshw (Hardware Lister) is a small tool to provide detailed informaton on
17the hardware configuration of the machine. It can report exact memory
18configuration, firmware version, mainboard configuration, CPU version and
19speed, cache configuration, bus speed, etc. on DMI-capable x86 systems
20and on some PowerPC machines (PowerMac G4 is known to work).
21
22Information can be output in plain text, XML or HTML.
23
24%package gui
25Summary:  Graphical hardware lister
26Summary(ja): グラフィカルなハードウエア情報表示ツール
27Group:    Applications/System
28Requires: usermode
29Requires: %{name} = %{version}-%{release}
30BuildRequires: gtk2-devel >= 2.4
31BuildRequires: desktop-file-utils
32
33%description gui
34Graphical frontend for the hardware lister (lshw) tool.
35If desired, hardware information can be saved to file in
36plain, XML or HTML format.
37
38%prep
39%setup -q -n %{name}-%{version}
40
41%{__sed} -i 's|-g -Wall -g|%{optflags}|' src/Makefile
42%{__sed} -i 's|-g -Wall -Os|%{optflags}|' src/core/Makefile
43%{__sed} -i 's|-g -Wall -Os|%{optflags}|' src/gui/Makefile
44%{__sed} -i 's|LDFLAGS= -Os -s|LDFLAGS=|' src/gui/Makefile
45
46%build
47%{__make} %{?_smp_mflags} SBINDIR="%{_sbindir}" gui
48
49# Replace copyrighted icons
50pushd src
51%{__make} nologo
52
53%install
54%{__rm} -rf %{buildroot}
55%{__make} install              \
56        DESTDIR="%{buildroot}" \
57        PREFIX="%{_prefix}"    \
58        SBINDIR="%{_sbindir}"  \
59        MANDIR="%{_mandir}"    \
60        INSTALL="%{__install} -p"
61
62%{__make} install-gui          \
63        DESTDIR="%{buildroot}" \
64        PREFIX="%{_prefix}"    \
65        SBINDIR="%{_sbindir}"  \
66        MANDIR="%{_mandir}"    \
67        INSTALL="%{__install} -p"
68
69%{__ln_s} -f gtk-lshw %{buildroot}%{_sbindir}/lshw-gui
70
71# desktop icon
72%{__install} -D -m 0644 -p ./src/gui/artwork/logo.svg \
73     %{buildroot}%{_datadir}/pixmaps/%{name}-logo.svg
74
75desktop-file-install --vendor ""  \
76  --dir %{buildroot}%{_datadir}/applications %{SOURCE1}
77
78# consolehelper
79%{__install} -d %{buildroot}%{_bindir}
80%{__ln_s} -f consolehelper %{buildroot}%{_bindir}/%{name}-gui
81%{__install} -D -m 0644 %{SOURCE2} \
82   %{buildroot}%{_sysconfdir}/security/console.apps/%{name}-gui
83%{__install} -D -m 0644 %{SOURCE3} \
84   %{buildroot}%{_sysconfdir}/pam.d/%{name}-gui
85
86%clean
87%{__rm} -rf %{buildroot}
88
89%files
90%defattr(-, root, root, -)
91%doc COPYING README docs/*
92%doc %{_mandir}/man1/lshw.1*
93%{_sbindir}/%{name}
94%dir %{_datadir}/%{name}
95%{_datadir}/%{name}/*.txt
96%{_datadir}/%{name}/*.ids
97
98%files gui
99%defattr(-, root, root, -)
100%doc COPYING
101%config(noreplace) %{_sysconfdir}/pam.d/%{name}-gui
102%config(noreplace) %{_sysconfdir}/security/console.apps/%{name}-gui
103%{_bindir}/%{name}-gui
104%{_sbindir}/gtk-%{name}
105%{_sbindir}/%{name}-gui
106%{_datadir}/%{name}/artwork
107%{_datadir}/pixmaps/%{name}-logo.svg
108%{_datadir}/applications/%{name}.desktop
109
110%changelog
111* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> B.02.13-1
112- new upstream release
113
114* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> B.02.12.01-0vl1
115- initial build for Vine Linux
116
117* Mon Nov  5 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.12.01-1
118- B.02.12.01
119- Replace trademark icons
120
121* Tue Aug 14 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-3
122- Move desktop and pam config to files
123- Simplify build
124
125* Tue Aug 07 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-2
126- Remove trademarks
127
128* Mon Aug 06 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11.01-1
129- B.02.11.01
130
131* Sun Aug 05 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-3
132- Move artwork to gui subpackage
133- Implement consolehelper support
134
135* Sat Aug 04 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-2
136- License is GPLv2 (only)
137- Fix ui %%description
138
139* Wed Aug 01 2007 Terje Rosten <terjeros@phys.ntnu.no> - B.02.11-1
140- Follow upstream version scheme
141
142* Wed Jul 25 2007 Terje Rosten <terjeros@phys.ntnu.no> - 2.11-1
143- 2.11
144
145* Wed Jun 27 2007 Terje Rosten <terjeros@phys.ntnu.no> - 2.10-2
146- minor fixes
147- add patch to avoid stripping
148- add desktop file
149- strip changelog
150- move from sbin to bin
151- new url
152
153* Wed Feb 14 2007 Dag Wieers <dag@wieers.com> - 2.10-1 - 4876+/dag
154- Updated to release B.02.10.
155
156* Tue Dec 21 2004 Dag Wieers <dag@wieers.com> - 2.0-1
157- Initial package. (using DAR)
158
Note: See TracBrowser for help on using the repository browser.