source: projects/specs/trunk/l/lookup/lookup-vl.spec @ 7411

Revision 7411, 5.7 KB checked in by iwaim, 11 years ago (diff)

lookup 1.4.1-2

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define emacsen_pkgdir /usr/lib/emacsen-common/packages
4%define origname lookup
5%define origver  1.4.1
6
7Summary:      a Search Interface for Emacsen
8Summary(ja):  Emacs 系のエディタで利用できる辞書検索インターフェース
9Name:         %{origname}
10Version:      %{origver}
11Release:      2%{?_dist_release}
12
13Source0:      http://openlab.jp/edict/lookup/dist/lookup-%{version}.tar.gz
14Source1:      %{origname}-install.sh
15Source2:      %{origname}-remove.sh
16Source10:     lookup-sample.dotemacs
17Source11:     lookup-init.el
18Source12:     vine-default-lookup.el
19Patch0:       lookup-1.4.1-void-e.patch
20
21License:      GPLv2+
22Group:        Applications/Editors/Emacs
23URL:          http://openlab.jp/edict/lookup/
24BuildRoot:    %{_tmppath}/%{name}-%{version}
25BuildArch:    noarch
26
27Requires:     emacsen flim apel
28BuildRequires: flim apel
29%prereq_ge    emacsen-common
30Requires:     /sbin/install-info
31Obsoletes:    lookup-emacs, lookup-xemacs
32Conflicts:    %{origname}-el
33
34Distribution: Vine Linux
35Vendor:       Project Vine
36Packager:     Tomoya TAKA <taka@vinelinux.org>
37
38
39%description
40Lookup is interface on Emacs to use some dictionaries.
41Lookup is developed by OpenLab, Ring Server Project.
42
43%description -l ja
44Lookup は Emacs 系のエディタで利用できる辞書検索インターフェースです。
45市販のCD-ROM 辞書やネットワークの辞書サーバを始め、様々な情報源から簡単な操作
46と設定で辞書検索が行なえます。
47
48
49%prep
50
51%setup -q -n %{origname}-%{origver}
52%patch0 -p 1
53
54%build
55
56%configure --prefix=%{_prefix} --infodir=%{_infodir}
57
58
59%install
60[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
61[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
62
63mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
64mkdir -p %{buildroot}%{emacsen_pkgdir}/install
65mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
66
67#
68# install el files
69#
70
71cp -p lisp/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
72cp -p lisp/*.el.in %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
73cp -p lisp/lookup-logo.* %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
74cp -p packages/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
75cp -p packages/dict-misc/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
76cp -p packages/jitenban97/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
77cp %{SOURCE11} %{SOURCE12} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/
78
79#
80# install script (bytecompile el and install elc , remove)
81#
82
83%_installemacsenscript %{origname} %{SOURCE1}
84
85%_removeemacsenscript  %{origname} %{SOURCE2}
86
87#
88# install info file
89#
90
91mkdir -p %{buildroot}%{_infodir}
92cp -p texi/lookup-guide.info %{buildroot}%{_infodir}
93cp -p texi/lookup.info* %{buildroot}%{_infodir}
94
95#
96# copy sample of ~/{.emacs.el,.xemacs.el}
97#
98
99cp %{SOURCE10} ./sample.dotemacs
100
101%clean
102[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
103
104%post
105#
106# bytecompile and install
107#
108
109if [ "$1" = 2 ]; then
110
111%_emacsenPackageRemove %{origname}
112
113fi
114
115%_addemacsenlist %{origname}
116
117%_emacsenPackageInstall %{origname}
118
119/sbin/install-info --info-dir=%{_infodir} %{_infodir}/lookup-guide.info.gz
120/sbin/install-info --info-dir=%{_infodir} %{_infodir}/lookup.info.gz
121
122%preun
123if [ "$1" = 0 ]; then
124
125%_emacsenPackageRemove %{origname}
126
127%_removeemacsenlist %{origname}
128
129/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/lookup-guide.info.gz
130/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/lookup.info.gz
131
132fi
133
134
135%files
136%defattr(-,root,root)
137%doc AUTHORS COPYING ChangeLog NEWS README VERSION
138%doc sample.dotemacs texi/*.texi
139%{_datadir}/emacs/site-lisp/%{origname}
140%{emacsen_pkgdir}/install/%{origname}
141%{emacsen_pkgdir}/remove/%{origname}
142%{_infodir}/*
143
144
145%changelog
146* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 1.4.1-2
147- add fix Symbol's value as variable is void patch (Patch0) for Emacs24
148- update License tag: GPL -> GPLv2+
149- replace PreReq to Requires: prereq is deprecated
150
151* Tue Mar 30 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.1-1
152- update to 1.4.1
153- add PreReq: apel
154- add BuildRequires: flim apel
155
156* Mon Dec 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.4-2
157- apply vine-default
158  - add lookup-init.el (Source11)
159  - add vine-default-lookup.el (Source12)
160  - update lookup-{install,remove}.sh
161- update sammary and description in English
162- rename Source10: sample.dotemacs to lookup-sample.dotemacs
163- add PreReq: flim :fixed <BTS:VineLinux:857>
164
165* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4-1vl5
166- applied new versioning policy, spec in utf-8
167- added %%emacsen_pkgdir macro
168
169* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4-0vl3
170- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
171- s/Copyright/License/
172
173* Fri Jul  2 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.4-0vl2
174- add missing SOURCES (ndeb-binary.el, ndnmz.el) in lookup-install.sh
175
176* Tue May  4 2004 IWAI, Masaharu <iwai@alib.jp> 1.4-0vl1
177- version up to 1.4 ( edict openlab version )
178- update URL and Source0 tags
179- update lookup-install.sh script: value of VERSION
180
181* Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 1.3-0vl4
182- rebuild
183
184* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3-0vl3
185- lookup-el -> lookup again
186
187* Sat Dec  9 2001 Tomoya TAKA <taka@vinelinux.org> 1.3-0vl1
188- emacsenize
189
190* Sun Jun 24 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
191- 1.3-0vl1
192- add Prereq: /sbin/install-info, handle info pages in %%post and %%preun
193- some fix on spec file, use rpm macros
194
195* Mon Jun 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
196- 1.2-0vl3
197- BuildArch: noarch
198
199* Wed Apr 26 2000 Masaki Kawamura <kawamura@ic.sci.yamaguchi-u.ac.jp>
200- release for the Vine Linux 2.0
Note: See TracBrowser for help on using the repository browser.