source: projects/specs/trunk/l/logrotate/logrotate-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Rotates, compresses, removes and mails system log files.
2Summary(ja): システムのログファイルを圧縮/削除するプログラム
3Name: logrotate
4Version: 3.7.7
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: https://fedorahosted.org/releases/l/o/logrotate/logrotate-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: popt
11Requires: coreutils >= 5.92
12Requires: popt
13
14%description
15The logrotate utility is designed to simplify the administration of
16log files on a system which generates a lot of log files.  Logrotate
17allows for the automatic rotation compression, removal and mailing of
18log files.  Logrotate can be set to handle a log file daily, weekly,
19monthly or when the log file gets to a certain size.  Normally,
20logrotate runs as a daily cron job.
21
22Install the logrotate package if you need a utility to deal with the
23log files on your system.
24
25%description -l ja
26logrotate ユーティリティは,ログファイルを大量に生成するシステムでの
27ログファイル管理を楽にする目的で作られています.
28logrotate はログファイルを古いものから順にリネームしたり,
29圧縮したり,メールで送ったりすることが出来ます.
30logrotate の処理は,毎日/毎週/毎月といった単位でも設定出来ますし,
31ログファイルが一定サイズに達した時に処理する様にすることも出来ます.
32通常は logrotate は cron によって毎日実行される様になっています.
33
34システム上のログファイルを管理するツールが必要なら
35logrotate パッケージをインストールして下さい.
36
37%prep
38%setup -q
39
40%build
41make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
42
43%install
44rm -rf $RPM_BUILD_ROOT
45make PREFIX=$RPM_BUILD_ROOT BINDIR=%{_sbindir} MANDIR=%{_mandir} install
46mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
47mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
48mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib
49
50install -m 644 examples/logrotate-default $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.conf
51install -m 755 examples/logrotate.cron $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/logrotate
52touch $RPM_BUILD_ROOT%{_localstatedir}/lib/logrotate.status
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(-,root,root)
59%doc CHANGES
60%attr(0755, root, root) %{_sbindir}/logrotate
61%attr(0644, root, root) %{_mandir}/man8/logrotate.8*
62%attr(0755, root, root) %{_sysconfdir}/cron.daily/logrotate
63%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/logrotate.conf
64%attr(0755, root, root) %dir %{_sysconfdir}/logrotate.d
65%attr(0644, root, root) %verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/logrotate.status
66
67%changelog
68* Sun Jun 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.7-1
69- new upstream release
70- spec in UTF-8
71
72* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.4-1vl1
73- based on 3.7.4-1 from Rawhide
74  * Wed May 17 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-1
75  - add new "minsize" option (#173088)
76  * Tue Mar 28 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.3-3
77  - correct man page "extension" option description  (#185318)
78  * Mon Nov 07 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-11
79  - man description for "nodateext" option (#171577)
80  - remove not working "pattern" option (#171577)
81  * Wed Sep 07 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-3
82  - even when sharedscript option used, do postrotate
83    script before compress (#167575)
84  * Wed Aug 17 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-2
85  - allow yearly rotations(#134612)
86  * Wed Jun 22 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.1-12
87  - enhance logrotate with "dateext", "maxage"
88
89* Fri Apr 11 2003 Ryoichi INAGAKI <ryo1@ueda.info.waseda.ac.jp> 3.6.8-1vl1
90- based on 3.6.8-1 from Rawhide
91- add Requires, BuildRequires popt
92  * Mon Jan 20 2003 Elliot Lee <sopwith@redhat.com> 3.6.8-1
93  - Old patch from pm@debian.org
94  * Tue Jan 14 2003 Elliot Lee <sopwith@redhat.com> 3.6.7-1
95  - Fixes from bugzilla
96  * Fri Nov 15 2002 Elliot Lee <sopwith@redhat.com> 3.6.6-1
97  - Commit patch from Fidelis Assis <fidelis@embratel.net.br>
98  * Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 3.6.5-1
99  - Commit fix for #65299
100  * Mon Apr 15 2002 Elliot Lee <sopwith@redhat.com> 3.6.4-1
101  - Commit fix for #62560
102  * Wed Mar 13 2002 Elliot Lee <sopwith@redhat.com> 3.6.3-1
103  - Apply various bugfix patches from the openwall people
104  * Tue Jan 29 2002 Elliot Lee <sopwith@redhat.com> 3.6.2-1
105  - Fix bug #55809 (include logrotate.status in %files)
106  - Fix bug #58328 (incorrect error detection when reading state file)
107  - Allow 'G' size specifier from bug #57242
108  * Wed Nov 28 2001 Preston Brown <pbrown@redhat.com> 3.6-1
109  - patch from Alexander Kourakos <awk@awks.org> to stop the shared
110    postrotate/prerotate scripts from running if none of the log(s) need
111    rotating.  All log files are now checked for rotation in one batch,
112    rather than sequentially.
113  - more fixes from Paul Martin <pm@debian.org>
114
115* Thu Oct  4 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 3.5.4-1vl2
116- added noreplace flag (%%config file is not replaced)
117
118* Sun Jan 14 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
119- 3.5.4-1vl1
120- based on 3.5.4-1 from Rawhide
121- use better macros (%%{_tmppath}, %%{_sbindir})
122- added Japanese summary and description
123
124* Thu Jan  4 2001 Bill Nottingham <notting@redhat.com>
125- %defattr
126
127* Wed Jan 03 2001 Preston Brown <pbrown@redhat.com>
128- see CHANGES
129
130* Tue Aug 15 2000 Erik Troan <ewt@redhat.com>
131- see CHANGES
132
133* Sun Jul 23 2000 Erik Troan <ewt@redhat.com>
134- see CHANGES
135
136* Tue Jul 11 2000 Erik Troan <ewt@redhat.com>
137- support spaces in filenames
138- added sharedscripts
139
140* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
141- use %%{_mandir} for man pages
142
143* Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
144- don't rotate lastlog
145
146* Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
147- gzipped manpages
Note: See TracBrowser for help on using the repository browser.