source: projects/specs/trunk/l/lmdb/lmdb-vl.spec @ 12284

Revision 12284, 6.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

lmdb-0.9.24-1

libmodsecurity-3.0.3-3

libssh2-1.9.0-1

nginx-1.16.1-2

proftpd-1.3.6b-1

ssdeep-2.14.1-8

yajl-2.1.0-1

Line 
1# The files themselves are in several subdirectories and need to be prefixed wit this.
2%global archive_path libraries/lib%{name}
3
4Name:           lmdb
5Version:        0.9.24
6Release:        1%{?_dist_release}
7Summary:        Memory-mapped key-value database
8Group:          Development/Libraries
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        OpenLDAP
14URL:            http://symas.com/mdb/
15Source0:        https://github.com/LMDB/lmdb/archive/LMDB_%{version}.tar.gz
16Source1:        lmdb.pc.in
17# Patch description in the corresponding file
18Patch0: lmdb-make.patch
19Patch1: lmdb-s390-check.patch
20
21BuildRequires: make
22BuildRequires: gcc
23BuildRequires: doxygen
24
25%description
26LMDB is an ultra-fast, ultra-compact key-value embedded data
27store developed by Symas for the OpenLDAP Project. By using memory-mapped files,
28it provides the read performance of a pure in-memory database while still
29offering the persistence of standard disk-based databases, and is only limited
30to the size of the virtual address space.
31
32%package        libs
33Summary:        Shared libraries for %{name}
34
35%description    libs
36The %{name}-libs package contains shared libraries necessary for running
37applications that use %{name}.
38
39%package        devel
40Summary:        Development files for %{name}
41Requires:       %{name}%{?_isa} = %{version}-%{release}
42
43%description    devel
44The %{name}-devel package contains libraries and header files for
45developing applications that use %{name}.
46
47%package        doc
48Summary:        Documentation files for %{name}
49BuildArch:      noarch
50
51%description    doc
52The %{name}-doc package contains automatically generated documentation for %{name}.
53
54
55%prep
56%setup -q -n %{name}-LMDB_%{version}
57%patch0 -p1 -b .make
58%patch1 -p1 -b .s390-check
59
60
61%build
62pushd %{archive_path}
63make XCFLAGS="%{optflags}" %{?_smp_mflags}
64# Build doxygen documentation
65doxygen
66# remove unpackaged files
67rm -f Doxyfile
68rm -rf man # Doxygen generated manpages
69popd
70
71%install
72pushd %{archive_path}
73# make install expects existing directory tree
74mkdir -m 0755 -p %{buildroot}{%{_bindir},%{_includedir}}
75mkdir -m 0755 -p %{buildroot}{%{_libdir}/pkgconfig,%{_mandir}/man1}
76make DESTDIR=%{buildroot} prefix=%{_prefix} libdir=%{_libdir} mandir=%{_mandir} install
77popd
78
79# Install pkgconfig file
80sed -e 's:@PREFIX@:%{_prefix}:g' \
81    -e 's:@EXEC_PREFIX@:%{_exec_prefix}:g' \
82    -e 's:@LIBDIR@:%{_libdir}:g' \
83    -e 's:@INCLUDEDIR@:%{_includedir}:g' \
84    -e 's:@PACKAGE_VERSION@:%{version}:g' \
85    %{SOURCE1} >lmdb.pc
86install -Dpm 0644 -t %{buildroot}%{_libdir}/pkgconfig lmdb.pc
87
88%check
89pushd %{archive_path}
90rm -rf testdb
91LD_LIBRARY_PATH=$PWD make test
92popd
93
94%post libs -p /sbin/ldconfig
95%postun libs -p /sbin/ldconfig
96
97
98%files
99%{_bindir}/*
100%{_mandir}/man1/*
101
102%files libs
103%doc %{archive_path}/COPYRIGHT
104%doc %{archive_path}/CHANGES
105%license %{archive_path}/LICENSE
106%{_libdir}/*.so.*
107
108%files devel
109%{_includedir}/*
110%{_libdir}/*.so
111%{_libdir}/pkgconfig/*.pc
112
113%files doc
114%doc %{archive_path}/html
115%doc %{archive_path}/COPYRIGHT
116%doc %{archive_path}/CHANGES
117%license %{archive_path}/LICENSE
118
119
120%changelog
121* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.24-1
122- initial build for Vine Linux.
123- new upstream release.
124
125* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-3
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
127
128* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
130
131* Wed Jan 09 2019 Tomas Krizek <tomas.krizek@nic.cz> - 0.9.23-1
132- Updated to 0.9.23
133
134* Mon Nov 05 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-4
135- Import upstream fix for rhbz#1645114
136
137* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.22-3
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
139
140* Mon Apr 23 2018 Florin Asavoaie <florin.asavoaie@gmail.com> - 0.9.22-2
141- Fixed Build Dependencies
142- Made build work on CentOS 7 for EPEL
143
144* Tue Apr 10 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-1
145- Updated to 0.9.22
146
147* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-4
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
149
150* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-3
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
152
153* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
155
156* Fri Jun 02 2017 Jan Stanek <jstanek@redhat.com> - 0.9.21-1
157- Update to 0.9.21
158
159* Mon Mar 20 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-3
160- Add pkgconfig file to devel subpackage
161
162* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.20-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
164
165* Thu Jan 12 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-1
166- Update to 0.9.20
167
168* Wed Jan 04 2017 Jan Stanek <jstanek@redhat.com> - 0.9.19-1
169- Update to 0.9.19
170
171* Wed Feb 10 2016 Jan Stanek <jstanek@redhat.com> - 0.9.18-1
172- Update to 0.9.18
173
174* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.17-3
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
176
177* Mon Dec 28 2015 Jan Vcelak <jvcelak@fedoraproject.org> 0.9.17-2
178- Make liblmdb.so a symbolic link to (not a copy of) the versioned DSO
179
180* Thu Dec 03 2015 Jan Staněk <jstanek@redhat.com> - 0.9.17-1
181- Update to 0.9.17
182
183* Wed Nov 25 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-2
184- Return the name 'Symas' into description
185
186* Fri Aug 14 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-1
187- Updated to 0.9.16
188
189* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.14-2
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
191
192* Thu Dec 11 2014 Jan Staněk <jstanek@redhat.com> - 0.9.14-1
193- Updated to 0.9.14
194
195* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.13-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
197
198* Fri Jul 18 2014 Jan Stanek <jstanek@redhat.com> - 0.9.13-1
199- Updated to 0.9.13
200
201* Mon Jul 14 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-4
202- Changed install instruction to be compatible with older coreutils (#1119084)
203
204* Thu Jun 26 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-3
205- Added delay in testing which was needed on s390* arches (#1104232)
206
207* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.11-2
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
209
210* Tue May 27 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-1
211- Initial Package
Note: See TracBrowser for help on using the repository browser.