source: projects/specs/trunk/l/lm-sensors/lm-sensors-vl.spec @ 2348

Revision 2348, 3.1 KB checked in by owa, 13 years ago (diff)

update: STLport, lm-sensors

Line 
1Summary: Linux hardware monitoring
2Summary(ja): Linux ハードウェア監視ソフト
3Name: lm-sensors
4Version: 3.2.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.lm-sensors.org/
9Source0: http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-%{version}.tar.bz2
10BuildRequires: sysfsutils-devel
11BuildRequires: bison, flex
12Requires: perl
13Requires: initscripts
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: shaolin, owa
18
19%description
20The lm-sensors package, version 3, provides user-space support for the
21hardware monitoring drivers in Linux 2.6.5 and later. For older kernel
22versions, you have to use lm-sensors version 2.
23
24Lm-sensors is a hardware health monitoring package for Linux.
25It allows you to access information from temperature, voltage,
26and fan speed sensors. It works with most newer systems.
27
28
29%package devel
30Summary: Development libraries and headers for %{name}
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description devel
35Development libraries and headers for %{name}.
36
37%prep
38%setup -q -n lm_sensors-%{version}
39
40%build
41make all
42
43%install
44rm -rf %{buildroot}
45make install \
46        PREFIX=%{buildroot}%{_prefix} \
47        LIBDIR=%{buildroot}%{_libdir} \
48        ETCDIR=%{buildroot}%{_sysconfdir} \
49        MANDIR=%{buildroot}%{_mandir}
50
51# add initscript from proc/init
52mkdir -p %{buildroot}%{_initdir}
53install -m755 prog/init/lm_sensors.init %{buildroot}%{_initdir}/lm_sensors
54
55# remove unuse files
56rm -f %{buildroot}/%{_libdir}/*.a
57
58%clean
59rm -rf %{buildroot}
60
61%post
62/sbin/ldconfig
63if [ "$1" = 1 ] ; then
64        /sbin/chkconfig --add lm_sensors
65fi
66%{_initdir}/lm_sensors condrestart
67
68%preun
69if [ "$1" = 0 ] ; then
70        %{_initdir}/lm_sensors stop > /dev/null 2>&1
71    /sbin/chkconfig --del lm_sensors
72fi
73
74%postun
75/sbin/ldconfig
76
77
78%files
79%defattr(-,root,root,-)
80%doc CHANGES CONTRIBUTORS COPYING INSTALL README doc
81%dir %{_sysconfdir}/sensors.d
82%config(noreplace) %{_sysconfdir}/sensors3.conf
83%config %{_initdir}/lm_sensors
84%{_bindir}/sensors
85%{_bindir}/sensors-conf-convert
86%{_sbindir}/fancontrol
87%ifarch %{ix86} x86_64
88%{_sbindir}/isadump
89%{_sbindir}/isaset
90%endif
91%{_sbindir}/pwmconfig
92%{_sbindir}/sensors-detect
93%{_libdir}/libsensors.so*
94%{_mandir}/*/*
95
96%files devel
97%{_includedir}/sensors
98
99%changelog
100* Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.0-1
101- updated lm-sensors to 3.2.0
102- added RQ: initscripts
103
104* Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
105- updated lm-sensors to 3.1.2
106
107* Tue Oct 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1.1-2
108- isadump/isaset only available on ix86/x86_64 archs
109
110* Mon Aug 31 2009 Shu KONNO <owa@bg.wakwak.com> 3.1.1-1
111- updated lm-sensors to 3.1.1
112- added japanese summary, spec in utf-8
113- added %{_initdir}/lm_sensors to %%files
114- added %%post, %%preun, %%postun scripts
115
116* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.10.7-1vl5
117- new upstream release
118- applied new versioning policy
119
120* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> - 2.10.3-0vl2
121- fixed libdir in Makefile (for support lib64)
122
123* Thu May 29 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.10.3-0vl1
124- Initial build.
125
Note: See TracBrowser for help on using the repository browser.