source: projects/specs/trunk/l/lm-sensors/lm-sensors-vl.spec @ 12075

Revision 12075, 4.9 KB checked in by tomop, 5 years ago (diff)

lm-sensors-3.5.0-1

RevLine 
[9229]1Summary: Hardware monitoring tools
2Summary(ja): ハードウェア監視ツール集
[521]3Name: lm-sensors
[12075]4Version: 3.5.0
[588]5Release: 1%{?_dist_release}
[9229]6
[12075]7%global ver_str %(echo -n "%{version}" | sed -e 's/\\./-/g')
8
[521]9Group: Applications/System
[9229]10License: LGPLv2+ and GPLv3+ and GPLv2+ and Verbatim and Public Domain
[12075]11URL: https://github.com/lm-sensors/lm-sensors
[9229]12
[12075]13Source0: https://github.com/lm-sensors/lm-sensors/archive/lm_sensors-%{version}.tar.gz#/lm-sensors-%{ver_str}.tar.gz
[9229]14Source1: lm_sensors.sysconfig
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: bison
18BuildRequires: flex
19BuildRequires: gawk
20BuildRequires: kernel-headers >= 2.2.16
[9796]21%if "%{_dist_release}" >= "vl7"
[9229]22BuildRequires: libsysfs-devel
[9796]23%else
24BuildRequires: sysfsutils-devel
25%endif
[9229]26BuildRequires: rrdtool-devel
27
[2348]28Requires: perl
29Requires: initscripts
[9229]30Requires(post): /sbin/chkconfig
31Requires(preun): /sbin/chkconfig
32
[521]33Vendor: Project Vine
34Distribution: Vine Linux
[588]35Packager: shaolin, owa
[521]36
37%description
[9229]38The lm-sensors package includes a collection of modules for general SMBus
39access and hardware monitoring.
[521]40
[9229]41%package libs
42Summary: Lm_sensors core libraries
43Summary(ja): Lm_sensors コアライブラリ
44Group: System Environment/Libraries
[521]45
[9229]46%description libs
47Core libraries for lm_sensors applications
[521]48
[9229]49
[521]50%package devel
[9229]51Summary: Development files for programs which will use lm_sensors
52Summary(ja): lm_sensors を使用するプログラムのための開発用ファイル
[521]53Group: Development/Libraries
[9229]54Requires: %{name}-libs = %{version}-%{release}
[521]55
56%description devel
[9229]57The %{name}-devel package includes a header files and libraries for use
58when building applications that make use of sensor data.
[521]59
[9229]60
61%package sensord
62Summary: Daemon that periodically logs sensor readings
63Summary(ja): センサーの読み取り値を定期的に記録するデーモン
64Group: System Environment/Daemons
65Requires: %{name} = %{version}-%{release}
66
67%description sensord
68Daemon that periodically logs sensor readings to syslog or a round-robin
69database, and warns of sensor alarms.
70
[521]71%prep
[12075]72%setup -q -n lm-sensors-%{ver_str}
[521]73
74%build
[9229]75export CFLAGS="%{optflags}"
76make PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} EXLDFLAGS=  user
[521]77
78%install
[9229]79rm -rf $RPM_BUILD_ROOT
80make user_install \
81     DESTDIR=$RPM_BUILD_ROOT \
82     PREFIX=%{_prefix} \
83     LIBDIR=%{_libdir} \
84     ETCDIR=%{_sysconfdir} \
85     MANDIR=%{_mandir}
[521]86
[9229]87ln -s sensors.conf.5.gz $RPM_BUILD_ROOT%{_mandir}/man5/sensors3.conf.5.gz
88
[521]89# add initscript from proc/init
[9229]90mkdir -p $RPM_BUILD_ROOT%{_initdir}
91mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sensors.d
92mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
93install -m755 prog/init/lm_sensors.init $RPM_BUILD_ROOT%{_initdir}/lm_sensors
94install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/lm_sensors
[521]95
96# remove unuse files
[9229]97rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
[521]98
99%clean
[9229]100rm -rf $RPM_BUILD_ROOT
[521]101
102%post
103if [ "$1" = 1 ] ; then
104        /sbin/chkconfig --add lm_sensors
105fi
106%{_initdir}/lm_sensors condrestart
107
108%preun
109if [ "$1" = 0 ] ; then
110        %{_initdir}/lm_sensors stop > /dev/null 2>&1
111    /sbin/chkconfig --del lm_sensors
112fi
113
[9229]114%post libs -p /sbin/ldconfig
[521]115
[9229]116%postun libs -p /sbin/ldconfig
[521]117
[9229]118
[521]119%files
120%defattr(-,root,root,-)
[12075]121%license COPYING
122%doc CHANGES CONTRIBUTORS INSTALL README doc
[521]123%dir %{_sysconfdir}/sensors.d
124%config(noreplace) %{_sysconfdir}/sensors3.conf
[9229]125%config(noreplace) %{_sysconfdir}/sysconfig/lm_sensors
[521]126%config %{_initdir}/lm_sensors
127%{_bindir}/sensors
128%{_bindir}/sensors-conf-convert
129%{_sbindir}/fancontrol
130%ifarch %{ix86} x86_64
131%{_sbindir}/isadump
132%{_sbindir}/isaset
133%endif
134%{_sbindir}/pwmconfig
135%{_sbindir}/sensors-detect
[9229]136%{_mandir}/man1/*
137%{_mandir}/man5/*
138%{_mandir}/man8/*
[521]139
[9229]140%files libs
141%{_libdir}/lib*.so.*
142
[521]143%files devel
144%{_includedir}/sensors
[9229]145%{_libdir}/lib*.so
146%{_mandir}/man3/*
[521]147
[9229]148
[521]149%changelog
[12075]150* Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.0-1
151- updated to 3.5.0.
152
[9796]153* Sat Nov  7 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 3.4.0-1
154- update to 3.4.0
155
[9229]156* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.3.5-1
157- updated to 3.3.5
158- built on current VineSeed
159- split libraries to libs subpackage
160
[3447]161* Tue Apr 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.0-1
162- new upstrem release 3.3.0
163
[2348]164* Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.0-1
165- updated lm-sensors to 3.2.0
166- added RQ: initscripts
167
[588]168* Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
169- updated lm-sensors to 3.1.2
170
[521]171* Tue Oct 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1.1-2
172- isadump/isaset only available on ix86/x86_64 archs
173
174* Mon Aug 31 2009 Shu KONNO <owa@bg.wakwak.com> 3.1.1-1
175- updated lm-sensors to 3.1.1
176- added japanese summary, spec in utf-8
177- added %{_initdir}/lm_sensors to %%files
178- added %%post, %%preun, %%postun scripts
179
180* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.10.7-1vl5
181- new upstream release
182- applied new versioning policy
183
184* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> - 2.10.3-0vl2
185- fixed libdir in Makefile (for support lib64)
186
[12075]187* Tue May 29 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.10.3-0vl1
[521]188- Initial build.
189
Note: See TracBrowser for help on using the repository browser.