source: projects/specs/trunk/l/llvm/llvm-vl.spec @ 11293

Revision 11293, 22.2 KB checked in by tomop, 6 years ago (diff)

llvm-3.8.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# Build options:
4# Components skipped by default:
5%bcond_with doxygen
6%bcond_with ocaml
7%bcond_with force_gold
8
9# Documentation install path
10%global llvmdocdir() %{_docdir}/%1-%{version}
11
12%define _unpackaged_files_terminate_build 1
13
14Name:           llvm
15Version:        3.8.1
16Release:        1%{?_dist_release}
17Summary:        The Low Level Virtual Machine
18Summary(ja):    LLVM - 低レベルバーチャルマシン
19
20Group:          Development/Languages
21License:        NCSA
22URL:            http://llvm.org/
23Source0:        http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
24Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
25Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
26Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
27
28# multilib fixes
29Source10:        llvm-config.h
30Source11:        clang-config.h
31
32# patches
33
34# added acc5-abi support
35Patch1: 0001-GCC-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
36Patch2: 0002-GCC-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
37
38# Vine Patch
39Patch1000: clang-3.8.1-driver-ld.gold.patch
40Patch1002: clang-3.8.1-driver-vine.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
43
44BuildRequires:  binutils-devel
45BuildRequires:  cmake
46BuildRequires:  bison
47BuildRequires:  chrpath
48BuildRequires:  flex
49BuildRequires:  gcc-c++ >= 3.4
50BuildRequires:  groff
51BuildRequires:  libffi-devel
52BuildRequires:  libstdc++-devel
53BuildRequires:  libstdc++-static
54BuildRequires:  libtool-ltdl-devel
55BuildRequires:  libxml2-devel
56BuildRequires:  ocaml-findlib
57BuildRequires:  ocaml-ctypes
58BuildRequires:  ocaml-ounit
59# for DejaGNU test suite
60BuildRequires:  dejagnu tcl-devel python
61%if %{with doxygen}
62BuildRequires:  doxygen graphviz
63%endif
64# pod2man
65BuildRequires:  perl
66# lldb
67BuildRequires:  swig
68BuildRequires:  libedit-devel
69BuildRequires:  python-devel >= 2.7
70
71Requires:       llvm-libs = %{version}-%{release}
72
73# LLVM is not supported on PPC64
74# http://llvm.org/bugs/show_bug.cgi?id=3729
75ExcludeArch:    ppc64
76
77%description
78LLVM is a compiler infrastructure designed for compile-time,
79link-time, runtime, and idle-time optimization of programs from
80arbitrary programming languages.  The compiler infrastructure includes
81mirror sets of programming tools as well as libraries with equivalent
82functionality.
83
84
85%package devel
86Summary:        Libraries and header files for LLVM
87Summary(ja):    LLVM のライブラリおよびヘッダファイル
88Group:          Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       libstdc++-devel
91Requires:       libffi-devel
92Provides:       llvm-static = %{version}-%{release}
93
94%description devel
95This package contains library and header files needed to develop new
96native programs that use the LLVM infrastructure.
97
98
99%package doc
100Summary:        Documentation for LLVM
101Summary(ja):    LLVM のドキュメント
102Group:          Documentation
103BuildArch:      noarch
104Requires:       %{name} = %{version}-%{release}
105# might seem redundant, but needed to kill off the old arch-ed -doc subpackage
106Obsoletes:      %{name}-doc < %{version}-%{release}
107
108%description doc
109Documentation for the LLVM compiler infrastructure.
110
111
112%package libs
113Summary:        LLVM shared libraries
114Summary(ja):    LLVM 共有ライブラリ
115Group:          System Environment/Libraries
116
117%description libs
118Shared libraries for the LLVM compiler infrastructure.
119
120%description libs -l ja
121LLVM コンパイラ基盤の共有ライブラリです.
122
123%package -n clang
124Summary:        A C language family front-end for LLVM
125Summary(ja):    LLVM の C 言語フロントエンド
126License:        NCSA
127Group:          Development/Languages
128Requires:       %{name} = %{version}-%{release}
129# clang requires gcc, clang++ requires libstdc++-devel
130Requires:       libstdc++-devel
131# remove clang-doc pacakge
132Obsoletes:      clang-doc < %{version}-%{release}
133
134%description -n clang
135clang: noun
136    1. A loud, resonant, metallic sound.
137    2. The strident call of a crane or goose.
138    3. C-language family front-end toolkit.
139
140The goal of the Clang project is to create a new C, C++, Objective C
141and Objective C++ front-end for the LLVM compiler. Its tools are built
142as libraries and designed to be loosely-coupled and extensible.
143
144%Package -n clang-libs
145Summary:        Runtime library for clang
146Summary(ja):    Clang のランタイムライブラリ
147Group:          System Environment/Libraries
148
149%description -n clang-libs
150Runtime library for clang.
151
152%description -n clang-libs -l ja
153Clang のランタイムライブラリです.
154
155%package -n clang-devel
156Summary:        Header files for clang
157Summary(ja):    Clang のヘッダファイル
158Group:          Development/Libraries
159Requires:       clang = %{version}-%{release}
160
161%description -n clang-devel
162This package contains header files for the Clang compiler.
163
164%description -n clang-devel -l ja
165Clang コンパイラのヘッダファイル集です.
166
167%package -n clang-analyzer
168Summary:        A source code analysis framework
169Summary(ja):    ソースコード分析フレームワーク
170License:        NCSA
171Group:          Development/Languages
172Requires:       clang = %{version}-%{release}
173# not picked up automatically since files are currently not instaled
174# in standard Python hierarchies yet
175Requires:       python
176
177%description -n clang-analyzer
178The Clang Static Analyzer consists of both a source code analysis
179framework and a standalone tool that finds bugs in C and Objective-C
180programs. The standalone tool is invoked from the command-line, and is
181intended to run in tandem with a build of a project or code base.
182
183#%package -n clang-doc
184#Summary:        Documentation for Clang
185#Summary(ja):    Clang のドキュメント
186#Group:          Documentation
187#Requires:       %{name} = %{version}-%{release}
188#
189#%description -n clang-doc
190#Documentation for the Clang compiler front-end.
191
192%package -n lldb
193Summary:        Next generation high-performance debugger
194Summary(ja):    高性能デバッガー
195License:        NCSA
196Group:          Development/Debuggers
197Requires:       %{name} = %{version}-%{release}
198
199%description -n lldb
200LLDB is a next generation, high-performance debugger. It is built as a set
201of reusable components which highly leverage existing libraries in the
202larger LLVM Project, such as the Clang expression parser and LLVM
203disassembler.
204
205%package -n lldb-devel
206Summary:        Header files for LLDB
207Summary(ja):    LLDB のヘッダファイル
208Group:          Development/Libraries
209Requires:       lldb = %{version}-%{release}
210
211%description -n lldb-devel
212This package contains header files for the LLDB debugger.
213
214
215%if %{with doxygen}
216%package apidoc
217Summary:        API documentation for LLVM
218Summary(ja):    LLVM の API ドキュメント
219Group:          Documentation
220BuildArch:      noarch
221Requires:       %{name}-docs = %{version}-%{release}
222
223%description apidoc
224API documentation for the LLVM compiler infrastructure.
225
226%package -n clang-apidoc
227Summary:        API documentation for Clang
228Summary(ja):    Clang の API ドキュメント
229Group:          Documentation
230BuildArch:      noarch
231
232%description -n clang-apidoc
233API documentation for the Clang compiler.
234%endif
235
236%if %{with ocaml}
237%package        ocaml
238Summary:        OCaml binding for LLVM
239Summary(ja):    LLVM の OCaml バインディング
240Group:          System Environment/Libraries
241Requires:       %{name} = %{version}-%{release}
242Requires:       ocaml
243
244%description    ocaml
245OCaml binding for LLVM.
246
247%package        ocaml-devel
248Summary:        Development files for %{name}-ocaml
249Summary(ja):    %{name}-ocaml の開発ファイル
250Group:          Development/Libraries
251Requires:       %{name}-devel = %{version}-%{release}
252Requires:       %{name}-ocaml = %{version}-%{release}
253Requires:       ocaml
254
255%description    ocaml-devel
256The %{name}-ocaml-devel package contains libraries and signature files
257for developing applications that use %{name}-ocaml.
258
259%package ocaml-doc
260Summary:        Documentation for %{name}-ocaml
261Summary(ja):    %{name}-ocaml のドキュメント
262Group:          Documentation
263BuildArch:      noarch
264Requires:       %{name}-ocaml = %{version}-%{release}
265# might seem redundant, but needed to kill off the old arch-ed -doc subpackage
266Obsoletes:      %{name}-ocaml-doc < %{version}-%{release}
267
268%description ocaml-doc
269HTML documentation for LLVM's OCaml binding.
270
271%endif
272
273# compat32'
274%package -n compat32-%{name}-libs
275Summary:        LLVM shared libraries
276Summary(ja):    LLVM 共有ライブラリ
277Group:          System Environment/Libraries
278Requires:       %{name}-libs = %{version}-%{release}
279
280%description -n compat32-%{name}-libs
281Shared libraries for the LLVM compiler infrastructure.
282
283
284%prep
285%setup -q -a1 -a2 -a3 -n llvm-%{version}.src
286rm -rf tools/clang tools/lldb projects/compiler-rt
287mv cfe-%{version}.src tools/clang
288mv compiler-rt-%{version}.src projects/compiler-rt
289mv lldb-%{version}.src tools/lldb
290
291# clang
292
293pushd tools/clang
294%patch1 -p1 -b .gcc_abi-1
295%patch2 -p1 -b .gcc_abi-2
296popd
297
298# Vine Linux
299%if %{with force_gold}
300pushd tools/clang
301%patch1000 -p1 -b .driver-ld.gold
302popd
303%endif
304%patch1002 -p1 -b .driver-vine
305
306sed -i -e 's/"ld"/"ld.gold"/' tools/clang/include/clang/Driver/ToolChain.h
307
308%build
309mkdir build
310cd build
311
312CFLAGS="%{optflags} -fno-strict-aliasing -Wno-error=format-security -fPIC"
313CXXFLAGS="%{optflags} -fno-strict-aliasing -Wno-error=format-security -fPIC -std=c++11"
314LDFLAGS="%{?__global_ldflags} -lpthread -ldl"
315
316%cmake .. \
317        -DBUILD_SHARED_LIBS:BOOL=OFF \
318        -DCMAKE_BUILD_TYPE=Release \
319        -DCMAKE_SHARED_LINKER_FLAGS="-Wl,-Bsymbolic -static-libstdc++" \
320%if 0%{?__isa_bits} == 64
321        -DLLVM_LIBDIR_SUFFIX=64 \
322%else
323        -DLLVM_LIBDIR_SUFFIX= \
324%endif
325        -DLLVM_TARGETS_TO_BUILD="X86;AMDGPU;PowerPC;NVPTX;SystemZ;AArch64;ARM;BPF;CppBackend" \
326        -DLLVM_ENABLE_LIBCXX:BOOL=OFF \
327        -DLLVM_ENABLE_ZLIB:BOOL=ON \
328        -DLLVM_ENABLE_FFI:BOOL=ON \
329        -DLLVM_ENABLE_RTTI:BOOL=ON \
330        -DLLVM_BINUTILS_INCDIR=%{_includedir} \
331        -DLLVM_BUILD_RUNTIME:BOOL=ON \
332        -DLLVM_INCLUDE_TOOLS:BOOL=ON \
333        -DLLVM_BUILD_TOOLS:BOOL=ON \
334        -DLLVM_INCLUDE_TESTS:BOOL=ON \
335        -DLLVM_BUILD_TESTS:BOOL=ON \
336        -DLLVM_INCLUDE_EXAMPLES:BOOL=ON \
337        -DLLVM_BUILD_EXAMPLES:BOOL=OFF \
338        -DLLVM_INCLUDE_UTILS:BOOL=ON \
339        -DLLVM_INSTALL_UTILS:BOOL=OFF \
340        -DLLVM_INCLUDE_DOCS:BOOL=ON \
341        -DLLVM_ENABLE_SPHINX:BOOL=OFF \
342%if %{with doxygen}
343        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
344%else
345        -DLLVM_ENABLE_DOXYGEN:BOOL=OFF \
346%endif
347        -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
348        -DLLVM_DYLIB_EXPORT_ALL:BOOL=ON \
349        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
350        -DLLVM_BUILD_EXTERNAL_COMPILER_RT:BOOL=ON \
351        -DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
352        -DLLVM_OPTIMIZED_TABLEGEN:BOOL=ON \
353        \
354        -DCLANG_ENABLE_ARCMT:BOOL=ON \
355        -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
356        -DCLANG_INCLUDE_DOCS:BOOL=ON \
357        -DCLANG_INCLUDE_TESTS:BOOL=ON \
358        -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
359        -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
360        -DLIB_SUFFIX= \
361        \
362        -DLLDB_PATH_TO_LLVM_BUILD=%{_prefix} \
363        -DLLDB_PATH_TO_CLANG_BUILD=%{_prefix} \
364        \
365        -DLLDB_DISABLE_CURSES:BOOL=OFF \
366        -DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
367        -DLLDB_DISABLE_PYTHON:BOOL=OFF \
368        \
369        -DPYTHON_EXECUTABLE:STRING=%{__python} \
370        -DPYTHON_VERSION_MAJOR:STRING=$(%{__python} -c "import sys; print sys.version_info.major") \
371        -DPYTHON_VERSION_MINOR:STRING=$(%{__python} -c "import sys; print sys.version_info.minor") \
372        -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
373
374# workaround for all-in-one build
375TMP_PWD=$(pwd)
376LD_LIBRARY_PATH="$TMP_PWD/%{_lib}" make %{?_smp_mflags}
377
378
379%install
380rm -rf %{buildroot}
381
382cd build
383make install DESTDIR=%{buildroot}
384
385# llvm
386
387install -m755 ./bin/lli-child-target %{buildroot}%{_bindir}/lli-child-target
388
389# fix multi-lib
390mv -v %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
391mv -v %{buildroot}%{_includedir}/llvm/Config/llvm-config{,-%{__isa_bits}}.h
392install -m 0644 %{SOURCE10} %{buildroot}%{_includedir}/llvm/Config/llvm-config.h
393
394
395# clang
396
397mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
398install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
399
400# remove git integration
401rm -vf %{buildroot}%{_bindir}/git-clang-format
402# remove editor integrations (bbedit, sublime, emacs, vim)
403rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
404rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
405rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
406rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
407# remove diff reformatter
408rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
409
410
411# lldb
412
413# remove static libraries
414#rm -fv %{buildroot}%{_libdir}/*.a
415
416# python: fix binary libraries location
417liblldb=$(basename $(readlink -e %{buildroot}%{_libdir}/liblldb.so))
418ln -vsf "../../../${liblldb}" %{buildroot}%{python_sitearch}/lldb/_lldb.so
419mv -v %{buildroot}%{python_sitearch}/readline.so %{buildroot}%{python_sitearch}/lldb/readline.so
420
421# remove bundled six.py
422rm -f %{buildroot}%{python_sitearch}/six.*
423
424
425# compiler-rt
426
427# move sanitizer lists to better place
428mkdir -p %{buildroot}%{_libdir}/clang/%{version}
429for file in asan_blacklist.txt msan_blacklist.txt dfsan_blacklist.txt cfi_blacklist.txt dfsan_abilist.txt; do
430        mv -v %{buildroot}%{_prefix}/${file} %{buildroot}%{_libdir}/clang/%{version}/ || :
431done
432
433# move sanitizer libs to better place
434#mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
435#mv -v %{buildroot}%{_prefix}/lib/linux/libclang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
436#mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
437#pushd %{buildroot}%{_libdir}/clang/%{version}/lib
438#for i in *.a *.syms *.so; do
439#        ln -s ../$i linux/$i
440#done
441
442rm -rf %{buildroot}%{_libdir}/python*
443
444
445%check
446# the || : is wrong, i know, but the git snaps fail to make check due to
447# broken makefiles in the doc dirs.
448cd build
449make check-all LIT_ARGS="-v -j4" | tee llvm-testlog.txt ||:
450make -C tools/clang/test TESTARGS="-v -j4" | tee clang-testlog.txt ||:
451
452%clean
453rm -rf %{buildroot}
454
455
456%post libs -p /sbin/ldconfig
457%postun libs -p /sbin/ldconfig
458
459%post -n clang-libs -p /sbin/ldconfig
460%postun -n clang-libs -p /sbin/ldconfig
461
462%post -n lldb -p /sbin/ldconfig
463%postun -n lldb -p /sbin/ldconfig
464
465
466%posttrans devel
467# link llvm-config to the platform-specific file;
468# use ISA bits as priority so that 64-bit is preferred
469# over 32-bit if both are installed
470alternatives \
471  --install \
472  %{_bindir}/llvm-config \
473  llvm-config \
474  %{_bindir}/llvm-config-%{__isa_bits} \
475  %{__isa_bits}
476
477%postun devel
478if [ $1 -eq 0 ]; then
479  alternatives --remove llvm-config \
480    %{_bindir}/llvm-config-%{__isa_bits}
481fi
482exit 0
483
484
485%files
486%defattr(-,root,root,-)
487%doc CREDITS.TXT README.txt
488%{_bindir}/bugpoint
489%{_bindir}/llc
490%{_bindir}/lli
491%{_bindir}/lli-child-target
492%{_bindir}/obj2yaml
493%{_bindir}/sancov
494%{_bindir}/verify-uselistorder
495%{_bindir}/yaml2obj
496%exclude %{_bindir}/llvm-config-%{__isa_bits}
497%{_bindir}/llvm*
498%{_bindir}/opt
499%dir %{_datadir}/llvm
500%exclude %{_mandir}/man1/scan-build.1.*
501%doc %{_mandir}/man1/*.1.*
502
503%files devel
504%defattr(-,root,root,-)
505#doc %{llvmdocdir %{name}-devel}/
506%{_bindir}/llvm-config-%{__isa_bits}
507%{_includedir}/%{name}
508%{_includedir}/%{name}-c
509%{_libdir}/*.a
510%{_libdir}/libLLVM.so
511%{_datadir}/%{name}/cmake
512
513%files libs
514%defattr(-,root,root,-)
515%doc LICENSE.TXT
516#config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
517#dir %{_libdir}/%{name}
518%{_libdir}/BugpointPasses.so
519%{_libdir}/libLLVM-*.so
520%{_libdir}/libLTO.so
521%{_libdir}/LLVMgold.so
522%exclude %{_libdir}/LLVMHello.so
523
524%files -n clang
525%defattr(-,root,root,-)
526#doc %{llvmdocdir clang}/
527%{_bindir}/clang*
528%{_bindir}/c-index-test
529%{_libdir}/clang
530
531%files -n clang-libs
532%defattr(-,root,root,-)
533%{_libdir}/libclang.so
534%{_libdir}/libclang.so.*
535
536%files -n clang-devel
537%defattr(-,root,root,-)
538#doc %{llvmdocdir clang-devel}/
539%{_includedir}/clang
540%{_includedir}/clang-c
541%dir %{_datadir}/clang/
542%{_datadir}/clang/cmake
543
544%files -n clang-analyzer
545%defattr(-,root,root,-)
546%{_bindir}/scan-build
547%{_bindir}/scan-view
548%{_libexecdir}/ccc-analyzer
549%{_libexecdir}/c++-analyzer
550%{_datadir}/scan-view
551%{_datadir}/scan-build
552%{_mandir}/man1/scan-build.1.*
553
554%files -n lldb
555%defattr(-,root,root,-)
556#doc %{llvmdocdir lldb}/
557%{_bindir}/lldb
558%{_bindir}/lldb-*
559%{_libdir}/liblldb.so.*
560
561%files -n lldb-devel
562%defattr(-,root,root,-)
563%{_includedir}/lldb
564%{_libdir}/liblldb.so
565
566#python-lldb
567#{python_sitearch}/*
568
569%files doc
570%defattr(-,root,root,-)
571%doc docs/*
572#doc %{llvmdocdir %{name}-doc}/
573
574%if %{with ocaml}
575%files ocaml
576%defattr(-,root,root,-)
577%{_libdir}/ocaml/*.cma
578%{_libdir}/ocaml/*.cmi
579%{_libdir}/ocaml/*.so
580%{_libdir}/ocaml/META.llvm*
581
582%files ocaml-devel
583%defattr(-,root,root,-)
584%{_libdir}/ocaml/*.a
585%{_libdir}/ocaml/*.cmx*
586%{_libdir}/ocaml/*.mli
587
588%files ocaml-doc
589%defattr(-,root,root,-)
590#doc %{llvmdocdir %{name}-ocaml-doc}/
591%endif
592
593%if 0%{?_with_doxygen}
594%files apidoc
595%defattr(-,root,root,-)
596%doc %{llvmdocdir %{name}-apidoc}/
597
598%files -n clang-apidoc
599%defattr(-,root,root,-)
600%doc %{llvmdocdir clang-apidoc}/
601%endif
602
603%if %{build_compat32}
604%files -n compat32-%{name}-libs
605%defattr(-,root,root)
606%doc LICENSE.TXT
607#config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
608%exclude %{_libdir}/libclang.so
609%exclude %{_libdir}/liblldb.so
610%exclude %{_libdir}/LLVMHello.so
611%{_libdir}/*.so
612%endif
613
614%changelog
615* Fri Aug  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
616- new upstream release.
617- switched to cmake.
618- disable ocaml binding as default.
619- updated Patch1000 and 1002.
620- disabled Patch1000 as default.
621- cleanup patches.
622
623* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
624- rebuild with gcc-5.4.0
625
626* Sat Sep  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
627- new upstream release
628- added BR: ocaml-ctypes
629
630* Thu Jun  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
631- new upstream release
632- dropt Patch 1, 201 and 1001
633- updated Patch 1000
634
635* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
636- updated to 3.5.1
637- added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
638- added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
639- obsoleted clang-doc
640- built with ocaml 4.02.1
641
642* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
643- fix <BTS:2832>
644  - fix configure option "--with-c-include-dirs"
645  - update Patch1000: clang-3.5.0-driver-ld.gold.patch
646  - update Patch1001: clang-3.5.0-driver-lib64.patch
647  - update Patch1002: clang-3.5.0-driver-vine.patch
648
649* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
650- update to 3.5.0
651- remove Patch11 (clang-hardfloat-hack.patch)
652
653* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
654- rebuild with libffi-3.0.13
655
656* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
657- update to 3.3
658
659* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
660- ld.gold (patch1000,1001)
661- add /%{_lib} to ld search path
662- add support *-vine-linux gcc (patch1002)
663
664* Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
665- update to 3.1
666
667* Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
668- updated to 3.0 release
669
670* Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
671- added patch 2-4 to support -O4 link-time optimization
672
673* Fri Sep  9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
674- disable -fno-var-tracking-assignments on ppc
675  (seems like gcc-4.4.5 still doesn't support this)
676
677* Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
678- new upstream release
679- add BR: libffi-devel
680- add R: libffi-devel to -devel
681
682* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
683- initial build for Vine Linux
684
685* Sun May  2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
686- Update to final 2.7 release
687
688* Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
689- Update to first 2.7 pre-release
690
691* Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
692- Update to 2.6 pre-release2
693- -devel subpackage now virtually provides -static
694
695* Wed Sep  9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
696- Disable var tracking assignments on PPC
697
698* Wed Sep  9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
699- Don't adjust clang include dir; files there are noarch (bz#521893)
700- Enable clang unit tests
701- clang and clang-analyzer renamed; no longer depend on llvm at runtime
702
703* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
704- Package Clang's static analyzer tools
705
706* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
707- PIC is now enabled by default; explicitly disable on %%{ix86}
708
709* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
710- First 2.6 prerelease
711- Enable Clang front-end
712- Enable debuginfo generation
713
714* Sat Sep  5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
715- Disable assertions (needed by OpenGTL, bz#521261)
716- Align spec file with upstream build instructions
717- Enable unit tests
718
719* Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
720- Only disable PIC on %%ix86; ppc actually needs it
721
722* Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
723- Disable use of position-independent code on 32-bit platforms
724  (buggy in LLVM <= 2.5)
725
726* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
727- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
728
729* Wed Mar  4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
730- Remove build scripts; they require the build directory to work
731
732* Wed Mar  4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
733- Update to 2.5
734- Package build scripts (bug #457881)
735
736* Tue Dec  2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
737- Patched build process for the OCaml binding
738
739* Tue Dec  2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
740- Update to 2.4
741- Package Ocaml binding
742
743* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
744- Add dependency on groff
745
746* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
747- LLVM 2.3
748
749* Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
750- fix license tags
751
752* Wed Mar  5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
753- Fix compilation problems with gcc 4.3
754
755* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
756- Autorebuild for GCC 4.3
757
758* Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
759- Fix review comments
760
761* Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
762- Initial version
Note: See TracBrowser for help on using the repository browser.