source: projects/specs/trunk/l/llvm/llvm-vl.spec @ 9470

Revision 9470, 21.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-25 Ryoichi INAGAKI <ryo1@…>

  • llvm: updated and added compat32 subpackage


RevLine 
[9470]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[1073]3# Build options:
[9470]4# Components skipped by default:
5%bcond_with doxygen
[1073]6
[9470]7# Documentation install path
8%global llvmdocdir() %{_docdir}/%1-%{version}
9
[1073]10Name:           llvm
[9470]11Version:        3.5.1
12Release:        1%{?_dist_release}
[1073]13Summary:        The Low Level Virtual Machine
14Summary(ja):    LLVM - 低レベルバーチャルマシン
15
16Group:          Development/Languages
17License:        NCSA
18URL:            http://llvm.org/
[9073]19Source0:        http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
20Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
21Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
[9470]22Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
[7943]23
[4656]24# multilib fixes
[7943]25Source10:        llvm-Config-config.h
26Source11:        llvm-Config-llvm-config.h
[4656]27
[9470]28# patches
29Patch1:         llvm-3.5.0-build-fix.patch
30Patch2:         0001-data-install-preserve-timestamps.patch
[1073]31
[9470]32# newish glibc hides the definition of __extern_always_inline behind
33# a check for gcc 4.3, clang pretends to be gcc 4.2.  a proper fix would
34# be to build everything herein with gcc, but i don't have the patience
35# atm, so in the interest of bootstrapping...
36Patch100:       clang-fake-gcc43.patch
37# http://llvm.org/bugs/show_bug.cgi?id=22625
38Patch101:       clang-pr22625.patch
[7197]39
[9470]40Patch200:       lldb-python.patch
41Patch201:       lldb-fix-expression-parser.patch
42Patch202:       lldb-python-module-symlink.patch
43
[7201]44# Vine Patch
[9121]45Patch1000: clang-3.5.0-driver-ld.gold.patch
46Patch1001: clang-3.5.0-driver-lib64.patch
47Patch1002: clang-3.5.0-driver-vine.patch
[7201]48
[1073]49BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
50
[5424]51BuildRequires:  binutils-devel
[1073]52BuildRequires:  bison
53BuildRequires:  chrpath
54BuildRequires:  flex
55BuildRequires:  gcc-c++ >= 3.4
56BuildRequires:  groff
[4656]57BuildRequires:  libffi-devel
[1073]58BuildRequires:  libtool-ltdl-devel
59BuildRequires:  ocaml
[9470]60BuildRequires:  perl
[1073]61# for DejaGNU test suite
62BuildRequires:  dejagnu tcl python
[9470]63%if %{with doxygen}
[1073]64BuildRequires:  doxygen graphviz
65%endif
[9470]66# lldb
67BuildRequires:  swig
68BuildRequires:  libedit-devel
69BuildRequires:  python-devel
70
[4656]71Requires:       llvm-libs = %{version}-%{release}
[1073]72
73# LLVM is not supported on PPC64
74# http://llvm.org/bugs/show_bug.cgi?id=3729
75ExcludeArch:    ppc64
76
77%description
78LLVM is a compiler infrastructure designed for compile-time,
79link-time, runtime, and idle-time optimization of programs from
80arbitrary programming languages.  The compiler infrastructure includes
81mirror sets of programming tools as well as libraries with equivalent
82functionality.
83
84
85%package devel
86Summary:        Libraries and header files for LLVM
87Summary(ja):    LLVM のライブラリおよびヘッダファイル
[9470]88Group:          Development/Libraries
[1073]89Requires:       %{name} = %{version}-%{release}
90Requires:       libstdc++-devel
[4656]91Requires:       libffi-devel
[1073]92Provides:       llvm-static = %{version}-%{release}
93
94%description devel
95This package contains library and header files needed to develop new
96native programs that use the LLVM infrastructure.
97
98
99%package doc
100Summary:        Documentation for LLVM
101Summary(ja):    LLVM のドキュメント
102Group:          Documentation
[9470]103BuildArch:      noarch
[1073]104Requires:       %{name} = %{version}-%{release}
[9470]105# might seem redundant, but needed to kill off the old arch-ed -doc subpackage
106Obsoletes:      %{name}-doc < %{version}-%{release}
[1073]107
108%description doc
109Documentation for the LLVM compiler infrastructure.
110
111
[4656]112%package libs
113Summary:        LLVM shared libraries
[9470]114Summary(ja):    LLVM 共有ライブラリ
[4656]115Group:          System Environment/Libraries
116
117%description libs
118Shared libraries for the LLVM compiler infrastructure.
119
120
[1073]121%package -n clang
122Summary:        A C language family front-end for LLVM
[9470]123Summary(ja):    LLVM の C 言語フロントエンド
[1073]124License:        NCSA
125Group:          Development/Languages
[9470]126Requires:       %{name} = %{version}-%{release}
127# clang requires gcc, clang++ requires libstdc++-devel
128Requires:       libstdc++-devel
129# remove clang-doc pacakge
130Obsoletes:      clang-doc < %{version}-%{release}
[1073]131
132%description -n clang
133clang: noun
134    1. A loud, resonant, metallic sound.
135    2. The strident call of a crane or goose.
136    3. C-language family front-end toolkit.
137
138The goal of the Clang project is to create a new C, C++, Objective C
139and Objective C++ front-end for the LLVM compiler. Its tools are built
140as libraries and designed to be loosely-coupled and extensible.
141
[9470]142%Package -n clang-libs
143Summary:        Runtime library for clang
144Summary(ja):    Clang のランタイムライブラリ
145Group:          System Environment/Libraries
[1073]146
[9470]147%description -n clang-libs
148Runtime library for clang.
149
150
[1073]151%package -n clang-devel
152Summary:        Header files for clang
[9470]153Summary(ja):    Clang のヘッダファイル
154Group:          Development/Libraries
[1073]155Requires:       clang = %{version}-%{release}
156
157%description -n clang-devel
158This package contains header files for the Clang compiler.
159
160
161%package -n clang-analyzer
162Summary:        A source code analysis framework
163Summary(ja):    ソースコー分析フレームワーク
164License:        NCSA
165Group:          Development/Languages
166Requires:       clang = %{version}-%{release}
167# not picked up automatically since files are currently not instaled
168# in standard Python hierarchies yet
169Requires:       python
170
171%description -n clang-analyzer
172The Clang Static Analyzer consists of both a source code analysis
173framework and a standalone tool that finds bugs in C and Objective-C
174programs. The standalone tool is invoked from the command-line, and is
175intended to run in tandem with a build of a project or code base.
176
[9470]177#%package -n clang-doc
178#Summary:        Documentation for Clang
179#Summary(ja):    Clang のドキュメント
180#Group:          Documentation
181#Requires:       %{name} = %{version}-%{release}
182#
183#%description -n clang-doc
184#Documentation for the Clang compiler front-end.
[1073]185
[9470]186%package -n lldb
187Summary:        Next generation high-performance debugger
188Summary(ja):    高性能デバッガー
189License:        NCSA
190Group:          Development/Debuggers
[1073]191Requires:       %{name} = %{version}-%{release}
192
[9470]193%description -n lldb
194LLDB is a next generation, high-performance debugger. It is built as a set
195of reusable components which highly leverage existing libraries in the
196larger LLVM Project, such as the Clang expression parser and LLVM
197disassembler.
[1073]198
[9470]199%package -n lldb-devel
200Summary:        Header files for LLDB
201Summary(ja):    LLDB のヘッダファイル
202Group:          Development/Libraries
203Requires:       lldb = %{version}-%{release}
[1073]204
[9470]205%description -n lldb-devel
206This package contains header files for the LLDB debugger.
207
208
209%if %{with doxygen}
[1073]210%package apidoc
211Summary:        API documentation for LLVM
212Summary(ja):    LLVM の API ドキュメント
[9470]213Group:          Documentation
214BuildArch:      noarch
[1073]215Requires:       %{name}-docs = %{version}-%{release}
216
217%description apidoc
218API documentation for the LLVM compiler infrastructure.
[9470]219
220%package -n clang-apidoc
221Summary:        API documentation for Clang
222Summary(ja):    Clang の API ドキュメント
223Group:          Documentation
224BuildArch:      noarch
225
226%description -n clang-apidoc
227API documentation for the Clang compiler.
[1073]228%endif
229
230%package        ocaml
231Summary:        OCaml binding for LLVM
232Summary(ja):    LLVM の OCaml バインディング
[9470]233Group:          System Environment/Libraries
[1073]234Requires:       %{name} = %{version}-%{release}
235Requires:       ocaml
236
237%description    ocaml
238OCaml binding for LLVM.
239
240%package        ocaml-devel
241Summary:        Development files for %{name}-ocaml
242Summary(ja):    %{name}-ocaml の開発ファイル
243Group:          Development/Libraries
244Requires:       %{name}-devel = %{version}-%{release}
245Requires:       %{name}-ocaml = %{version}-%{release}
246Requires:       ocaml
247
248%description    ocaml-devel
249The %{name}-ocaml-devel package contains libraries and signature files
250for developing applications that use %{name}-ocaml.
251
252%package ocaml-doc
253Summary:        Documentation for %{name}-ocaml
254Summary(ja):    %{name}-ocaml のドキュメント
255Group:          Documentation
[9470]256BuildArch:      noarch
[1073]257Requires:       %{name}-ocaml = %{version}-%{release}
[9470]258# might seem redundant, but needed to kill off the old arch-ed -doc subpackage
259Obsoletes:      %{name}-ocaml-doc < %{version}-%{release}
[1073]260
261%description ocaml-doc
262HTML documentation for LLVM's OCaml binding.
263
[9470]264# compat32'
265%package -n compat32-%{name}-libs
266Summary:        LLVM shared libraries
267Summary(ja):    LLVM 共有ライブラリ
268Group:          System Environment/Libraries
269Requires:       %{name}-libs = %{version}-%{release}
[1073]270
[9470]271%description -n compat32-%{name}-libs
272Shared libraries for the LLVM compiler infrastructure.
[1073]273
[9470]274
[1073]275%prep
[9470]276%setup -q -a1 -a2 -a3 -n llvm-%{version}.src
277rm -rf tools/clang tools/lldb projects/compiler-rt
[7943]278mv cfe-%{version}.src tools/clang
[9470]279mv compiler-rt-%{version}.src projects/compiler-rt
280mv lldb-%{version}.src tools/lldb
[1073]281
[9470]282%patch1 -p1
283%patch2 -p1
[1073]284
[9470]285# clang
286pushd tools/clang
287%patch100 -p1
288%patch101 -p0
289popd
[4656]290
[9470]291# lldb
292pushd tools/lldb
293# careful when recreating this patch...
294%patch200 -p1 -b .python
295%patch201 -p2
296%patch202 -p1
297sed -i s/@lib@/%{_lib}/g scripts/Python/modules/readline/Makefile
298popd
299
300# Vine Linux
[9121]301%patch1000 -p1 -b .driver-ld.gold
302%ifarch x86_64
303%patch1001 -p1 -b .driver-lib64
304%endif
305%patch1002 -p1 -b .driver-vine
[7201]306
[9470]307# fix library paths
308sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' configure
[9121]309sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config.in
310sed -i 's|/lib\>|/%{_lib}/%{name}|g' tools/llvm-config/llvm-config.cpp
[1073]311
312%build
[7943]313export CC=/usr/bin/gcc
314export CXX=/usr/bin/g++
[5555]315
[9470]316# -fno-devirtualize shouldn't be necessary, but gcc has scary template-related
317# bugs that make it so.  gcc 5 ought to be fixed.
[4656]318%configure \
[9470]319  --with-extra-options="-fno-devirtualize" \
320  --with-extra-ld-options=-Wl,-Bsymbolic \
[1073]321  --libdir=%{_libdir}/%{name} \
[4656]322  --datadir=%{_libdir}/%{name} \
[9470]323%if %{with doxygen}
[5555]324  --enable-doxygen \
[9470]325%else
326  --disable-doxygen \
[5555]327%endif
[7943]328%ifarch armv7hl armv7l
329  --with-cpu=cortex-a8 \
330  --with-tune=cortex-a8 \
331  --with-arch=armv7-a \
332  --with-float=hard \
333  --with-fpu=vfpv3-d16 \
334  --with-abi=aapcs-linux \
335%endif
[5555]336  --enable-targets=host \
[1073]337  --disable-assertions \
[7943]338  --enable-optimized \
[1073]339  --enable-jit \
[4656]340  --enable-libffi \
341  --enable-shared \
[7943]342  --enable-pic \
[9121]343  --with-c-include-dirs=%{_includedir}:$(echo %{_prefix}/lib/gcc/%{_target_cpu}*/*/include) \
[7197]344  --with-binutils-include=%{_includedir} \
[7943]345  --enable-targets=x86,powerpc,arm,aarch64,cpp,nvptx \
[9470]346  --enable-experimental-targets=R600 \
347  --with-optimize-option=-O3
[4656]348 
[9470]349make %{?_smp_mflags} REQUIRES_RTTI=1 VERBOSE=1
[1073]350
351%install
352rm -rf %{buildroot}
[5555]353
[1073]354make install DESTDIR=%{buildroot} \
355     PROJ_docsdir=/moredocs
[4656]356
[9121]357# you have got to be kidding me
358rm -f %{buildroot}%{_bindir}/{FileCheck,count,not}
359
[4656]360# multilib fixes
361mv %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
362
363pushd %{buildroot}%{_includedir}/llvm/Config
364mv config.h config-%{__isa_bits}.h
[7943]365cp -p %{SOURCE10} config.h
[4656]366mv llvm-config.h llvm-config-%{__isa_bits}.h
[7943]367cp -p %{SOURCE11} llvm-config.h
[1073]368popd
369
370# Create ld.so.conf.d entry
371mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
372cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
373%{_libdir}/llvm
374EOF
375
376# Static analyzer not installed by default:
377# http://clang-analyzer.llvm.org/installation#OtherPlatforms
[9470]378# scan-view
379mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/
380cp -pr tools/clang/tools/scan-view %{buildroot}%{_libexecdir}/clang-analyzer/
381
382# scan-build
383mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/scan-build
384for file in c++-analyzer ccc-analyzer scan-build scanview.css sorttable.js; do
385    cp -p tools/clang/tools/scan-build/$file \
386       %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/
387done
388
389# scan-build manual page
390mkdir -p %{buildroot}%{_mandir}/man1
391cp -p tools/clang/tools/scan-build/scan-build.1 %{buildroot}%{_mandir}/man1/
392
393# scan-build requires clang in search path
394ln -s ../../../bin/clang %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/clang
395
396# launchers in /bin
[1073]397for f in scan-{build,view}; do
[9470]398  ln -s %{_libexecdir}/clang-analyzer/$f/$f %{buildroot}%{_bindir}/$f
[1073]399done
400
[9470]401# Get rid of erroneously installed example files.
402rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
[1073]403
[9470]404# remove executable bit from static libraries
405find %{buildroot}%{_libdir} -name "*.a" -type f -print0 | xargs -0 chmod -x
[1073]406
[9470]407# Install man page for LLDB
408mkdir -p %{buildroot}%{_mandir}/man1
409cp tools/lldb/docs/lldb.1 %{buildroot}%{_mandir}/man1/
[1073]410
[9470]411# llvm-doc
412mkdir -p %{buildroot}%{llvmdocdir %{name}-doc}
413cp -ar examples %{buildroot}%{llvmdocdir %{name}-doc}/examples
414find %{buildroot}%{llvmdocdir %{name}-doc} -name Makefile -o -name CMakeLists.txt -o -name LLVMBuild.txt -print0 | xargs -0 rm -f
415
416# llvm-apidoc
417%if %{with doxygen}
418mv %{buildroot}/moredocs/html/doxygen %{buildroot}%{llvmdocdir %{name}-apidoc}
[4656]419%endif
420
[9470]421# llvm-ocaml-doc
422mv %{buildroot}/moredocs/ocamldoc/html %{buildroot}%{llvmdocdir %{name}-ocaml-doc}
423
424# clang
425mkdir -p %{buildroot}%{llvmdocdir clang}
426for f in LICENSE.TXT NOTES.txt README.txt CODE_OWNERS.TXT; do
427  cp tools/clang/$f %{buildroot}%{llvmdocdir clang}/
[1073]428done
429
[9470]430# clang-apidoc
431%if %{with doxygen}
432cp -ar tools/clang/docs/doxygen/html %{buildroot}%{llvmdocdir clang-apidoc}
433%endif
[1073]434
[9470]435# lldb
436mkdir -p %{buildroot}%{llvmdocdir lldb}
437cp tools/lldb/LICENSE.TXT %{buildroot}%{llvmdocdir lldb}/
[1073]438
[9470]439# delete the rest of installed documentation (because it's bad)
440rm -rf %{buildroot}/moredocs
[1073]441
[9470]442# install CMake modules
443mkdir -p %{buildroot}%{_datadir}/llvm/cmake/
444cp -p cmake/modules/*.cmake %{buildroot}%{_datadir}/llvm/cmake/
[1073]445
[9470]446# remove RPATHs
447file %{buildroot}/%{_bindir}/* | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
448file %{buildroot}/%{_libdir}/%{name}/*.so | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
[1073]449
450
[4656]451%check
452make check 2>&1 | tee ../llvm-testlog.txt
453make -C tools/clang/test 2>&1 | tee ../llvm-testlog.txt
454
455
[1073]456%clean
457rm -rf %{buildroot}
458
459
[4656]460%post libs -p /sbin/ldconfig
[9470]461%postun libs -p /sbin/ldconfig
[1073]462
[9470]463%post -n clang-libs -p /sbin/ldconfig
464%postun -n clang-libs -p /sbin/ldconfig
[1073]465
[9470]466%post -n lldb -p /sbin/ldconfig
467%postun -n lldb -p /sbin/ldconfig
[1073]468
469
[4656]470%posttrans devel
471# link llvm-config to the platform-specific file;
472# use ISA bits as priority so that 64-bit is preferred
473# over 32-bit if both are installed
474alternatives \
475  --install \
476  %{_bindir}/llvm-config \
477  llvm-config \
478  %{_bindir}/llvm-config-%{__isa_bits} \
479  %{__isa_bits}
480
481%postun devel
482if [ $1 -eq 0 ]; then
483  alternatives --remove llvm-config \
484    %{_bindir}/llvm-config-%{__isa_bits}
485fi
486exit 0
487
488
[1073]489%files
490%defattr(-,root,root,-)
[9470]491%doc CREDITS.TXT README.txt
[1073]492%{_bindir}/bugpoint
493%{_bindir}/llc
494%{_bindir}/lli
[9121]495%{_bindir}/lli-child-target
[4656]496%exclude %{_bindir}/llvm-config-%{__isa_bits}
[1073]497%{_bindir}/llvm*
[4656]498%{_bindir}/macho-dump
[1073]499%{_bindir}/opt
[9470]500%dir %{_datadir}/llvm
[1073]501%exclude %{_mandir}/man1/clang.1.*
[9470]502%exclude %{_mandir}/man1/scan-build.1.*
503%exclude %{_mandir}/man1/lldb.1.*
[1073]504%doc %{_mandir}/man1/*.1.*
505
506%files devel
507%defattr(-,root,root,-)
[9470]508#doc %{llvmdocdir %{name}-devel}/
[4656]509%{_bindir}/llvm-config-%{__isa_bits}
[1073]510%{_includedir}/%{name}
511%{_includedir}/%{name}-c
512%{_libdir}/%{name}/*.a
[9073]513%{_datadir}/%{name}/cmake
[1073]514
[4656]515%files libs
516%defattr(-,root,root,-)
[9470]517%doc LICENSE.TXT
[4656]518%config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
519%dir %{_libdir}/%{name}
520%exclude %{_libdir}/%{name}/libclang.so
[9470]521%exclude %{_libdir}/%{name}/liblldb.so
[4656]522%{_libdir}/%{name}/*.so
523
[1073]524%files -n clang
525%defattr(-,root,root,-)
[9470]526%doc %{llvmdocdir clang}/
[1073]527%{_bindir}/clang*
[7197]528%{_bindir}/c-index-test
[1073]529%{_prefix}/lib/clang
530%doc %{_mandir}/man1/clang.1.*
531
[9470]532%files -n clang-libs
533%defattr(-,root,root,-)
534%{_libdir}/%{name}/libclang.so
535
[1073]536%files -n clang-devel
537%defattr(-,root,root,-)
[9470]538#doc %{llvmdocdir clang-devel}/
[1073]539%{_includedir}/clang
540%{_includedir}/clang-c
541
542%files -n clang-analyzer
543%defattr(-,root,root,-)
544%{_bindir}/scan-build
545%{_bindir}/scan-view
[9470]546%{_libexecdir}/clang-analyzer
547%{_mandir}/man1/scan-build.1.*
[1073]548
[9470]549%files -n lldb
[1073]550%defattr(-,root,root,-)
[9470]551%doc %{llvmdocdir lldb}/
552%{_bindir}/lldb
553%{_bindir}/lldb-*
554%{_libdir}/%{name}/liblldb.so
555# XXX double check this
556%{python_sitearch}/*
557%doc %{_mandir}/man1/lldb.1.*
[1073]558
[9470]559%files -n lldb-devel
560%defattr(-,root,root,-)
561%{_includedir}/lldb
562
[1073]563%files doc
564%defattr(-,root,root,-)
[9470]565%doc %{llvmdocdir %{name}-doc}/
[1073]566
567%files ocaml
568%defattr(-,root,root,-)
569%{_libdir}/ocaml/*.cma
570%{_libdir}/ocaml/*.cmi
[9073]571%{_libdir}/ocaml/*.so
572%{_libdir}/ocaml/META.llvm*
[1073]573
574%files ocaml-devel
575%defattr(-,root,root,-)
576%{_libdir}/ocaml/*.a
577%{_libdir}/ocaml/*.cmx*
578%{_libdir}/ocaml/*.mli
579
580%files ocaml-doc
581%defattr(-,root,root,-)
[9470]582%doc %{llvmdocdir %{name}-ocaml-doc}/
[1073]583
[4656]584%if 0%{?_with_doxygen}
[1073]585%files apidoc
586%defattr(-,root,root,-)
[9470]587%doc %{llvmdocdir %{name}-apidoc}/
[4656]588
589%files -n clang-apidoc
590%defattr(-,root,root,-)
[9470]591%doc %{llvmdocdir clang-apidoc}/
[1073]592%endif
593
[9470]594%if %{build_compat32}
595%files -n compat32-%{name}-libs
596%defattr(-,root,root)
597%doc LICENSE.TXT
598%config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
599%dir %{_libdir}/%{name}
600%exclude %{_libdir}/%{name}/libclang.so
601%exclude %{_libdir}/%{name}/liblldb.so
602%{_libdir}/%{name}/*.so
603%endif
[1073]604
[4656]605%changelog
[9470]606* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
607- updated to 3.5.1
608- added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
609- added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
610- obsoleted clang-doc
611- built with ocaml 4.02.1
612
[9121]613* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
614- fix <BTS:2832>
615  - fix configure option "--with-c-include-dirs"
616  - update Patch1000: clang-3.5.0-driver-ld.gold.patch
617  - update Patch1001: clang-3.5.0-driver-lib64.patch
618  - update Patch1002: clang-3.5.0-driver-vine.patch
619
[9073]620* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
621- update to 3.5.0
622- remove Patch11 (clang-hardfloat-hack.patch)
623
[8758]624* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
625- rebuild with libffi-3.0.13
626
[7943]627* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
628- update to 3.3
629
[7201]630* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
631- ld.gold (patch1000,1001)
632- add /%{_lib} to ld search path
633- add support *-vine-linux gcc (patch1002)
634
[7197]635* Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
636- update to 3.1
637
[5555]638* Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
639- updated to 3.0 release
640
[5424]641* Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
642- added patch 2-4 to support -O4 link-time optimization
643
[4738]644* Fri Sep  9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
645- disable -fno-var-tracking-assignments on ppc
646  (seems like gcc-4.4.5 still doesn't support this)
647
[4656]648* Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
649- new upstream release
650- add BR: libffi-devel
651- add R: libffi-devel to -devel
[1073]652
653* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
654- initial build for Vine Linux
655
656* Sun May  2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
657- Update to final 2.7 release
658
659* Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
660- Update to first 2.7 pre-release
661
662* Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
663- Update to 2.6 pre-release2
664- -devel subpackage now virtually provides -static
665
666* Wed Sep  9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
667- Disable var tracking assignments on PPC
668
669* Wed Sep  9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
670- Don't adjust clang include dir; files there are noarch (bz#521893)
671- Enable clang unit tests
672- clang and clang-analyzer renamed; no longer depend on llvm at runtime
673
674* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
675- Package Clang's static analyzer tools
676
677* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
678- PIC is now enabled by default; explicitly disable on %%{ix86}
679
680* Mon Sep  7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
681- First 2.6 prerelease
682- Enable Clang front-end
683- Enable debuginfo generation
684
685* Sat Sep  5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
686- Disable assertions (needed by OpenGTL, bz#521261)
687- Align spec file with upstream build instructions
688- Enable unit tests
689
690* Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
691- Only disable PIC on %%ix86; ppc actually needs it
692
693* Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
694- Disable use of position-independent code on 32-bit platforms
695  (buggy in LLVM <= 2.5)
696
697* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
698- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
699
700* Wed Mar  4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
701- Remove build scripts; they require the build directory to work
702
703* Wed Mar  4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
704- Update to 2.5
705- Package build scripts (bug #457881)
706
707* Tue Dec  2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
708- Patched build process for the OCaml binding
709
710* Tue Dec  2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
711- Update to 2.4
712- Package Ocaml binding
713
714* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
715- Add dependency on groff
716
717* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
718- LLVM 2.3
719
720* Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
721- fix license tags
722
723* Wed Mar  5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
724- Fix compilation problems with gcc 4.3
725
726* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
727- Autorebuild for GCC 4.3
728
729* Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
730- Fix review comments
731
732* Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
733- Initial version
Note: See TracBrowser for help on using the repository browser.