source: projects/specs/trunk/l/linuxconf/linuxconf-vl.spec @ 521

Revision 521, 19.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An extremely capable system configuration tool.
2Summary(ja): ¤­¤ï¤á¤Æ¹âµ¡Ç½¤Ê¥·¥¹¥Æ¥àÀßÄê¥Ä¡¼¥ë
3Name: linuxconf
4Version: 1.24r6
5Release: 0vl3
6License: GPL
7Group: Applications/System
8Url: http://www.solucorp.qc.ca/linuxconf/
9Source: ftp://ftp.solucorp.qc.ca/pub/linuxconf/devel/src/linuxconf-%{version}.src.tar.gz
10#Source1: linuxconf.power.gif
11Patch1: linuxconf-1.16r8-wvf.patch
12Patch3: linuxconf-1.17r7-gcc.patch
13Patch4: linuxconf-1.17r2-nooptalpha.patch
14Patch5: linuxconf-1.17r2-internaldaemons.patch
15Patch6: linuxconf-1.24r2-named.patch
16Patch10: linuxconf-1.24r2-pppquoting.patch
17Patch11: linuxconf-1.19-dlopengd.patch
18Patch12: linuxconf-1.18r5-system-auth.patch
19Patch13: linuxconf-1.18r7-ia64.patch
20Patch14: linuxconf-1.19r1-noegcs.patch
21Patch16: linuxconf-1.19r2-translate.patch
22Patch17: linuxconf-1.24r6-range.patch
23Patch18: linuxconf-broken-routes.patch
24Patch19: linuxconf-1.25r7-libs.patch
25
26# sources/patches for Japanese by Vine
27Source100: linuxconf-1.19r1-ja-0.7.3.tar.gz
28Source101: linuxconf-vine.power.gif
29Patch100: linuxconf-1.16r3.2-lastlang.patch
30Patch101: linuxconf-1.16r3.2-euc.patch
31Patch102: linuxconf-1.21r3-vlconf.patch
32Patch104: linuxconf-1.21r3-nonroot.patch
33Patch105: linuxconf-1.24r6-postinst.patch
34Patch106: linuxconf-1.24r6-vine.patch
35Patch107: linuxconf-1.24r6-time.patch
36
37# from misc/module.h
38%define MODULE_API_VERSION 18
39Provides: LINUXCONFAPIREV%{MODULE_API_VERSION}
40Requires: initscripts >= 3.79
41Requires: gd >= 1.7
42Prereq: /usr/sbin/groupadd
43Prereq: setup
44Prereq: /bin/mktemp
45Prereq: sh-utils fileutils textutils grep chkconfig
46Prereq: pam util-linux
47BuildPreReq: gd >= 1.7 , perl
48BuildPrereq:  python-devel
49Obsoletes: usercfg fstool cabaret
50AutoReqProv: no
51BuildRoot: %{_tmppath}/%{name}-root
52Vendor: Project Vine
53Distribution: Vine Linux
54
55%description
56Linuxconf is an extremely capable system configuration tool.
57Linuxconf provides four different interfaces for you to choose from:
58command line, character-cell (like the installation program), an X
59Window System based GUI and a web-based interface.  Linuxconf can
60manage a large proportion of your system's operations, including
61networking, user accounts, file systems, boot parameters, and more.
62
63Linuxconf will simplify the process of configuring your system.
64Unless you are completely happy with configuring your system manually,
65you should install the linuxconf package and use linuxconf instead.
66
67%package devel
68Summary: The tools needed for developing linuxconf modules.
69Summary(ja): Linuxconf¥â¥¸¥å¡¼¥ë¤Î³«È¯¤ËɬÍפʥġ¼¥ë
70Group: Development/Libraries
71Requires: linuxconf = %{version}-%{release}
72
73%description devel
74Linuxconf is an extremely capable system configuration tool.  It
75provides a variety of interfaces through which you can configure your
76Linux system and manage a large proportion of the system's operations.
77
78This package provides the components necessary for developing
79Linuxconf modules outside of the linuxconf source tree and/or
80developing stand-alone utilities using the linuxconf interface
81toolkit.
82
83Install linuxconf-devel if you want to develop Linuxconf modules.  You
84must also have linuxconf installed.
85
86
87%prep
88%setup -q -a 100
89(cd conf.files/redhat/scripts
90 mv S99linuxconf linuxconf
91 chmod 755 linuxconf
92 rm -f S00linuxconf
93 rm -f grabinfo.sh)
94#%patch1 -p1 -b .wvf
95#%ifarch alpha
96#%patch4 -p0 -b .nooptalpha
97#%endif
98%patch5 -p0 -b .internaldaemons
99%patch6 -p1 -b .named
100
101%patch10 -p1 -b .pppquoting
102%patch11 -p1 -b .dlopengd
103%patch12 -p1 -b .system-auth
104%patch13 -p1 -b .ia64
105#not aplied for Vine
106#%patch14 -p1 -b .egcs
107%patch16 -p1 -b .translate
108%patch17 -p1 -b .range
109%patch18 -p1 -b .routes
110%patch19 -p1 -b .libs
111
112%{__cp} -p %{SOURCE101} images/power.gif
113%patch100 -p1 -b .lastlang
114%patch101 -p1 -b .euc
115%patch102 -p1
116%patch104 -p1 -b .noroot
117%patch105 -p1 -b .postinst
118%patch106 -p1
119%patch107 -p1 -b .time
120
121
122%build
123# remove check of permission of sendmail
124rm conf.files/redhat/perm/mail
125
126# lynx -> w3m
127find ./ -type f|xargs perl -i -ne 's/[Ll][Yy][Nn][Xx]/w3m/g;print'
128make
129
130%install
131rm -rf %{buildroot}
132# do not install patched files
133find conf.files -name "*.rhconf" | xargs rm -f
134
135make install_for_rpm
136
137mkdir -p %{buildroot}/var/log
138for file in htmlaccess netconf ; do
139        touch %{buildroot}/var/log/$file.log
140        chmod 600 %{buildroot}/var/log/$file.log
141done
142
143rm -f %{buildroot}/usr/lib/linuxconf/install/*{caldera,conectiva,debian,suse}*
144cp %{buildroot}/usr/lib/linuxconf/install/conf.linuxconf-redhat-4.x  %{buildroot}/etc/conf.linuxconf
145
146make install-devel
147
148(cd %{buildroot}/usr/lib/linuxconf; find . -type f -print) |
149  grep -v '^\./help\.' | grep -v '^\.$' |
150  sed 's:^\./:/usr/lib/linuxconf/:g' > libfiles
151(cd %{buildroot}/usr/lib/linuxconf; find . -type d -print) |
152  grep -v '^\./help\.' | grep -v '^\.$' |
153  sed 's:^\./:%dir /usr/lib/linuxconf/:g' >> libfiles
154
155# Install shared libraries.
156make install-lib
157
158%clean
159if [ "%{buildroot}" != "/" ] ; then
160        rm -rf %{buildroot}
161fi
162
163%pre
164OLDINSTALL=/usr/lib/linuxconf/help.eng/notices/01-oldinstall
165INITTABREPLACE=/usr/lib/linuxconf/uninstall/inittab.replace
166UPGRADE="NO"
167
168# Check for tarball installation
169if [ -f /usr/lib/linuxconf/conf.daemons ] ; then
170        UPGRADE="YES"
171fi
172
173if [ -f /usr/lib/linuxconf/std/conf.daemons ] ; then
174        UPGRADE="YES"
175fi
176
177# Check for old 1.9r22 RPM installation
178if [ -f /usr/lib/linuxconf/install/doinst.sh ] ; then
179        UPGRADE="YES"
180fi
181
182if [ $UPGRADE = "YES" ] ; then
183        # Script to upgrade pre-1.9r25 Linuxconf to new SysV compliant booting.
184        # Dale - Hacked in a few minutes late one night :-)
185
186        # Kill the Install directory
187        if [ -f /install/doinst.sh ] ; then
188                rm -Rf /install
189        fi
190
191        # Kill the old /usr/lib/linuxconf directory, the RPM will put
192        # everything we need back in later.
193        rm -Rf /usr/lib/linuxconf
194
195        # Create the directories we will need for the upgrade
196        install -d -g users -m 755 -o root /usr/lib/linuxconf/
197        install -d -g users -m 755 -o root /usr/lib/linuxconf/help.eng/notices/
198        install -d -g users -m 755 -o root /usr/lib/linuxconf/uninstall/
199
200        # Create a note displayed by linuxconf informing that the RPM
201        # install has done some cleanup
202        echo "      Installation note" >$OLDINSTALL
203        echo >>$OLDINSTALL
204        echo "The RPM installation has detected that linuxconf was already" >>$OLDINSTALL
205        echo "installed using the tar.gz kit" >>$OLDINSTALL
206        echo >>$OLDINSTALL
207        echo "It has taken action to fix your linuxconf installation" >>$OLDINSTALL
208        echo "so it becomes more compatible with RPM based systems" >>$OLDINSTALL
209        echo >>$OLDINSTALL
210
211        # I put a default RedHat inittab in /usr/lib/linuxconf/install
212        # When I unpack the distro, the original SHOULD be there, but hey,
213        # You never can tell when someone is gonna need that 1k taken up
214        # by the backup....
215        if [ -f /etc/inittab.old ] ; then
216                cp /etc/inittab /usr/lib/linuxconf/uninstall/inittab.beforeupgrade
217                mv -f /etc/inittab.old /etc/inittab
218        #else
219                # Tell the RPM to replace this file with a stock RedHat
220                # We haven't untarred anything yet, so we can't replace it
221                #cp /etc/inittab /usr/lib/linuxconf/uninstall/inittab.beforeupgrade
222                #touch $INITTABREPLACE
223        fi
224
225        if [ -f /etc/rc.d/rc.M ] ; then
226                mv -f /etc/rc.d/rc.M /usr/lib/linuxconf/uninstall/rc.M.beforeupgrade
227        fi
228
229        if [ -f /usr/sbin/syslogd.old ] ; then
230                mv -f /usr/bin/syslogd.old /usr/lib/linuxconf/uninstall/syslogd.beforelinuxconf
231        fi
232
233        if [ -f /etc/conf.linuxconf ] ; then
234                mv -f /etc/conf.linuxconf /etc/conf.linuxconf-installed
235        fi
236fi
237
238%post
239/sbin/ldconfig
240/usr/lib/linuxconf/install/rpm-postinst.sh $*
241
242# Add a few group ids so that the user is not prompted for them later...
243
244# if it is an old version of groupadd, the combined -g and -r options
245# will cause it to fail, so we fall back on just -r.  It will be less
246# consistent across systems, but that's not too horrible.
247/usr/sbin/groupadd -g 44 -r -f pppusers >/dev/null 2>&1 || \
248  /usr/sbin/groupadd -r -f pppusers >/dev/null
249/usr/sbin/groupadd -g 45 -r -f popusers >/dev/null 2>&1 || \
250  /usr/sbin/groupadd -r -f popusers >/dev/null
251/usr/sbin/groupadd -g 46 -r -f slipusers >/dev/null 2>&1 || \
252  /usr/sbin/groupadd -r -f slipusers >/dev/null
253
254%triggerin -- netkit-base inetd
255# Update /etc/inetd.conf
256if ! grep -q '[# \t]*linuxconf' /etc/inetd.conf ; then
257        echo >> /etc/inetd.conf
258        echo linuxconf stream tcp wait root /bin/linuxconf linuxconf --http >> /etc/inetd.conf
259        if [ -f /var/run/inetd.pid ] ; then
260                kill -HUP `cat /var/run/inetd.pid`
261        fi
262fi
263
264%triggerin -- setup
265# Update /etc/services
266if ! grep -q '[# \t]*linuxconf' /etc/services ; then
267  echo "linuxconf       98/tcp" >> /etc/services
268fi
269
270%triggerin -- openssh-server
271/bin/linuxconf --setmod opensshd
272%triggerin -- squid
273/bin/linuxconf --setmod squid
274%triggerin -- named
275/bin/linuxconf --setmod dnsconf
276%triggerin -- dhcpd
277/bin/linuxconf --setmod dhcpd
278#%triggerin -- sendmail
279#/bin/linuxconf --setmod mailconf
280%triggerin -- apache
281/bin/linuxconf --setmod apache
282%triggerin -- samba
283/bin/linuxconf --setmod samba
284#%triggerin -- wu-ftpd
285#/bin/linuxconf --setmod wuftpd
286%triggerun -- named
287# we do not use --unsetmod because we want to leave a module that is
288# explicitly turned off that way even if the triggered package is
289# afterwards reinstalled...
290[ $2 = 0 ] || exit 0
291TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
292sed '/^module.list 1 dnsconf$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
293mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
294%triggerun -- openssh-server
295[ $2 = 0 ] || exit 0
296TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
297sed '/^module.list 1 opensshd$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
298mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
299
300%triggerun -- squid
301[ $2 = 0 ] || exit 0
302TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
303sed '/^module.list 1 squid$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
304mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
305
306%triggerun -- dhcpd
307[ $2 = 0 ] || exit 0
308TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
309sed '/^module.list 1 dhcpd$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
310mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
311%triggerun -- sendmail
312[ $2 = 0 ] || exit 0
313TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
314sed '/^module.list 1 mailconf$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
315mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
316%triggerun -- apache
317[ $2 = 0 ] || exit 0
318TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
319sed '/^module.list 1 apache$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
320mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
321%triggerun -- samba
322[ $2 = 0 ] || exit 0
323TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
324sed '/^module.list 1 samba$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
325mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
326%triggerun -- wu-ftpd
327[ $2 = 0 ] || exit 0
328TMPFILE=`mktemp /tmp/lct.XXXXXX` || exit 1
329sed '/^module.list 1 wuftpd$/d' < /etc/conf.linuxconf > $TMPFILE || exit 2
330mv $TMPFILE /etc/conf.linuxconf || { rm -f $TMPFILE ; exit 3 ; }
331
332
333%preun
334# The script is handed a 0 if this is a uninstall
335# and a 1 if it is an upgrade...
336/usr/lib/linuxconf/install/rpm-preuninst.sh $1 >/dev/null 2>&1
337exit 0
338
339%postun
340/sbin/ldconfig
341if [ "$1" = 0 ] ; then
342        # remove linuxconf from /etc/inetd.conf if it is there
343        if [ -f /etc/inetd.conf ] &&
344        grep linuxconf /etc/inetd.conf >/dev/null 2>&1 ; then
345                if grep -v linuxconf /etc/inetd.conf > /tmp/inetd.$$ ; then
346                        mv /tmp/inetd.$$ /etc/inetd.conf
347                fi
348        fi
349        rm -f /var/run/treemenu.cache
350fi
351
352
353%files -f libfiles
354%defattr(-,root,root)
355%doc COPYING Changes HISTORY LICENSE.modules TODO
356%doc rpmfiles/doc/HELPING
357%doc rpmfiles/doc/RPM-CHANGES
358%doc rpmfiles/doc/RPM-INSTALL
359%doc rpmfiles/doc/RPM-README
360%doc rpmfiles/doc/UPGRADE
361%config(noreplace) %verify(not md5 size mtime) /etc/conf.linuxconf
362%config /etc/pam.d/*
363%config /etc/logrotate.d/linuxconf
364#%config(noreplace) /etc/xinetd.d/*
365%dir /usr/lib/linuxconf
366/usr/lib/liblinuxconf.so.1
367/usr/lib/liblinuxconf.so.%{version}
368
369/usr/lib/linuxconf/help.eng
370/usr/lib/linuxconf/help.ja
371%lang(zh) /usr/lib/linuxconf/help.bg5
372%lang(fr_CA) /usr/lib/linuxconf/help.cn
373%lang(cs) /usr/lib/linuxconf/help.cs
374%lang(de) /usr/lib/linuxconf/help.de
375%lang(es) /usr/lib/linuxconf/help.es
376%lang(fi) /usr/lib/linuxconf/help.fi
377%lang(fr) /usr/lib/linuxconf/help.fr
378%lang(it) /usr/lib/linuxconf/help.it
379%lang(ko) /usr/lib/linuxconf/help.ko
380%lang(no) /usr/lib/linuxconf/help.no
381%lang(pt) /usr/lib/linuxconf/help.pt
382%lang(se) /usr/lib/linuxconf/help.se
383%lang(sk) /usr/lib/linuxconf/help.sk
384/usr/bin/fsbrowser
385/usr/bin/linuxconf-wrapper
386/usr/bin/shellmod
387/bin/linuxconf
388/bin/netconf
389/bin/fsconf
390%config /bin/remadmin
391/bin/userconf
392/sbin/askrunlevel
393/sbin/dnsconf
394/sbin/fixperm
395/sbin/mailconf
396#/sbin/linuxconf
397/sbin/uucpconf
398/sbin/viewlog
399/sbin/vregistry
400
401%ghost /var/log/htmlaccess.log
402%ghost /var/log/netconf.log
403
404%files devel
405%defattr(-,root,root)
406/usr/include/linuxconf
407/usr/lib/liblinuxconf.so
408/usr/lib/liblinuxconf.a
409/usr/lib/linuxconf-devel
410
411%changelog
412* Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 1.24r6-0vl3
413- added a patch to build on glibc22 system correctly
414
415* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
416- 1.24r6-0vl2: pathes of uucp is fixed back correctly
417
418* Fri Aug 24 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
419- 1.24r6-0vl1
420- remove nooptalpha patch, it seems to be unnecessary with gcc-2.95.3
421
422* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
423- 1.24r6-0vl1: some of patches are taken from RH 1.24r2-4
424- add Requires: linuxconf = %%{version}-%%{release} to devel subpackage
425- added shared libraries to main package and ldconfig in post/postun
426
427* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org>
428- change filedepend to package name depend ( setup )
429
430* Thu Oct 19 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
431- 1.21r5-0vl6
432- added rules.mak patch for alpha (it missed correct dynamic linker)
433
434* Sun Oct 15 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
435- 1.21r5-0vl5
436- added PreReq: util-linux
437
438* Mon Oct  9 2000 Jun Nishii <jun@vinelinux.org>
439- 1.21r5-0vl4
440- remove check of the permission of sendmail
441
442* Fri Oct 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
443- 1.21r5-0vl3
444- fixed rpm-postinst.sh again (rc.sysinit should be unmodified for Vine)
445
446* Thu Oct 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
447- 1.21r5-0vl2
448- fixed rpm-postinst.sh (was still looking at S99linuxconf!)
449- added ppc patch for rules.mak (dynamic linker for ppc is ld.so.1)
450
451* Wed Oct  4 2000 Kazuhisa TAKEI <takei@vinelinux.org> 1.21r5-0vl1
452- added %triggerin opensshd,squid
453
454* Thu Jul 13 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
455- 1.19r1-0vl2
456- added %defattr
457
458* Fri Jul  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
459- updated to 1.19r1
460- added w3m patch
461
462* Mon Jun  19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
463- updated to 1.18r7
464
465* Fri Jun  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
466- updated to 1.18r6
467- added vlconf patch and vine-powerd gif (But just parody...)
468- syncronize japanese NLS catalog and fixed it a little.
469- remove pnggif patch
470
471* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
472- update to 1.18r4
473- pull out gd backwards-compatibility patch
474
475* Fri May 12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
476- updated to 1.18r2
477- remove bounds patch merged
478- syncronize japanese NLS catalog and fixed it a little.
479
480* Fri Apr 21 2000 Nalin Dahyabhai <nalin@redhat.com>
481- update to 1.18
482
483* Wed Apr 05 2000 Nalin Dahyabhai <nalin@redhat.com>
484- update to 1.17r9
485
486* Fri Mar 31 2000 Nalin Dahyabhai <nalin@redhat.com>
487- update to 1.17r8
488- include Jacques's fix for sysctl thing
489- fix uucp speed setting problem
490- fix quoting in PPP chat scripts
491
492* Tue Mar 07 2000 Nalin Dahyabhai <nalin@redhat.com>
493- change ownership of directories created under /var/named to named.named
494- add inetd to trigger that adds linuxconf to inetd.conf
495- fix newly-broken regex checks in triggers
496
497* Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
498- change groups created in post-install to have GIDs under 100
499
500* Wed Feb 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
501- First release for Vine
502- added Japanese message catalogs and some help files.
503- added lastlang patch to prevend a trouble about NLS in boot time.
504- add euc patch for button's text turning in text mode.
505
506* Fri Jan 21 2000 Nalin Dahyabhai <nalin@redhat.com>
507- back out dialogs patch, which breaks linuxconf if not started in a terminal
508- back out pam_unix patch, going another route
509- make sure init script has execute bit set
510
511* Thu Jan 20 2000 Nalin Dahyabhai <nalin@redhat.com>
512- fix paths in linuxconf.internaldaemons
513
514* Mon Jan 17 2000 Nalin Dahyabhai <nalin@redhat.com>
515- update to 1.17r2
516- note that help.cfr has become help.cn
517- integrate patch to stop dialog-related segfaults from edward.huff@acm.org
518- make default distribution "redhat" instead of "std"
519
520* Wed Jan 12 2000 Nalin Dahyabhai <nalin@redhat.com>
521- updated to linuxconf 1.17r1
522- add patch to fix easy-to-spot potential buffer overflows
523
524* Mon Jan 10 2000 Nalin Dahyabhai <nalin@redhat.com>
525- change to only append entry to /etc/inetd.conf if it isn't mentioned at all
526
527* Tue Jan  4 2000 Nalin Dahyabhai <nalin@redhat.com>
528- change to only append entry to /etc/services if it isn't mentioned at all
529
530* Thu Dec 16 1999 Michael K. Johnson <johnsonm@redhat.com>
531- pulled in chat patch
532
533* Tue Dec 14 1999 Michael K. Johnson <johnsonm@redhat.com>
534- pulled in Jacques' errata patch
535
536* Thu Dec 02 1999 Michael K. Johnson <johnsonm@redhat.com>
537- updated to linuxconf 1.16r10 to fix a few more bugs
538- added rbl patches that will be in 1.16r11 when it is released
539- removed xconf
540
541* Wed Dec 01 1999 Michael K. Johnson <johnsonm@redhat.com>
542- updated to linuxconf 1.16r9 to fix a few more bugs
543
544* Wed Nov 24 1999 Michael K. Johnson <johnsonm@redhat.com>
545- updated to linuxconf 1.16r8 to see which bugs are fixed.
546- removed lpdconf as it is insufficient on Red Hat Linux systems
547
548* Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
549- reverted redhatppp module to an older, presumed working version
550  because wvdial support in the new one breaks otherwise working
551  setups.
552
553* Tue Sep 21 1999 Michael K. Johnson <johnsonm@redhat.com>
554- updated to 1.16r3.2
555- install main help files only for languages in use on the system
556
557* Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
558- updated to 1.16r3
559
560* Sat Aug 28 1999 Michael K. Johnson <johnsonm@redhat.com>
561- fixed quota.conf permissions problem
562
563* Tue Jul 27 1999 Michael K. Johnson <johnsonm@redhat.com>
564- Update to 1.16r1.3 to deal with a few more bug reports
565
566* Fri Jul 16 1999 Michael K. Johnson <johnsonm@redhat.com>
567- Update to 1.16r1.1 to deal with a number of bug reports
568
569* Wed Apr 14 1999 Michael K. Johnson <johnsonm@redhat.com>
570- setup trigger for /etc/services instead of postinstall
571- moved /etc/conf.linuxconf to a noreplace config file
572
573* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
574- update to 1.14r4
575- fix kmap/map confusion
576- fix dnsrecs combos not to be empty
577- be more conservative about finding phone numbers
578
579* Wed Apr 07 1999 Michael K. Johnson <johnsonm@redhat.com>
580- update to 1.14r3
581- added more triggers
582- sendmail V8 .cf
583
584* Mon Apr 05 1999 Michael K. Johnson <johnsonm@redhat.com>
585- prerequire redhat-release
586- remove ghost reference to boot.log in logrotate file.
587
588* Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
589- dhcpd config should trust dhcpd or dhcpd script to put in correct routes
590
591* Tue Mar 30 1999 Michael K. Johnson <johnsonm@redhat.com>
592- updated to 1.14r2
593- added defattr
594
595* Mon Mar 29 1999 Michael K. Johnson <johnsonm@redhat.com>
596- fixed ppp device names
597- added a bunch of modules by default
598
599* Thu Mar 25 1999 Michael K. Johnson <johnsonm@redhat.com>
600- removed /var/log/boot.log (not used on Red Hat Linux)
601- add redhatppp module by default
602- fix /var/spol/mqueue permissions
603
604* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
605- auto rebuild in the new build environment (release 4)
606
607* Thu Mar 18 1999 Michael K. Johnson <johnsonm@redhat.com>
608- do not install old versions of patch files
609- perm -> umask to fix bug #418
610
611* Mon Mar 15 1999 Michael K. Johnson <johnsonm@redhat.com>
612- french messages
613
614* Thu Mar 11 1999 Michael K. Johnson <johnsonm@redhat.com>
615- moved to 1.14
616
617* Wed Mar 10 1999 Michael K. Johnson <johnsonm@redhat.com>
618- Moved to pristine source from internal CVS archive
Note: See TracBrowser for help on using the repository browser.