source: projects/specs/trunk/l/lincity-ng/lincity-ng-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define alias_ttf /usr/share/fonts/TrueType-vlgothic/VL-PGothic-Regular.ttf
2
3%define name lincity-ng
4%define version 2.0
5%define release 3%{?_dist_release}
6Summary: City Simulation Game
7Summary(ja): 都市シミュレーションゲーム
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source: http://download.berlios.de/%{name}/%{name}-%{version}.tar.bz2
12License: GNU General Public License
13Group: Applications/Games
14URL: http://lincity-ng.berlios.de/
15
16Requires: TrueType-vlgothic
17Requires: SDL, SDL_image, SDL_mixer, SDL_ttf, SDL_gfx,
18Requires: zlib, libxml2, physfs
19BuildRequires: SDL-devel, SDL_image-devel, SDL_mixer-devel,
20BuildRequires: SDL_ttf-devel, SDL_gfx-devel,
21BuildRequires: mesa-libGL-devel
22BuildRequires: zlib-devel, libxml2-devel, physfs-devel,
23BuildRequires: jam, vorbis-tools
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26%description
27LinCity-NG is a City Simulation Game. It is a polished and improved
28version of the old LinCity game. Within the scope of the GoTM
29project at happypenguin.org we create a new iso-3d graphics engine
30together with completely redone modern gui.
31
32%description
33LinCity-NG は都市シミュレーションゲームです。
34以前の LinCity を精錬し、改善されたバージョンです。
35
36
37%prep
38%setup -q
39sed -i "s/CFLAGS += -O3 -g -Wall/CFLAGS += $RPM_OPT_FLAGS/" Jamrules
40sed -i "s/CXXFLAGS += -O3 -g -Wall/CXXFLAGS += $RPM_OPT_FLAGS/" Jamrules
41
42%build
43#./autogen.sh
44# export CFLAGS="$RPM_OPT_FLAGS -fstack-protector" \
45#     CXXFLAGS="$RPM_OPT_FLAGS -fstack-protector"
46%configure
47jam
48
49%install
50%{__rm} -rf ${RPM_BUILD_ROOT}
51jam -s DESTDIR=${RPM_BUILD_ROOT} install
52
53### to convert the sounds
54for i in ${RPM_BUILD_ROOT}%{_datadir}/%{name}/sounds/*.wav; do
55    oggenc --quiet $i && rm $i
56done
57
58# font alias
59pushd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
60ln -s %alias_ttf sans-ja_JP.ttf
61popd
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files
68%defattr(-,root,root)
69%doc %{_datadir}/doc/%{name}-%{version}
70%{_bindir}/lincity-ng
71%{_datadir}/pixmaps/*
72%{_datadir}/applications/lincity-ng.desktop
73%{_datadir}/lincity-ng
74
75%changelog
76* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.0-3
77- added Japanese Summary and description
78
79* Fri May 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0-2
80- added Requires: TrueType-vlgothic
81- corrected symbolic link to sans-ja_JP.ttf
82
83* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-1
84- new upstream release.
85- changed Group to Applications/Games
86
87* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.2-1vl5
88- new upstream release.
89- applied new versioning policy
90
91* Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl2
92- rebuilt for VineSeed
93
94* Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
95- new upstream release.
96- update Source:.
97- add "BuildRequires: XOrg-gl-devel".
98
99* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
100- initial build for Vine Linux 4.1
101- add BuildRequires: vorbis-tools to convert the sounds
102
103* Sun Dec 11 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.2-0vlmp1
104- minor version up
105
106* Sun Jul 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.1-0vlmp1
107- minor version up
108
109* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0-0vlmp1
110- initial build for Vine Linux 3.2
111
112
113# end of file
Note: See TracBrowser for help on using the repository browser.