source: projects/specs/trunk/l/lilypond/lilypond-vl.spec @ 521

Revision 521, 13.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define buildinfo yes
2
3%define name lilypond
4%define version 2.4.5
5%define release 0vl2
6
7%define iconsdir        /usr/share/pixmaps
8# %define infodir %{_infodir}/%{name}
9%define infodir %{_infodir}/lilypond
10
11Summary:        A program for printing sheet music.
12Summary(ja):    ³ÚÉèºîÀ®¥×¥í¥°¥é¥à
13Name:           %{name}
14Version:        %{version}
15Release:        %{release}
16License:        GPL
17Group:          Applications/Publishing
18URL:            http://lilypond.org/
19Source0:        http://ftp.cs.uu.nl/pub/GNU/LilyPond/development/lilypond-%{version}.tar.gz
20Patch0:         lilypond-platex-2.4.5.patch
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: gcc-c++ python python-devel
24BuildRequires: gettext netpbm-progs
25BuildRequires: tetex xdvik ghostscript
26BuildRequires: ec-fonts-mftraced
27Buildrequires: which t1utils bison m4 flex mftrace ImageMagick-devel
28Buildrequires: texinfo >= 4.7
29BuildRequires: guile-devel >= 1.6.4
30BuildRequires: t1lib-devel
31BuildRequires: glibc-devel groff
32BuildRequires: potrace >= 1.3 fontforge
33Requires:      chkfontpath XOrg
34
35%description
36LilyPond is a music typesetter.  It produces beautiful sheet music using a
37high level description file as input.  Lilypond is part of the GNU project.
38 
39LilyPond is split into two packages.  The package "lilypond" provides the
40core package, containing the utilities for converting the music source
41(.ly) files into printable output.  The package "lilypond-documentation"
42provides the full documentation, example .ly files for various features and
43the Mutopia project files (musical equivalent of the Gutenberg project - see
44http://www.mutopiaproject.org for details).
45 
46If you are new to lilypond, you will almost certainly want to install the
47"lilypond-documentation" package in addition to the "lilypond" package.
48
49%description -l ja
50LilyPond ¤Ï GNU ¥×¥í¥¸¥§¥¯¥È¤Ç³«È¯¤µ¤ì¤Æ¤¤¤ë³ÚÉèºîÀ®¥½¥Õ¥È¤Ç¤¹¡£¹â²òÁüÅÙ¤Î
51¤È¤Æ¤â¤­¤ì¤¤¤Ê³ÚÉè¤òºî¤ë¤³¤È¤¬¤Ç¤­¤Þ¤¹¡£
52
53LiLyPond ¤Ï2¤Ä¤Î¥Ñ¥Ã¥±¡¼¥¸¤Ë¤ï¤«¤ì¤Æ¤¤¤Þ¤¹¡£"lilypond"¥Ñ¥Ã¥±¡¼¥¸¤¬¥á¥¤¥ó¥Ñ¥Ã
54¥±¡¼¥¸"¤Ç¡¢³ÚÉ襽¡¼¥¹¥Õ¥¡¥¤¥ë(.ly)¤ò°õºþ²Äǽ¤Ê·Á¼°¤ËÊÑ´¹¤¹¤ë¥×¥í¥°¥é¥à¤¬Æþ¤Ã
55¤Æ¤Þ¤¹¡£tex, htmlÅù¤Ë´Êñ¤Ë³ÚÉè¤òÁÞÆþ¤¹¤ë¤¿¤á¤Î lilypond-book ¥³¥Þ¥ó¥É¤â¤¢¤ê
56¤Þ¤¹¡¥(VineÍѥѥ屡¼¥¸¤Ç¤Ï¡¤platex¤Ç¤ÎÍøÍѤâ²Äǽ¤ËÊѹ¹¤·¤Æ¤¢¤ê¤Þ¤¹¡¥)
57
58"lilypond-documentation" ¤Ë¤Ï¥Þ¥Ë¥å¥¢¥ë¤ä¤¤¤í¤¤¤í¤Ê¥µ¥ó¥×¥ë¥Õ¥¡¥¤¥ë(.ly)¡¢
59Mutopia¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë¤¤¤Ä¤¯¤«¤Î¥Õ¥¡¥¤¥ë¤¬Æþ¤Ã¤Æ¤Þ¤¹¡£Mutopia ¥×¥í¥¸¥§¥¯¥È
60(musical equivalent of the Gutenberg project)¤Ë¤Ä¤¤¤Æ¤Ï
61http://www.mutopiaproject.org¤ò¸«¤Æ¤¯¤À¤µ¤¤¡£
62
63%package -n liblilypond
64Summary: Lilypond libraries
65Summary(ja): Lilypond ¥é¥¤¥Ö¥é¥ê
66Group: System Environment/Libraries
67Requires: lilypond >= %{version}
68
69%description -n liblilypond
70Lilypond libs
71
72%package documentation
73Summary: LilyPond documentation, examples and Mutopia files.
74Summary(ja): LilyPond ¤Î¥Þ¥Ë¥å¥¢¥ë, ¥µ¥ó¥×¥ë¡¤Mutopia¥Õ¥¡¥¤¥ë
75Group: Applications/Documentation
76Requires: %{name}
77
78%description documentation
79The documentation of LilyPond, both in HTML and PostScript, along with
80example input files and the files from the Mutopia project.
81
82%description documentation -l ja
83LiLyPond ¤Î¥Þ¥Ë¥å¥¢¥ë¤Ç¤¹¡¥HTML ,PostScript, PDF ¤Î·Á¼°¤Î¤â¤Î¤¬¤¢¤ê¤Þ¤¹¡¥
84¥µ¥ó¥×¥ë¤ä Mutopia¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë¥Õ¥¡¥¤¥ë¤âÆþ¤Ã¤Æ¤Þ¤¹¡¥
85
86%prep
87rm -rf $RPM_BUILD_ROOT
88
89%setup -q
90#%patch -p1
91
92%build
93
94# DO NOT use % { configure } , it hardcodes all paths, runs libtool,
95# so we can't do make prefixix=/tmp/ install.
96
97# In fact, do not take out the spaces between % and { in the above comment,
98# because RPM will gladly do a substitution anyway.
99
100./configure --disable-checking --prefix=%{_prefix} --libdir=%{_libdir} \
101         --enable-optimising
102
103%{__make} all
104%{__make} web
105%{__make} -C Documentation/user omf
106
107
108%install
109%{__rm} -rf %{buildroot}
110
111%{makeinstall} MAKE_PFA_FILES=1 local_lilypond_libdir=%{buildroot}/%{_libdir}/%{name}/%{version}
112
113########## install emacs els
114%{__mkdir} -p %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
115%{__install} -m 644 elisp/lilypond-init.el %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
116
117######### gzip mans
118%{__gzip} -9fn %{buildroot}%{_mandir}/man1/*
119
120########## install profiles
121#mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
122#cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
123#cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
124
125########## move items to texmf dir
126%define texmfdir %{buildroot}/usr/share/texmf/
127mkdir -p %{texmfdir}/{tex,dvips,fonts}
128
129pushd %{buildroot}%{_datadir}/%{name}/%{version}/
130for d in dvips tex; do
131        mv $d %{texmfdir}/$d/lilypond
132done
133
134for d in afm source tfm; do
135        mkdir %{texmfdir}/fonts/$d
136        mv fonts/$d %{texmfdir}/fonts/$d/lilypond
137done
138popd
139
140############################################
141########## install docs
142
143%{__make} prefix="%{buildroot}%{_prefix}" \
144          infodir="%{buildroot}%{_infodir}" \
145          webdir="%{buildroot}%{_docdir}/lilypond-documentation-%{version}/" web-install
146
147%{__rm} -f %{buildroot}/%{_infodir}/dir
148%{__gzip} -9fn `find %{buildroot}%{_infodir}/ -name '*.info'`
149
150########## install icons
151install -d $RPM_BUILD_ROOT/%{iconsdir}
152install -m 644 Documentation/pictures/out-www/lelie-logo.png $RPM_BUILD_ROOT/%{iconsdir}/%{name}.png
153
154%clean
155%{__rm} -rf %{buildroot}
156
157
158%post
159
160touch /tmp/.lilypond-install
161%{__rm} `find /var/lib/texmf -name 'feta*pk' -or -name 'feta*tfm' -or -name 'parmesan*pk' -or -name 'parmesan*tfm' -print` /tmp/.lilypond-install
162
163/sbin/install-info %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
164/sbin/install-info %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
165
166if [ -x /usr/bin/texhash ]; then /usr/bin/env - /usr/bin/texhash 2> /dev/null ;fi
167if [ -x /usr/bin/updmap ]; then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
168
169/usr/X11R6/bin/mkfontdir %{_datadir}/lilypond/%{version}/fonts/type1/
170/usr/sbin/chkfontpath -q --add=%{_datadir}/lilypond/%{version}/fonts/type1/
171
172%preun
173if [ $1 = 0 ] ; then
174  if [ -f /usr/share/lilypond/%{version}/ls-R ]; then
175    %{__rm} -f /usr/share/lilypond/%{version}/ls-R
176  fi
177fi
178
179if [ $1 = 0 ]; then
180    /sbin/install-info --delete %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
181    /sbin/install-info --delete %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
182fi
183
184if [ -x /usr/bin/chkfontpath ] ; then
185    chkfontpath --remove=%{_datadir}/lilypond/%{version}/fonts/type1/
186fi
187
188%postun
189# %{clean_menus}
190if [ -x /usr/bin/texhash ] ;then /usr/bin/env - /usr/bin/texhash 2> /dev/null;fi
191if [ -x /usr/bin/updmap ] ;then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
192if [ -x /usr/bin/scrollkeeper-update ] ;then /usr/bin/env - /usr/bin/scrollkeeper-update 2> /dev/null;fi
193
194%post documentation
195if [ -x /usr/bin/scrollkeeper-update ] ; then
196    scrollkeeper-update
197fi
198
199%postun documentation
200if [ -x /usr/bin/scrollkeeper-update ] ; then
201    scrollkeeper-update
202fi
203
204%files
205%defattr(-, root, root)
206%doc AUTHORS.txt COPYING ChangeLog DEDICATION INSTALL.txt NEWS.txt README.txt
207%doc ROADMAP THANKS
208
209%{_datadir}/emacs/site-lisp/site-start.d/lilypond-*
210%{_datadir}/emacs/site-lisp/lilypond*
211
212%{_bindir}/*
213%{_infodir}/*
214%{_mandir}/man1/*
215
216%{_datadir}/%{name}/%{version}/
217%{_datadir}/locale/*/LC_MESSAGES/lilypond.mo
218
219%{_datadir}/texmf/dvips/lilypond/
220%{_datadir}/texmf/tex/lilypond/
221%{_datadir}/texmf/fonts/afm/lilypond/
222%{_datadir}/texmf/fonts/source/lilypond/
223%{_datadir}/texmf/fonts/tfm/lilypond/
224# %{_prefix}/../etc/profile.d/lilypond.*
225%iconsdir/%{name}.*
226
227%files -n liblilypond
228%defattr(-,root,root)
229%{_libdir}/%{name}/%{version}/python/*.so
230
231%files documentation
232%defattr(-, root, root)
233%{_docdir}/*
234%{_datadir}/omf/lilypond/%{version}
235
236%changelog
237* Sun Jul  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
238- rebuilt for VineSeed
239
240* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
241- build on Vine 3.1
242
243* Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
244- build for Vine Linux
245- many fixes in post/postun scripts
246
247* Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
248- Updated to latest devel release
249
250* Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
251- Updated to latest devel release
252
253* Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
254- Updated to latest devel release
255
256* Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
257- Updated to latest devel release
258
259* Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
260- Updated to latest devel release
261
262* Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
263- Updated to latest devel release
264- Built against latest pfaedit-040211 and mftrace-1.0.27
265- Added requirement for potrace
266
267* Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
268- Updated to latest devel release
269
270* Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
271- Updated to latest devel release
272
273* Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
274- Updated to latest devel release
275
276* Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
277- Updated to latest devel release
278
279* Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
280- Updated to latest devel release
281
282* Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
283- Updated to latest devel release
284
285* Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
286- Updated to latest devel release
287
288* Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
289- Updated to latest devel release
290
291* Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
292- Updated to latest devel release
293
294* Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
295- Updated to latest devel release
296
297* Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
298- Updated to latest devel release
299
300* Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
301- Updated to latest devel release
302
303* Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
304- Updated to latest devel release
305
306* Thu Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
307- Updated to latest devel release
308
309* Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
310- Rebuilt for Mandrake 9.2
311
312* Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
313- Updated to latest devel release
314
315* Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
316- Updated to latest devel release
317
318* Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
319- Updated to latest devel release
320- removed lilypond-words
321
322* Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
323- Updated to latest devel release
324- fixed lilypond.word install
325
326* Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
327- Updated to latest devel release
328
329* Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
330- Updated to latest devel release
331- Built against pyton2.3
332
333* Sun Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
334- Updated to latest devel release
335
336* Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
337- Updated to latest devel release
338
339* Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
340- Updated to latest devel release
341
342* Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
343- Updated to latest devel release
344- Changed naming to differ from Mandrake cooker
345
346* Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
347- Fixed documentation path
348- Added some of Heikki Johannes Junes suggestions
349
350* Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
351- Added Heikki Johannes Junes fix for confilcting PHP variable
352  out=/dev/vc/ by adding unset out before compiling
353- Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
354- Changed icon to lilypond.png
355- Added menu and icons again
356
357* Thu Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
358- removed menu and icons, sync with redhat-spec
359
360* Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
361- refreshed dependencies and file list.
362
363* Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
364- Built for Mandrake 9.1
365
366* Fri Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
367- set menu-items to lilypond-info and lilypond-documentation.
368
369* Fri Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
370- add pre/post-dependencies and menus with icon from source.
371
372* Fri Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
373- info, commented menu
374
375* Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
376- Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
377- TODO: info (?) and dependencies.
378
379* Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
380- updated by Michael Brown <mbrown@linux-mandrake.com> :
381        - Upgraded to 1.4.2
382        - Changed URL
383        - Removed /etc/profile.d scripts: all TeX bits are now located properly
384        - Rearranged documentation
385        - Tidied spec file
386        - Updated README.first
387
388* Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
389- added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
390        - Removed info files completely (couldn't get info reader to read them)
391        - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
392
393* Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
394- Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
395- Added mktexlsr to post-install and post-uninstall scripts
396- Patched scripts in /etc/profile.d to reflect changes to font locations
397- Added QuickStart guide and Points to note sections to README.first (well worth reading)
398- Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
399
400* Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
401- First Mandrake package
402- spec file heavily adapted from PowerPC contribs.
403- Note HTML documentation may contain duff links and may be incomplete.  Lots of warnings appear when building HTML docs.
404- PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
405- Created README.first file
Note: See TracBrowser for help on using the repository browser.