source: projects/specs/trunk/l/lilypond/lilypond-vl.spec @ 9291

Revision 9291, 12.3 KB checked in by Takemikaduchi, 9 years ago (diff)

libdbi-drivers,goffice08,guile18: NEW package
geda-gaf,missile,rrdtool,trackballs,trackballs-music,ulogd,xkeycaps,xorg-x11-jpfonts: rebuild
others: new upstream release

Line 
1%define buildinfo yes
2%define name lilypond
3%define iconsdir /usr/share/pixmaps
4%define infodir %{_infodir}/%{name}
5Summary:        A typesetting system for music notation
6Summary(ja):楽譜作成プログラム
7Group:          Applications/Publishing
8Name:           %{name}
9Version:        2.18.2
10Release:        1%{?_dist_release}
11License:        GPLv2
12URL:            http://www.lilypond.org/
13Source0:        http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16## from fc11
17Patch12:        lilypond-2.21.2-gcc44-relocate.patch
18
19BuildRequires: t1utils ImageMagick-devel gettext texlive-common
20BuildRequires: gcc-c++
21BuildRequires: bison flex m4
22BuildRequires: python-devel >= 2.4.0
23BuildRequires: mftrace >= 1.1.19
24BuildRequires: texinfo >= 4.8
25BuildRequires: texi2html
26BuildRequires: guile18-devel >= 1.8
27BuildRequires: ghostscript >= 8.15
28BuildRequires: pango-devel >= 1.12.0
29BuildRequires: rsync
30BuildRequires: texlive-collection-metapost
31BuildRequires: texlive-collection-genericrecommended
32BuildRequires: dblatex
33
34BuildRequires: potrace >= 1.3
35BuildRequires: netpbm-progs
36BuildRequires: which
37BuildRequires: glibc-devel groff
38BuildRequires: fontforge
39
40%description
41LilyPond is a music typesetter.  It produces beautiful sheet music using a
42high level description file as input.  Lilypond is part of the GNU project.
43 
44LilyPond is split into two packages.  The package "lilypond" provides the
45core package, containing the utilities for converting the music source
46(.ly) files into printable output.  The package "lilypond-documentation"
47provides the full documentation, example .ly files for various features and
48the Mutopia project files (musical equivalent of the Gutenberg project - see
49http://www.mutopiaproject.org for details).
50 
51If you are new to lilypond, you will almost certainly want to install the
52"lilypond-documentation" package in addition to the "lilypond" package.
53
54%description -l ja
55LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
56とてもきれいな楽譜を作ることができます。
57
58LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
59ケージ"で、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
60てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
61ます.(Vine用パッケージでは,platexでの利用も可能に変更してあります.)
62
63"lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
64Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
65(musical equivalent of the Gutenberg project)については
66http://www.mutopiaproject.orgを見てください。
67
68%package -n liblilypond
69Summary: Lilypond libraries
70Summary(ja): Lilypond ライブラリ
71Group: System Environment/Libraries
72Requires: lilypond >= %{version}
73
74%description -n liblilypond
75Lilypond libs
76
77%package documentation
78Summary: LilyPond documentation, examples and Mutopia files.
79Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
80Group: Applications/Documentation
81Requires: %{name}
82
83%description documentation
84The documentation of LilyPond, both in HTML and PostScript, along with
85example input files and the files from the Mutopia project.
86
87%description documentation -l ja
88LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
89サンプルや Mutopiaプロジェクトによるファイルも入ってます.
90
91%prep
92rm -rf $RPM_BUILD_ROOT
93
94%setup -q
95
96# from fc11
97%patch12 -p0
98
99%build
100sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4
101autoconf
102%configure \
103        --without-kpathsea \
104        --disable-checking \
105        --with-ncsb-dir=%{_datadir}/fonts/default/Type1
106%{__make}
107
108
109%install
110%{__rm} -rf %{buildroot}
111make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim74
112
113chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
114
115# Symlink lilypond-init.el in emacs' site-start.d directory
116pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
117mkdir site-start.d
118ln -s ../lilypond-init.el site-start.d
119popd
120
121# Change encoding to UTF8
122pushd $RPM_BUILD_ROOT%{_infodir}
123iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
124mv music-glossary.info.utf8 music-glossary.info
125sed -e s,lilypond/,, -i *.info
126popd
127
128rm -f $RPM_BUILD_ROOT%{_infodir}/dir
129
130%find_lang %{name}
131
132mkdir -p $RPM_BUILD_ROOT%{_fontdir}
133mv $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf/*.otf $RPM_BUILD_ROOT%{_fontdir}
134rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
135ln -s %{_fontdir} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
136
137%clean
138%{__rm} -rf %{buildroot}
139
140
141%files -f %{name}.lang
142%defattr(-, root, root)
143%doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
144%doc ROADMAP THANKS
145%{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
146%{_datadir}/emacs/site-lisp/lilypond*
147%{_bindir}/*
148%{_infodir}/*
149%{_mandir}/man1/*
150%{_datadir}/%{name}/%{version}/
151%{_datadir}/vim/vim*
152
153%files -n liblilypond
154%defattr(-,root,root)
155%{_libdir}/%{name}/%{version}/python/*.so
156
157%files documentation
158%defattr(-, root, root)
159%{_docdir}/*
160
161
162%changelog
163* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.2-1
164- update to 2.18.2
165- change BuildRequires: texlive-common instead of tetex
166- change BuildRequires: guile18-devel instead of guile-devel
167- remove Patch0,10,13
168- add BuildRequires: texlive-collection-metapost, texlive-collection-genericrecommended, rsync, dblatex, texi2html
169
170
171* Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
172- updated LilyPond to 2.12.3
173- applied new versioning policy, spec in utf-8
174- dropt Patch0: lilypond-platex-2.4.5.patch
175- imported patch from fc11
176        Patch10: lilypond-2.11.65-python26.patch
177        Patch12: lilypond-2.21.2-gcc44-relocate.patch
178        Patch13: lilypond-consts.patch
179- replaced build, install, pre/post scripts (from fc11)
180
181* Sun Jul  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
182- rebuilt for VineSeed
183
184* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
185- build on Vine 3.1
186
187* Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
188- build for Vine Linux
189- many fixes in post/postun scripts
190
191* Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
192- Updated to latest devel release
193
194* Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
195- Updated to latest devel release
196
197* Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
198- Updated to latest devel release
199
200* Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
201- Updated to latest devel release
202
203* Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
204- Updated to latest devel release
205
206* Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
207- Updated to latest devel release
208- Built against latest pfaedit-040211 and mftrace-1.0.27
209- Added requirement for potrace
210
211* Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
212- Updated to latest devel release
213
214* Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
215- Updated to latest devel release
216
217* Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
218- Updated to latest devel release
219
220* Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
221- Updated to latest devel release
222
223* Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
224- Updated to latest devel release
225
226* Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
227- Updated to latest devel release
228
229* Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
230- Updated to latest devel release
231
232* Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
233- Updated to latest devel release
234
235* Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
236- Updated to latest devel release
237
238* Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
239- Updated to latest devel release
240
241* Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
242- Updated to latest devel release
243
244* Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
245- Updated to latest devel release
246
247* Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
248- Updated to latest devel release
249
250* Wed Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
251- Updated to latest devel release
252
253* Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
254- Rebuilt for Mandrake 9.2
255
256* Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
257- Updated to latest devel release
258
259* Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
260- Updated to latest devel release
261
262* Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
263- Updated to latest devel release
264- removed lilypond-words
265
266* Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
267- Updated to latest devel release
268- fixed lilypond.word install
269
270* Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
271- Updated to latest devel release
272
273* Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
274- Updated to latest devel release
275- Built against pyton2.3
276
277* Mon Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
278- Updated to latest devel release
279
280* Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
281- Updated to latest devel release
282
283* Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
284- Updated to latest devel release
285
286* Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
287- Updated to latest devel release
288- Changed naming to differ from Mandrake cooker
289
290* Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
291- Fixed documentation path
292- Added some of Heikki Johannes Junes suggestions
293
294* Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
295- Added Heikki Johannes Junes fix for confilcting PHP variable
296  out=/dev/vc/ by adding unset out before compiling
297- Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
298- Changed icon to lilypond.png
299- Added menu and icons again
300
301* Sat Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
302- removed menu and icons, sync with redhat-spec
303
304* Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
305- refreshed dependencies and file list.
306
307* Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
308- Built for Mandrake 9.1
309
310* Sun Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
311- set menu-items to lilypond-info and lilypond-documentation.
312
313* Sat Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
314- add pre/post-dependencies and menus with icon from source.
315
316* Mon Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
317- info, commented menu
318
319* Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
320- Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
321- TODO: info (?) and dependencies.
322
323* Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
324- updated by Michael Brown <mbrown@linux-mandrake.com> :
325        - Upgraded to 1.4.2
326        - Changed URL
327        - Removed /etc/profile.d scripts: all TeX bits are now located properly
328        - Rearranged documentation
329        - Tidied spec file
330        - Updated README.first
331
332* Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
333- added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
334        - Removed info files completely (couldn't get info reader to read them)
335        - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
336
337* Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
338- Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
339- Added mktexlsr to post-install and post-uninstall scripts
340- Patched scripts in /etc/profile.d to reflect changes to font locations
341- Added QuickStart guide and Points to note sections to README.first (well worth reading)
342- Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
343
344* Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
345- First Mandrake package
346- spec file heavily adapted from PowerPC contribs.
347- Note HTML documentation may contain duff links and may be incomplete.  Lots of warnings appear when building HTML docs.
348- PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
349- Created README.first file
Note: See TracBrowser for help on using the repository browser.