source: projects/specs/trunk/l/lilypond/lilypond-vl.spec @ 11201

Revision 11201, 13.0 KB checked in by ara_t, 7 years ago (diff)

lilypond: correct SPEC file

RevLine 
[521]1%define buildinfo yes
2%define name lilypond
[883]3%define iconsdir /usr/share/pixmaps
4%define infodir %{_infodir}/%{name}
[11201]5%define fontdir %{_datadir}/fonts/%{name}
[521]6
[11201]7Summary: A typesetting system for music notation
8Summary(ja): 楽譜作成プログラム
9Group:   Applications/Publishing
10Name:    %{name}
11Version: 2.18.2
12Release: 2%{?_dist_release}
13License: GPLv3
14URL:     http://www.lilypond.org/
15Source0: http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
[883]18## from fc11
[11201]19Patch12:  lilypond-2.21.2-gcc44-relocate.patch
[883]20
[9291]21BuildRequires: t1utils ImageMagick-devel gettext texlive-common
[883]22BuildRequires: gcc-c++
23BuildRequires: bison flex m4
24BuildRequires: python-devel >= 2.4.0
25BuildRequires: mftrace >= 1.1.19
[9291]26BuildRequires: texinfo >= 4.8
27BuildRequires: texi2html
[11201]28%if %{?_dist_release} == "vl6"
29BuildRequires: guile-devel >= 1.8
30%endif
31%if %{?_dist_release} >= "vl7"
[9291]32BuildRequires: guile18-devel >= 1.8
[11201]33%endif
[883]34BuildRequires: ghostscript >= 8.15
35BuildRequires: pango-devel >= 1.12.0
[9291]36BuildRequires: rsync
37BuildRequires: texlive-collection-metapost
[11201]38%if %{?_dist_release} == "vl6"
[9291]39BuildRequires: texlive-collection-genericrecommended
[11201]40%endif
41%if %{?_dist_release} >= "vl7"
42BuildRequires: texlive-collection-plaingeneric
43%endif
[9291]44BuildRequires: dblatex
[883]45
46BuildRequires: potrace >= 1.3
47BuildRequires: netpbm-progs
[9291]48BuildRequires: which
[521]49BuildRequires: glibc-devel groff
[883]50BuildRequires: fontforge
[521]51
52%description
53LilyPond is a music typesetter.  It produces beautiful sheet music using a
54high level description file as input.  Lilypond is part of the GNU project.
[11201]55
[521]56LilyPond is split into two packages.  The package "lilypond" provides the
57core package, containing the utilities for converting the music source
58(.ly) files into printable output.  The package "lilypond-documentation"
59provides the full documentation, example .ly files for various features and
60the Mutopia project files (musical equivalent of the Gutenberg project - see
61http://www.mutopiaproject.org for details).
[11201]62
[521]63If you are new to lilypond, you will almost certainly want to install the
64"lilypond-documentation" package in addition to the "lilypond" package.
65
66%description -l ja
[883]67LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
68とてもきれいな楽譜を作ることができます。
[521]69
[883]70LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
[11201]71ケージで、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
[883]72てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
[11201]73ます。(Vine用パッケージでは、platexでの利用も可能に変更してあります。)
[521]74
[883]75"lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
76Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
77(musical equivalent of the Gutenberg project)については
78http://www.mutopiaproject.orgを見てください。
[521]79
80%package -n liblilypond
81Summary: Lilypond libraries
[883]82Summary(ja): Lilypond ライブラリ
[521]83Group: System Environment/Libraries
84Requires: lilypond >= %{version}
85
86%description -n liblilypond
87Lilypond libs
88
89%package documentation
90Summary: LilyPond documentation, examples and Mutopia files.
[883]91Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
[521]92Group: Applications/Documentation
93Requires: %{name}
94
95%description documentation
96The documentation of LilyPond, both in HTML and PostScript, along with
97example input files and the files from the Mutopia project.
98
99%description documentation -l ja
[883]100LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
101サンプルや Mutopiaプロジェクトによるファイルも入ってます.
[521]102
[11201]103
[521]104%prep
105rm -rf $RPM_BUILD_ROOT
106
107%setup -q
108
[883]109# from fc11
110%patch12 -p0
111
[521]112%build
[11201]113%if %{?_dist_release} >= "vl7"
[9291]114sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4
[11201]115%endif
116autoconf
[9291]117%configure \
[11201]118  --without-kpathsea \
119  --disable-checking \
120  --with-ncsb-dir=%{_datadir}/fonts/default/Type1
[883]121%{__make}
[521]122
123%install
124%{__rm} -rf %{buildroot}
[9291]125make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim74
126
[883]127chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
[521]128
[883]129# Symlink lilypond-init.el in emacs' site-start.d directory
130pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
131mkdir site-start.d
132ln -s ../lilypond-init.el site-start.d
133popd
[521]134
[883]135# Change encoding to UTF8
136pushd $RPM_BUILD_ROOT%{_infodir}
137iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
138mv music-glossary.info.utf8 music-glossary.info
139sed -e s,lilypond/,, -i *.info
[521]140popd
141
[9291]142rm -f $RPM_BUILD_ROOT%{_infodir}/dir
[521]143
[9291]144%find_lang %{name}
[521]145
[11201]146mkdir -p $RPM_BUILD_ROOT%{fontdir}
147mv $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf/*.otf $RPM_BUILD_ROOT%{fontdir}
[9291]148rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
[11201]149ln -s %{fontdir} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
[521]150
151%clean
152%{__rm} -rf %{buildroot}
153
154
[9291]155%files -f %{name}.lang
[521]156%defattr(-, root, root)
[11201]157%doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
158%doc ROADMAP
[883]159%{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
[521]160%{_datadir}/emacs/site-lisp/lilypond*
[11201]161%{_datadir}/fonts/%{name}/
[521]162%{_bindir}/*
163%{_infodir}/*
164%{_mandir}/man1/*
165%{_datadir}/%{name}/%{version}/
[883]166%{_datadir}/vim/vim*
[521]167
168%files -n liblilypond
169%defattr(-,root,root)
170%{_libdir}/%{name}/%{version}/python/*.so
171
172%files documentation
173%defattr(-, root, root)
174%{_docdir}/*
175
[883]176
[521]177%changelog
[11201]178* Wed Oct 11 2017 Toshiaki Ara <ara_t@384.jp> 2.18.2-2
179- rebuild for Vine6
180  - revert BuildRequires: guile-devel instead of guile18-devel for Vine6
181  - skip 'sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4' for Vine6
182- change BuildRequires: texlive-collection-plaingeneric
183  instead of texlive-collection-genericrecommended for VineSeed
184- change License: GPLv3
185- define %%{_fontdir}
186
[9291]187* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.2-1
188- update to 2.18.2
189- change BuildRequires: texlive-common instead of tetex
190- change BuildRequires: guile18-devel instead of guile-devel
191- remove Patch0,10,13
192- add BuildRequires: texlive-collection-metapost, texlive-collection-genericrecommended, rsync, dblatex, texi2html
193
[883]194* Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
195- updated LilyPond to 2.12.3
196- applied new versioning policy, spec in utf-8
197- dropt Patch0: lilypond-platex-2.4.5.patch
198- imported patch from fc11
199        Patch10: lilypond-2.11.65-python26.patch
200        Patch12: lilypond-2.21.2-gcc44-relocate.patch
201        Patch13: lilypond-consts.patch
202- replaced build, install, pre/post scripts (from fc11)
203
[521]204* Sun Jul  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
205- rebuilt for VineSeed
206
207* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
208- build on Vine 3.1
209
210* Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
211- build for Vine Linux
212- many fixes in post/postun scripts
213
214* Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
215- Updated to latest devel release
216
217* Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
218- Updated to latest devel release
219
220* Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
221- Updated to latest devel release
222
223* Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
224- Updated to latest devel release
225
226* Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
227- Updated to latest devel release
228
229* Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
230- Updated to latest devel release
231- Built against latest pfaedit-040211 and mftrace-1.0.27
232- Added requirement for potrace
233
234* Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
235- Updated to latest devel release
236
237* Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
238- Updated to latest devel release
239
240* Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
241- Updated to latest devel release
242
243* Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
244- Updated to latest devel release
245
246* Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
247- Updated to latest devel release
248
249* Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
250- Updated to latest devel release
251
252* Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
253- Updated to latest devel release
254
255* Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
256- Updated to latest devel release
257
258* Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
259- Updated to latest devel release
260
261* Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
262- Updated to latest devel release
263
264* Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
265- Updated to latest devel release
266
267* Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
268- Updated to latest devel release
269
270* Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
271- Updated to latest devel release
272
[9291]273* Wed Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
[521]274- Updated to latest devel release
275
276* Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
277- Rebuilt for Mandrake 9.2
278
279* Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
280- Updated to latest devel release
281
282* Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
283- Updated to latest devel release
284
285* Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
286- Updated to latest devel release
287- removed lilypond-words
288
289* Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
290- Updated to latest devel release
291- fixed lilypond.word install
292
293* Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
294- Updated to latest devel release
295
296* Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
297- Updated to latest devel release
298- Built against pyton2.3
299
[9291]300* Mon Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
[521]301- Updated to latest devel release
302
303* Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
304- Updated to latest devel release
305
306* Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
307- Updated to latest devel release
308
309* Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
310- Updated to latest devel release
311- Changed naming to differ from Mandrake cooker
312
313* Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
314- Fixed documentation path
315- Added some of Heikki Johannes Junes suggestions
316
317* Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
318- Added Heikki Johannes Junes fix for confilcting PHP variable
319  out=/dev/vc/ by adding unset out before compiling
320- Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
321- Changed icon to lilypond.png
322- Added menu and icons again
323
[9291]324* Sat Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
[521]325- removed menu and icons, sync with redhat-spec
326
327* Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
328- refreshed dependencies and file list.
329
330* Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
331- Built for Mandrake 9.1
332
[9291]333* Sun Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
[521]334- set menu-items to lilypond-info and lilypond-documentation.
335
[9291]336* Sat Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
[521]337- add pre/post-dependencies and menus with icon from source.
338
[9291]339* Mon Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
[521]340- info, commented menu
341
342* Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
343- Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
344- TODO: info (?) and dependencies.
345
346* Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
347- updated by Michael Brown <mbrown@linux-mandrake.com> :
348        - Upgraded to 1.4.2
349        - Changed URL
350        - Removed /etc/profile.d scripts: all TeX bits are now located properly
351        - Rearranged documentation
352        - Tidied spec file
353        - Updated README.first
354
355* Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
356- added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
357        - Removed info files completely (couldn't get info reader to read them)
358        - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
359
360* Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
361- Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
362- Added mktexlsr to post-install and post-uninstall scripts
363- Patched scripts in /etc/profile.d to reflect changes to font locations
364- Added QuickStart guide and Points to note sections to README.first (well worth reading)
365- Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
366
367* Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
368- First Mandrake package
369- spec file heavily adapted from PowerPC contribs.
370- Note HTML documentation may contain duff links and may be incomplete.  Lots of warnings appear when building HTML docs.
371- PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
372- Created README.first file
Note: See TracBrowser for help on using the repository browser.