source: projects/specs/trunk/l/lightdm/lightdm-vl.spec @ 12463

Revision 12463, 7.7 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

lightdm-gtk-2.0.7-1

lightdm-1.30.0-1

RevLine 
[12463]1%bcond_with systemd
2
[8489]3Summary: A lightweight display manager
4Summary(ja): 軽量ディスプレイマネージャー
5Name: lightdm
[12463]6Version: 1.30.0
7Group: system
8Release: 1%{?_dist_release}%{?with_systemd:.systemd}
9Vendor: Project Vine
10Distribution: Vine Linux
11
[8489]12License: GPLv3,LGPLv2,LGPLv3
[12463]13URL: https://github.com/canonical/lightdm
14Source0: https://github.com/canonical/lightdm/releases/download/%{version}/%{name}-%{version}.tar.xz
[8489]15
[12463]16Source10:       lightdm-pam
17Source11:       lightdm-autologin-pam
18Source12:       lightdm-tmpfiles.conf
19Source13:       lightdm.service
20Source14:       lightdm.logrotate
21Source15:       lightdm.rules
[8489]22
[12463]23# .conf snippets
24Source20:       50-backup-logs.conf
25Source21:       50-minimum-vt.conf
26Source22:       50-session-wrapper.conf
27Source23:       50-user-authority-in-system-dir.conf
28Source24:       50-xserver-command.conf
29Source25:       50-disable-guest.conf
30Source26:       50-run-directory.conf
31
32Patch0:         gcc-10.patch
33
34# Upstreamed:
35Patch1:         lightdm-1.25.1-disable_dmrc.patch
36
37Patch101: lightdm-1.11.2-nodaemon_option.patch
[8489]38# for Vine Linux
[9834]39Patch1000: lightdm-1.17.2-vine.patch
[8489]40
41Requires(pre): shadow-utils
42Requires: accountsservice
43Requires: dbus-x11
44Requires: pam
45Requires: xorg-x11-xinit
46Requires: %{name}-gobject = %{version}-%{release}
47Requires: lightdm-greeter
48
49BuildRequires: glib2-devel >= 2.30.0
50BuildRequires: gobject-introspection-devel
51BuildRequires: libXdmcp-devel
52BuildRequires: libxcb-devel
53BuildRequires: libxklavier-devel
54BuildRequires: libX11-devel
55BuildRequires: pam-devel
56BuildRequires: libgcrypt-devel
57BuildRequires: yelp-tools
58
[12463]59Obsoletes:              %{name}-qt < 1.30.0
60Obsoletes:              %{name}-qt-devel < 1.30.0
[8489]61
62%description
63An display manager that:
64 * Has a lightweight codebase
65 * Is standards compliant (PAM, ConsoleKit, etc)
66 * Has a well defined interface between the server and user interface
67 * Cross-desktop (greeters can be written in any toolkit)
68
[12463]69
[8489]70%package                gobject
71Summary:                LightDM GObject client library
[12463]72Group:                  system
[8489]73
74%description    gobject
75This package contains a GObject based library for LightDM clients to
76use to interface with LightDM.
77
78
79%package                gobject-devel
80Summary:                Development files and headers for %{name}-gobject
[12463]81Group:                  programming
[8489]82Requires:               %{name}-gobject = %{version}-%{release}
83Requires:               pkgconfig
84
85%description    gobject-devel
86Development files and headers for %{name}-gobject.
87
88
89%prep
90%setup -q
[12463]91%autosetup -p 1
[8489]92
[12463]93
[8489]94%build
95autoreconf -if
96%configure \
[12463]97        --disable-dmrc \
98        --disable-silent-rules \
99        --disable-static \
100        --enable-liblightdm-gobject \
101        --enable-introspection \
102        --disable-liblightdm-qt \
103        --disable-liblightdm-qt5 \
104        --with-greeter-user=lightdm
[8489]105
106make %{?_smp_mflags}
107
[12463]108
[8489]109%install
110rm -rf $RPM_BUILD_ROOT
111make install DESTDIR=$RPM_BUILD_ROOT
112
[12463]113# We need to own these
114%{__mkdir_p} %{buildroot}%{_sysconfdir}/lightdm/lightdm.conf.d/         \
115        %{buildroot}%{_datadir}/dbus-1/interfaces               \
116        %{buildroot}%{_datadir}/dbus-1/system.d                 \
117        %{buildroot}%{_datadir}/lightdm/lightdm.conf.d/         \
118        %{buildroot}%{_datadir}/lightdm/remote-sessions/        \
119        %{buildroot}%{_datadir}/xgreeters/                      \
120        %{buildroot}%{_localstatedir}/cache/lightdm/            \
121        %{buildroot}%{_rundir}/lightdm/         \
122        %{buildroot}%{_localstatedir}/log/lightdm/              \
123        %{buildroot}%{_localstatedir}/lib/lightdm/              \
124        %{buildroot}%{_localstatedir}/lib/lightdm-data/
[8489]125
[12463]126# libtool cruft
127rm -fv %{buildroot}%{_libdir}/lib*.la
[8489]128
[12463]129# We don't ship AppAmor
130%{__rm} -rfv %{buildroot}%{_sysconfdir}/apparmor.d/
[8489]131
[12463]132# omit upstart support
133%{__rm} -rfv %{buildroot}%{_sysconfdir}/init
[8489]134
[12463]135# install pam file
136%{__install} -Dpm 0644 %{SOURCE10} %{buildroot}%{_sysconfdir}/pam.d/lightdm
137%{__install} -Dpm 0644 %{SOURCE11} %{buildroot}%{_sysconfdir}/pam.d/lightdm-autologin
138%{__install} -Dpm 0644 %{SOURCE14} %{buildroot}%{_sysconfdir}/logrotate.d/lightdm
139%{__install} -Dpm 0644 %{SOURCE15} %{buildroot}%{_datadir}/polkit-1/rules.d/lightdm.rules
140%{__install} -pm 0644 %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}   \
141        %{SOURCE24} %{SOURCE25} %{SOURCE26} %{buildroot}%{_datadir}/lightdm/lightdm.conf.d/
[8489]142
[12463]143%if %{with systemd}
144%{__install} -Dpm 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/lightdm.conf
145%{__install} -Dpm 0644 %{SOURCE13} %{buildroot}%{_unitdir}/lightdm.service
146%{__install} -pm 0644 %{SOURCE26} %{buildroot}%{_datadir}/lightdm/lightdm.conf.d/
147%else
148mkdir -p %{buildroot}%{_localstatedir}/run/lightdm
149%endif
[8489]150
[12463]151# Move DBus config to proper location.
152# why is this needed? -- rex
153%{__mv} -f %{buildroot}%{_sysconfdir}/dbus-1/system.d/*.conf            \
154        %{buildroot}%{_datadir}/dbus-1/system.d
155
156%find_lang lightdm --with-gnome
157
158
159%triggerun -- lightdm < 1.30.0
160getent passwd lightdm >/dev/null && \
161  /usr/sbin/usermod -d /var/lib/lightdm lightdm >/dev/null ||:
162
[8489]163%pre
164getent group lightdm >/dev/null || groupadd -r lightdm
165getent passwd lightdm >/dev/null || \
[12463]166  /usr/sbin/useradd -g lightdm -M -d /var/lib/lightdm -s /sbin/nologin -r lightdm
[8489]167exit 0
168
[12463]169%if %{with systemd}
170%post
171# todo: document need/purpose for this snippet
172if [ $1 = 1 ] ; then
173        %{_bindir}/killall -HUP dbus-daemon 2>&1 > /dev/null
174fi
175%systemd_post lightdm.service
[8489]176
[12463]177%preun
178%systemd_preun lightdm.service
179
180%postun
181%systemd_postun lightdm.service
182%endif
183
[8489]184%post gobject -p /sbin/ldconfig
185%postun gobject -p /sbin/ldconfig
186
187
188%files -f %{name}.lang
189%defattr(-, root, root, -)
[12463]190%license COPYING.GPL3
191%doc NEWS
[8489]192%dir %{_sysconfdir}/lightdm
[12463]193%dir %{_sysconfdir}/lightdm/lightdm.conf.d
194%config(noreplace) %{_sysconfdir}/pam.d/lightdm*
[8489]195%config(noreplace) %{_sysconfdir}/lightdm/keys.conf
196%config(noreplace) %{_sysconfdir}/lightdm/lightdm.conf
197%config(noreplace) %{_sysconfdir}/lightdm/users.conf
[12463]198%dir %{_sysconfdir}/logrotate.d/
199%{_sysconfdir}/logrotate.d/lightdm
200%dir %attr(-,lightdm,lightdm) %{_localstatedir}/cache/lightdm/
201%dir %attr(-,lightdm,lightdm) %{_localstatedir}/lib/lightdm/
202%dir %attr(-,lightdm,lightdm) %{_localstatedir}/lib/lightdm-data/
203%dir %attr(-,lightdm,lightdm) %{_localstatedir}/log/lightdm/
204%dir %{_datadir}/bash-completion
205%dir %{_datadir}/bash-completion/completions
206%dir %{_datadir}/xgreeters/
[8489]207%{_bindir}/dm-tool
208%{_sbindir}/lightdm
209%{_libexecdir}/lightdm-guest-session
[12463]210%{_datadir}/lightdm/
211%{_mandir}/man1/dm-tool.1.gz
212%{_mandir}/man1/lightdm.1.gz
213%{_datadir}/accountsservice
214%{_datadir}/dbus-1/interfaces/*.xml
215%{_datadir}/dbus-1/system.d/*.conf
216%{_datadir}/polkit-1/rules.d/lightdm.rules
217%{_datadir}/polkit-1/actions/org.freedesktop.DisplayManager.AccountsService.policy
[9834]218%{_datadir}/bash-completion/completions/dm-tool
219%{_datadir}/bash-completion/completions/lightdm
[12463]220%if %{with systemd}
221%{_unitdir}/lightdm.service
222%{_tmpfilesdir}/lightdm.conf
223%ghost %dir %{_rundir}/lightdm
224%else
[8489]225%dir %{_localstatedir}/run/lightdm
[12463]226%endif
[8489]227
228%files gobject
229%defattr(-, root, root, -)
[12463]230%license COPYING.LGPL2 COPYING.LGPL3
[8489]231%{_libdir}/liblightdm-gobject-1.so.*
232%{_libdir}/girepository-1.0/LightDM-1.typelib
233
234%files gobject-devel
235%defattr(-, root, root, -)
236%{_includedir}/lightdm-gobject-1
237%{_libdir}/liblightdm-gobject-1.so
238%{_libdir}/pkgconfig/liblightdm-gobject-1.pc
239%{_datadir}/gir-1.0/LightDM-1.gir
240%{_datadir}/gtk-doc/html/lightdm-gobject-1
241
242
[12463]243%changelog
244* Tue Aug 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.30.0-1
245- new upstream release.
246- added systemd support (disabled as default).
247- dropped subpackages: lightdm-qt{,-devel}.
[8489]248
[10533]249* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.19.2-1
250- updated to 1.19.2.
251
[9834]252* Sat Nov 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.17.2-1
253- update to 1.17.2
254- update Patch1000 (lightdm-1.17.2-vine.patch)
255
[9548]256* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.3-1
257- update to 1.12.3
258
[8962]259* Tue Sep 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.9-1
260- new upstream release
261
[8911]262* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
263- new upstream release
264- update Patch1000 (lightdm-1.11.5-vine.patch)
265
[8758]266* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.4-1
267- new upstream release
268
[8489]269* Sun Jun 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.2-1
270- initial build
271
Note: See TracBrowser for help on using the repository browser.