source: projects/specs/trunk/l/liferea/liferea-vl.spec @ 5278

Revision 5278, 6.5 KB checked in by kudoh, 12 years ago (diff)

liferea-vl.spec

Line 
1Name: liferea
2Version: 1.8.0
3Release: 1%{?_dist_release}
4License: GPL
5Group: Applications/Internet
6URL: http://liferea.sourceforge.net/
7Source0: http://prdownloads.sourceforge.net/liferea/%{name}-%{version}.tar.gz
8#Patch0: lX11.patch
9
10Requires(post): GConf2
11Requires(preun): GConf2
12
13BuildRequires: GConf2-devel gtk2-devel gnome-vfs2-devel
14BuildRequires: libxml2-devel zlib-devel gettext
15BuildRequires: libxslt-devel sqlite3-devel libglade2-devel
16BuildRequires: libnotify-devel gnutls-devel
17BuildRequires: dbus-devel dbus-glib-devel
18BuildRequires: libsoup-devel WebKit-gtk-devel
19BuildRequires: intltool >= 0.35
20BuildRequires: libtool libSM-devel perl-XML-Parser
21BuildRequires: unique-devel json-glib-devel
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Summary: aggregator for online news feeds
25Summary(ja): オンラインニュースアグリゲータ
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Liferea is an aggregator for online news feeds. There are many other news
32readers available, but these others are not available for Linux or require
33many extra libraries to be installed. Liferea tries to fill this gap by
34creating a fast, easy to use, easy to install news aggregator for GTK/GNOME.
35
36Technical Details
37 * RSS/RDF, CDF, Atom, OCS, OPML.
38 * Filters to scrape websites or postprocess feeds.
39 * Supports Enclosures (Podcasting).
40 * Bandwidth saving by supporting feed specified update intervals,
41   HTTP compression and etags.
42
43Liferea is an abbreviation for Linux Feed Reader.
44
45%description -l ja
46liferea はオンラインニュースフィードのアグリゲータです。
47多くのニュースリーダーがありますが、それらは Linux では利用できない、
48または多くの追加ライブラリをインストールする必要があります。
49liferea は GTK/GNOME で高速且つ簡単に使用とインストールが可能な
50ニュースアグリゲータを作成することでこのギャップを埋めようとしたものです。
51
52技術面の詳細
53 * RSS/RDF 、CDF 、Atom 、OCS、OPML。
54 * ウェブサイトをまとめたり、あるいはフィードを後処理するためのフィルタ。
55 * Enclosures (Podcasting) をサポート。
56 * フィードのアップデート間隔の指定、HTTP 圧縮と etags のサポートで帯域幅を節約。
57
58Liferea は Linux Feed Reader を省略したものです。
59
60%prep
61%setup -q
62#%patch0 -p1 -b .lX11
63
64%build
65#autoreconf
66#libtoolize --copy --force
67%configure --disable-schemas-install --enable-static=no
68%{__make} %{?_smp_mflags}
69
70%install
71%{__rm} -rf %{buildroot}
72%makeinstall
73
74rm -f $RPM_BUILD_ROOT%{_libdir}/liferea/*.{a,la}
75rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
76
77%find_lang %{name}
78
79%clean
80%{__rm} -rf %{buildroot}
81
82%preun
83GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null
84
85%post
86GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null
87touch --no-create %{_datadir}/icons/hicolor
88if [ -x /usr/bin/gtk-update-icon-cache ]; then
89  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
90fi
91
92%postun
93touch --no-create %{_datadir}/icons/hicolor
94if [ -x /usr/bin/gtk-update-icon-cache ]; then
95  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
96fi
97
98%files -f %{name}.lang
99%defattr(-,root,root)
100%doc AUTHORS COPYING ChangeLog INSTALL README
101%config %{_sysconfdir}/gconf/schemas/*
102%{_bindir}/*
103#%{_libdir}/liferea
104%{_datadir}/applications/*
105%{_datadir}/%{name}/*
106%{_datadir}/icons/*
107%{_mandir}/man?/*
108
109%changelog
110* Sun Dec 11 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.8.0-1
111- new upstream release
112- dropt patch0
113- added BuildRequires: unique-devel json-glib-devel
114- stopped running autoreconf and libtoolize
115
116* Wed Nov 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.7-1
117- new upstream release
118- dropt BuildRequires: xulrunner-devel
119
120* Wed Jun 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.6b-1
121- new upstream release
122
123* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.5-1
124- new upstream release
125- added BuildRequires: libtool, libSM-devel, perl-XML-Parser
126- run autoreconf in %%build
127- deleted unrecognized option
128- used %%{?_smp_mflags}
129
130* Thu Jul 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.4-1
131- new upstream release
132- added patch1 from Fedora
133
134* Thu Mar 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.3-1
135- new upstream release
136
137* Fri Feb 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.2-1
138- new upstream release
139- changed BuildRequires: xulrunner-devel-unstable to xulrunner-devel
140- done libtoolize --copy --force before configure
141
142* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.1-2
143- added Japanese description
144
145* Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.1-1
146- new upstream release
147
148* Thu Aug 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.0-2
149- run gtk-update-icon-cache in %post, %postun
150- added BuildRequires: libsoup-devel, WebKit-gtk-devel
151
152* Fri Aug 7 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.6.0-1
153- new upstream release
154
155* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.26-1
156- new upstream release
157
158* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.23-3
159- rebuilt with gnutls-2.6.3
160
161* Sat Jan 17 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.23-2
162- disabled GtkHTML2 support
163- updated --with-gecko configure option
164- added BuildRequires: libxslt-devel, sqlite3-devel and libglade2-devel
165
166* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.23-1
167- new upstream release
168- BuildRequires: gecko-devel-unstable (instead of firefox-devel)
169
170* Tue Nov 27 2007 IWAI, Masaharu <iwai@alib.jp> 1.4.8-0vl1
171- new upstream release
172
173* Sun Sep  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-0vl1
174- new upstream release
175- added Japanese summary
176- using firefox instead of mozilla
177
178* Mon Jan 16 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> - 1.0-0vl2
179- fixed %pre and %post scripts.
180
181* Thu Dec 29 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0-0vl1
182- new upstream
183- update description
184
185* Sun Dec 12 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.6.4b-0vl1
186- new upstream
187
188* Fri Oct 15 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.6.0-0vl2
189- add defattr in files section
190
191* Sun Oct  3 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.6.0-0vl1
192- new upstream
193
194* Tue Aug 24 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.5.3b-0vl1
195- new upstream
196- add BuildPreReq zlib-devel mozilla-devel gettext
197- install gconf schemas
198
199* Sun Feb 15 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.4.6b-0vl1
200- Initial build.
201
Note: See TracBrowser for help on using the repository browser.