source: projects/specs/trunk/l/liece/liece-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       origver       1.4.10
4%define       origname      liece
5%ifarch x86_64
6%define       _libdir      %{_prefix}/lib
7%endif
8
9Summary:      Liece is emacs based irc client
10Summary(ja):  Liece は Emacsen 上で動作する IRC のクライアント
11Name:         %{origname}
12Version:      %{origver}
13Release:      1%{?_dist_release}
14
15Source0:      http://www.unixuser.org/~ueno/liece/dist/%{origname}-%{origver}.tar.gz
16Source1:      %{origname}-install.sh
17Source2:      %{origname}-remove.sh
18Source3:      plum-support.el
19Patch1:       liece-dsa341.patch
20Patch10:      liece-1.4.10-emacs22.patch
21
22License:      GPL
23Group:        Applications/Editors/Emacs
24BuildRoot:    %{_tmppath}/%{name}-%{version}-root
25BuildRequires: gettext
26
27PreReq: emacsen
28%prereq_ge emacsen-common
29%prereq_ge flim
30
31Provides:     %{origname} = %{origver}
32Conflicts:    liece-el
33
34
35%description
36 Liece is based on Irchat, simple IRC client running under Emacsen,
37 nevertheless nothing to do with irchat-2.4jp which has various features added
38 by Japanese contributers (e.g. Mule support, channel buffers).  We are going
39 to full-replace to redesign thoroughly, and to stand up to extension against
40 arbitrary protocol backend. The most recent version of this program has been
41 almost completely rewritten from Irchat.
42
43
44%description -l ja
45Liece はEmacsen 上で動作するシンプルなIRC クライアントであるIrchat をベースに
46しています。にもかかわらず 日本人コントリビュータがたくさん機能を追加した
47irchat-2.4jp はまったくとりこまれていません。liece では全体的に再デザインし、
48完全におきかえをしてます。
49
50
51%prep
52%setup  -n %{origname}-%{origver}
53%patch1 -p1
54%patch10 -p1
55
56
57%build
58
59./configure --prefix=$RPM_BUILD_ROOT%{_prefix} \
60            --with-lispdir=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp \
61            --with-emacs=emacs
62
63make -C dcc
64make -C doc
65make -C etc
66(cd etc/po && msgfmt -o ja.mo ja.po)
67
68%install
69[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
70[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
71
72mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
73mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
74mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
75mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
76mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{origname}/icons
77mkdir -p ${RPM_BUILD_ROOT}/%{_bindir}
78mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/%{origname}/po/ja/LC_MESSAGES/
79
80
81#
82# install el files
83#
84
85cp dcc/{ldcc,ltcp} ${RPM_BUILD_ROOT}/%{_bindir}
86
87cp -r lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
88
89cp  %{SOURCE3}  ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
90
91mv  -f ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/ChangeLog \
92         ChangeLog.lisp
93
94(cd etc && make  install prefix=${RPM_BUILD_ROOT}/usr )
95(cp etc/po/ja.mo ${RPM_BUILD_ROOT}%{_datadir}/%{origname}/po/ja/LC_MESSAGES/%{origname}.mo )
96
97
98#
99#  build & install info
100#
101
102install -m 644 doc/*.info  ${RPM_BUILD_ROOT}%{_infodir}
103
104
105#
106# install  script( bytecompile el and install elc , remove )   
107#
108
109%_installemacsenscript %{origname} %{SOURCE1}
110
111%_removeemacsenscript  %{origname} %{SOURCE2}
112
113
114#
115# install info file
116#
117
118mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
119
120
121%post
122#
123# bytecompile and install
124#
125
126if [ "$1" = 2 ]; then
127
128%_emacsenPackageRemove %{origname}
129
130fi
131
132
133%_addemacsenlist %{origname}
134
135%_emacsenPackageInstall %{origname}
136
137
138/sbin/install-info %{_infodir}/liece.info.gz %{_infodir}/dir \
139    --entry="* Liece: (liece).  IRC Client On Emacsen" --section="Emacs"
140
141
142%preun
143
144if [ "$1" = 0 ]; then
145
146echo "preun$1"
147
148%_emacsenPackageRemove %{origname}
149
150%_removeemacsenlist %{origname}
151
152/sbin/install-info --delete %{_infodir}/liece.info.gz %{_infodir}/dir \
153    --entry="* Liece: (liece).  IRC Client On Emacsen" --section="Emacs"
154
155fi
156
157
158%clean
159[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
160
161
162%files
163%defattr(-,root,root)
164%doc AUTHORS COPYING ChangeLog* INSTALL NEWS README doc
165#%doc etc/sample.dot.emacs   where is it?
166
167%{_bindir}/*
168%{_datadir}/emacs/site-lisp/%{origname}/
169%{_libdir}/emacsen-common/packages/install/%{origname}
170%{_libdir}/emacsen-common/packages/remove/%{origname}
171
172%{_infodir}/%{origname}.info*
173%{_datadir}/%{origname}/po/ja/LC_MESSAGES/%{origname}.mo
174%{_datadir}/%{origname}/icons
175%{_datadir}/%{origname}/styles
176
177
178%changelog
179* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.10-1vl5
180- applied new versioning policy, spec in utf-8
181
182* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.4.10-0vl6
183- added %%define _libdir %%{_prefix}/lib for x86_64
184
185* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl5
186- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
187
188* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.10-0vl4
189- add Patch10 to support emacs22 (use assoc-string instead of assoc-ignore-case)
190
191* Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.10-0vl3
192- rebuild for VineSeed
193
194* Wed May 19 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp>
195- 1.4.10-0vl2
196- Added a patch "liece-dsa341.patch" for fixing security
197- DSA-341-1 liece -- insecure temporary file
198
199* Fri Nov  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.10-0vl1
200- new upstream version.
201
202* Wed Feb 13 2002 akira yamada <akira@vinelinux.org> 1.4.6-0vl1
203- new upstream version.
204- added BuildRequires: gettext
205- removed patch10.
206
207* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl4
208- liece-el -> liece
209- spec file cleaned up too much
210- added patch (Patch10) to set default {icon,style} directory for Vine
211- patch0 removed
212
213* Thu Nov  8 2001 Kazuhisa TAKEI <takei@vinelinux.org>
214- patchZZ
215
216* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
217- emacsenize
218
219* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
220- 1.14.3-0vl2
221- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
222
223* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
224- 1.14.3-0vl1
225- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
226
227* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
228- 1.13.7-8
229- added %define _noVersionedDependencies 1
230
231* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
232- 1.13.7-7
233- modified %files section to handle compressed man page(s)
234
235* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
236- 1.13.7-6
237- apel updated to 10.2
238
239* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
240- 1.13.7-5
241- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
242
243* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
244- 1.13.7-4
245- updated in sync with apel-10.0 / clime-1.13.6 release
246
247* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
248- 1.13.7-3
249- change Group to Applications/Editors/EmacsLisp
250
251* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
252- 1.13.7-2
253- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
254- now emh-1.10.1 and rmail-mime-1.13.0 are also included
255- documentation files are properly stored under /usr/doc directory
256
257* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
258- 1.13.7-1
259- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
260- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.