source: projects/specs/trunk/l/lftp/lftp-vl.spec @ 521

Revision 521, 9.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name lftp
2%define version 4.0.5
3%define release 1%{?_dist_release}
4
5Summary: The lftp command line ftp/http client
6Summary(ja): lftp - コマンドライン ftp/http クライアント
7Name: %{name}
8Version: %{version}
9Release: %{release}
10License: GPL3
11Group: Applications/Internet
12Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.bz2
13# Source10: lftp-3.0.9-0vl1-ja.po
14Source10: lftp-3.7.4-ja.po
15URL: http://lftp.yar.ru/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildPrereq: ncurses-devel, openssl-devel, pkgconfig, readline-devel
18BuildPrereq: expat-devel
19
20Packager: iwamoto
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25LFTP is a shell-like command line ftp client. It is
26reliable: can retry operations and does reget automatically.
27It can do several transfers simultaneously in background.
28You can start a transfer in background and continue browsing
29the ftp site or another one. This all is done in one process.
30Background jobs will be completed in nohup mode if you exit
31or close modem connection. Lftp has reput, mirror, reverse
32mirror among its features. Since version 2.0 it also supports
33http protocol.
34
35%description -l ja
36LFTP は、shell ライクなコマンドライン ftp クライアントです。
37リトライ機能の実装や自動的な再取得を行うため信頼性が高いです。
38バックグラウンドで複数の転送を同時に行うことができます。
39バックグラウンドでの転送を開始し、その ftp サイトや別の ftp
40サイトを閲覧し続けることができます。これらは全て 1 つのプロセス
41で実行されます。
42もし、モデムの接続が exit や close された場合、バックグラウンド
43ジョブは、nohup モードで終了します。lftp の特徴は、reput やミラー、
44逆ミラーなどです。バージョン 2.0 以降では、HTTP もサポートしています。
45
46%prep
47%setup -q
48
49cp po/ja.po po/ja.po.orig
50msgmerge -v %{SOURCE10} po/ja.po.orig -o po/ja.po
51
52%build
53if pkg-config openssl ; then
54        CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
55        LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
56fi
57LDFLAGS="-L`pwd`/src/.libs $LDFLAGS"; export LDFLAGS
58%configure --with-modules --disable-static --with-openssl
59export tagname=CC
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
65rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
66chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
67chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
68
69# Remove files from $RPM_BUILD_ROOT that we aren't shipping.
70rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
71rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
72
73%find_lang %{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files -f %{name}.lang
79%defattr(-,root,root)
80%doc README README.modules FAQ THANKS COPYING
81%doc  TODO lftp.lsm NEWS INSTALL FEATURES
82%config(noreplace) %{_sysconfdir}/lftp.conf
83%{_bindir}/*
84%{_mandir}/*/*
85%{_datadir}/lftp
86%{_libdir}/*.so*
87%dir %{_libdir}/lftp
88%dir %{_libdir}/lftp/%{version}
89%{_libdir}/lftp/%{version}/cmd-*.so
90%{_libdir}/lftp/%{version}/liblftp-network.so
91# %{_libdir}/lftp/%{version}/liblftp-getdate.so
92%{_libdir}/lftp/%{version}/liblftp-pty.so
93%{_libdir}/lftp/%{version}/proto-*.so
94
95%changelog
96* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.5-1
97- new upstream release 
98- update ja.po file (Thanks to Tadashi Jokagi <elf@elf.no-ip.org>)
99- update %files section to fit new release
100
101* Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.15-1
102- new upstream release
103
104* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.14-1
105- new upstream release
106
107* Wed May 06 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.13-1
108- new upstream release
109
110* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.11-1
111- new upstream release
112
113* Wed Mar 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.9-1vl5
114- new upstream release
115
116* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.8-1vl5
117- new upstream release
118- fix License tag
119
120* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.7-1vl5
121- new upstream release
122
123* Mon Dec 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.6-1vl5
124- new upstream release
125
126* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.4-1vl5
127- new upstream release
128- del liblftp-getdate.so from files list (upstream change)
129
130* Sat Jul 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.3-1vl5
131- new upstream release
132- spec in UTF8
133
134* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-2vl5
135- add BuildPrereq expat-devel
136
137* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-1vl5
138- new upstream release
139- new versioning policy
140
141* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.0-0vl1
142- new upstream release
143
144* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.6.1-0vl2
145- rebuild with expat-2.0.1
146
147* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.6.1-0vl1
148- new upstream release
149
150* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.15-0vl1
151- new upstream release
152
153* Tue Aug 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.13-0vl1
154- new upstream release
155
156* Mon Jul 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.12-0vl1
157- new upstream release
158
159* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-0vl1
160- new upstream release
161- rebuilt with new toolchain and openssl-0.9.8
162
163* Sat Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.9-0vl1
164- new upstream release
165
166* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.5.6-0vl3
167- fix configure option to use openssl
168
169* Sun Oct 29 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.5.6-0vl2
170- rebuild with gnutls-1.4.1
171
172* Fri Oct 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.6-0vl1
173- new upstream release
174
175* Mon Aug 21 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.5.4-0vl1
176- new upstream release
177
178* Fri Jul 07 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.7-0vl2
179- changed Group to Applications/Internet
180
181* Fri Jun 09 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.4.7-0vl1
182- new upstream release
183
184* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.4.2-0vl2
185- rebuild with readline-5.1
186
187* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.2-0vl1
188- new upstream release
189
190* Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 3.0.9-0vl1
191- new upstream release
192- update ja.po ( Source10 )
193- add Japanese description
194- lftp.conf: noreplace
195
196* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-0vl1
197- new upstream release
198
199* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.5-0vl1
200- new upstream release
201
202* Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-0vl1
203- new upstream release
204
205* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl2
206- update ja.po (more work needed...)
207
208* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl1
209- new upstream release
210
211* Sun Apr 4 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 3.0.0-0vl1
212- new upstream release
213
214* Mon Mar 1 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 2.6.12-0vl1
215- new upstream release
216
217* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.11-0vl1
218- new upstream release
219
220* Thu Dec 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-0vl1
221- new upstream release
222
223* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.7-0vl1
224- new upstream release
225
226* Tue Jun 10 2003 Jun NISHII <jun@vinelinux.org> 2.6.5-2vl1
227- synced with RawHide 2.6.5-2
228
229* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.6.3-4vl1
230- synced with RawHide 2.6.3-4
231
232* Wed Jan 23 2002 Jun Nishii <jun@vinelinux.org> 2.4.8-0vl1
233- ver.up
234- fix COPYRIGHT(GPL->GPL2)
235
236* Tue Sep 25 2001 Kazuhisa TAKEI <takei@vinelinux.org>
237- 2.4.4
238- major version  update
239
240* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
241- 2.3.10-0vl5
242- rebuilt with openssl-0.9.6b
243
244* Thu May 24 2001 <sagami@vinelinux.org>
245- 2.3.10-0vl4: fix so as not to own %%{_bindir} itself
246
247* Thu May 24 2001 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.10-0vl3
248- remove configurei's --with-modules option.
249
250* Sat May 19 2001 <takei@vinelinux.org> 2.3.10-0vl2
251- fixed spec bug( sevaral lftp modules lack)
252
253* Fri May 11 2001 <sagami@vinelinux.org>
254- 2.3.10-0vl1: use more macros
255
256* Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl2
257- enable ssl
258
259* Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl1
260- 2.3.7-0vl1
261
262* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
263- 2.3.3-0vl4
264- rebuilt with readline-4
265
266* Thu Oct 12 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl3
267- add lftpget
268
269* Mon Oct  9 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl1
270- upstream merge ja.po
271- %doc /usr/man -> %{_mandir}   
272- several .spec file's bug  fixed.
273
274* Sun Oct  1 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.0-0vl5
275- fixed ja.po
276
277* Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
278- 2.2.6-1vl0
279- remove noroot.patch
280
281* Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
282- 2.2.2-1vl3
283- added Japanese message catalog file
284
285* Thu Jul 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
286- 2.2.2-1vl2
287- cleaned up noroot.patch
288- added %build tag (why forgotten?)
289- added Japanese Summary
290- modified %files section to handle compressed man pages
291
292* Thu May  4 2000 Kazuhisa TAKEI <takei@vinelinux.org>
293- change spec file  for Vine Linux
294
295* Sat Oct 02 1999 Alexander Lukyanov <lav@yars.free.net>
296- 2.1.1 release
297- removed ChangeLog from doc.
298
299* Mon Sep 27 1999 Alexander Lukyanov <lav@yars.free.net>
300- 2.1.0 release
301
302* Tue Sep 14 1999 Alexander Lukyanov <lav@yars.free.net>
303- add lftpget
304
305* Tue Jul 27 1999 Adrian Likins <alikins@redhat.com>
306-initial release
Note: See TracBrowser for help on using the repository browser.