source: projects/specs/trunk/l/lftp/lftp-vl.spec @ 6866

Revision 6866, 10.9 KB checked in by iwamoto, 12 years ago (diff)

update: lftp

Line 
1%define name lftp
2%define version 4.4.0
3%define release 1%{?_dist_release}
4
5Summary: The lftp command line ftp/http client
6Summary(ja): lftp - コマンドライン ftp/http クライアント
7Name: %{name}
8Version: %{version}
9Release: %{release}
10License: GPL3
11Group: Applications/Internet
12# Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.bz2
13Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.xz
14# Source10: lftp-3.0.9-0vl1-ja.po
15# Source10: lftp-3.7.4-ja.po
16URL: http://lftp.yar.ru/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel
19BuildRequires: expat-devel
20
21Packager: iwamoto
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26LFTP is a shell-like command line ftp client. It is
27reliable: can retry operations and does reget automatically.
28It can do several transfers simultaneously in background.
29You can start a transfer in background and continue browsing
30the ftp site or another one. This all is done in one process.
31Background jobs will be completed in nohup mode if you exit
32or close modem connection. Lftp has reput, mirror, reverse
33mirror among its features. Since version 2.0 it also supports
34http protocol.
35
36%description -l ja
37LFTP は、shell ライクなコマンドライン ftp クライアントです。
38リトライ機能の実装や自動的な再取得を行うため信頼性が高いです。
39バックグラウンドで複数の転送を同時に行うことができます。
40バックグラウンドでの転送を開始し、その ftp サイトや別の ftp
41サイトを閲覧し続けることができます。これらは全て 1 つのプロセス
42で実行されます。
43もし、モデムの接続が exit や close された場合、バックグラウンド
44ジョブは、nohup モードで終了します。lftp の特徴は、reput やミラー、
45逆ミラーなどです。バージョン 2.0 以降では、HTTP もサポートしています。
46
47%package scripts
48Summary:        Scripts for lftp
49Summary(ja):    lftp のユーティリティスクリプト
50Group:          Applications/Internet
51Requires:       lftp = %{version}-%{release}
52Requires:       perl(DBD::SQLite)
53BuildArch:      noarch
54
55%description scripts
56Utility scripts for use with lftp.
57
58%description scripts -l ja
59lftp のユーティリティスクリプトです。
60
61%prep
62%setup -q
63
64# cp po/ja.po po/ja.po.orig
65# msgmerge -v %{SOURCE10} po/ja.po.orig -o po/ja.po
66
67%build
68if pkg-config openssl ; then
69        CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
70        LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
71fi
72LDFLAGS="-L`pwd`/src/.libs $LDFLAGS"; export LDFLAGS
73%configure --with-modules --disable-static --with-openssl
74export tagname=CC
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79%makeinstall sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
80rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
81chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
82chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
83
84# Remove files from $RPM_BUILD_ROOT that we aren't shipping.
85rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
86rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
87
88%find_lang %{name}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files -f %{name}.lang
94%defattr(-,root,root)
95%doc README README.modules FAQ THANKS COPYING
96%doc  TODO lftp.lsm NEWS INSTALL FEATURES
97%config(noreplace) %{_sysconfdir}/lftp.conf
98%{_bindir}/*
99%{_mandir}/*/*
100# %{_datadir}/lftp
101%{_libdir}/*.so*
102%dir %{_libdir}/lftp
103%dir %{_libdir}/lftp/%{version}
104%{_libdir}/lftp/%{version}/cmd-*.so
105%{_libdir}/lftp/%{version}/liblftp-network.so
106# %{_libdir}/lftp/%{version}/liblftp-getdate.so
107%{_libdir}/lftp/%{version}/liblftp-pty.so
108%{_libdir}/lftp/%{version}/proto-*.so
109
110
111%files scripts
112%defattr(-,root,root,-)
113%{_datadir}/lftp
114
115%changelog
116* Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.0-1
117- new upstream release
118- use upstream ja.po instead of old local ja.po (source10)
119
120* Sat Jun  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.7-1
121- new upstream release
122- built with openssl 1.0.1
123
124* Mon May  2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.3-1
125- new upstream release
126
127* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-3
128- rebuilt with openssl 1.0.0c
129
130* Wed Jan  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-2
131- separated scripts to script package
132
133* Mon Jan  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-1
134- new upstream release
135- change source tarball format (bz2 -> xz)
136
137* Sat Aug  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.9-1
138- new upstream release with security fix (CVE-2010-2251)
139
140* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.5-1
141- new upstream release 
142- update ja.po file (Thanks to Tadashi Jokagi <elf@elf.no-ip.org>)
143- update %files section to fit new release
144
145* Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.15-1
146- new upstream release
147
148* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.14-1
149- new upstream release
150
151* Wed May 06 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.13-1
152- new upstream release
153
154* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.11-1
155- new upstream release
156
157* Wed Mar 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.9-1vl5
158- new upstream release
159
160* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.8-1vl5
161- new upstream release
162- fix License tag
163
164* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.7-1vl5
165- new upstream release
166
167* Mon Dec 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.6-1vl5
168- new upstream release
169
170* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.4-1vl5
171- new upstream release
172- del liblftp-getdate.so from files list (upstream change)
173
174* Sat Jul 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.3-1vl5
175- new upstream release
176- spec in UTF8
177
178* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-2vl5
179- add BuildPrereq expat-devel
180
181* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-1vl5
182- new upstream release
183- new versioning policy
184
185* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.0-0vl1
186- new upstream release
187
188* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.6.1-0vl2
189- rebuild with expat-2.0.1
190
191* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.6.1-0vl1
192- new upstream release
193
194* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.15-0vl1
195- new upstream release
196
197* Tue Aug 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.13-0vl1
198- new upstream release
199
200* Mon Jul 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.12-0vl1
201- new upstream release
202
203* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-0vl1
204- new upstream release
205- rebuilt with new toolchain and openssl-0.9.8
206
207* Sat Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.9-0vl1
208- new upstream release
209
210* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.5.6-0vl3
211- fix configure option to use openssl
212
213* Sun Oct 29 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.5.6-0vl2
214- rebuild with gnutls-1.4.1
215
216* Fri Oct 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.6-0vl1
217- new upstream release
218
219* Mon Aug 21 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.5.4-0vl1
220- new upstream release
221
222* Fri Jul 07 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.7-0vl2
223- changed Group to Applications/Internet
224
225* Fri Jun 09 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.4.7-0vl1
226- new upstream release
227
228* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.4.2-0vl2
229- rebuild with readline-5.1
230
231* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.2-0vl1
232- new upstream release
233
234* Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 3.0.9-0vl1
235- new upstream release
236- update ja.po ( Source10 )
237- add Japanese description
238- lftp.conf: noreplace
239
240* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-0vl1
241- new upstream release
242
243* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.5-0vl1
244- new upstream release
245
246* Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-0vl1
247- new upstream release
248
249* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl2
250- update ja.po (more work needed...)
251
252* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl1
253- new upstream release
254
255* Sun Apr 4 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 3.0.0-0vl1
256- new upstream release
257
258* Mon Mar 1 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 2.6.12-0vl1
259- new upstream release
260
261* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.11-0vl1
262- new upstream release
263
264* Thu Dec 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-0vl1
265- new upstream release
266
267* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.7-0vl1
268- new upstream release
269
270* Tue Jun 10 2003 Jun NISHII <jun@vinelinux.org> 2.6.5-2vl1
271- synced with RawHide 2.6.5-2
272
273* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.6.3-4vl1
274- synced with RawHide 2.6.3-4
275
276* Wed Jan 23 2002 Jun Nishii <jun@vinelinux.org> 2.4.8-0vl1
277- ver.up
278- fix COPYRIGHT(GPL->GPL2)
279
280* Tue Sep 25 2001 Kazuhisa TAKEI <takei@vinelinux.org>
281- 2.4.4
282- major version  update
283
284* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
285- 2.3.10-0vl5
286- rebuilt with openssl-0.9.6b
287
288* Thu May 24 2001 <sagami@vinelinux.org>
289- 2.3.10-0vl4: fix so as not to own %%{_bindir} itself
290
291* Thu May 24 2001 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.10-0vl3
292- remove configurei's --with-modules option.
293
294* Sat May 19 2001 <takei@vinelinux.org> 2.3.10-0vl2
295- fixed spec bug( sevaral lftp modules lack)
296
297* Fri May 11 2001 <sagami@vinelinux.org>
298- 2.3.10-0vl1: use more macros
299
300* Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl2
301- enable ssl
302
303* Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl1
304- 2.3.7-0vl1
305
306* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
307- 2.3.3-0vl4
308- rebuilt with readline-4
309
310* Thu Oct 12 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl3
311- add lftpget
312
313* Mon Oct  9 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl1
314- upstream merge ja.po
315- %doc /usr/man -> %{_mandir}   
316- several .spec file's bug  fixed.
317
318* Sun Oct  1 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.0-0vl5
319- fixed ja.po
320
321* Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
322- 2.2.6-1vl0
323- remove noroot.patch
324
325* Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
326- 2.2.2-1vl3
327- added Japanese message catalog file
328
329* Thu Jul 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
330- 2.2.2-1vl2
331- cleaned up noroot.patch
332- added %build tag (why forgotten?)
333- added Japanese Summary
334- modified %files section to handle compressed man pages
335
336* Thu May  4 2000 Kazuhisa TAKEI <takei@vinelinux.org>
337- change spec file  for Vine Linux
338
339* Sat Oct 02 1999 Alexander Lukyanov <lav@yars.free.net>
340- 2.1.1 release
341- removed ChangeLog from doc.
342
343* Mon Sep 27 1999 Alexander Lukyanov <lav@yars.free.net>
344- 2.1.0 release
345
346* Tue Sep 14 1999 Alexander Lukyanov <lav@yars.free.net>
347- add lftpget
348
349* Tue Jul 27 1999 Adrian Likins <alikins@redhat.com>
350-initial release
Note: See TracBrowser for help on using the repository browser.