source: projects/specs/trunk/l/less/less-vl.spec @ 7000

Revision 7000, 7.4 KB checked in by daisuke, 12 years ago (diff)

less: update to 451, build with pcre-8.31

Line 
1Summary: A text file browser similar to more, but better
2Summary(ja): more よりも高機能な日本語対応ページャ
3Name: less
4Version: 451
5Release: 1%{?_dist_release}
6
7Group: Applications/Text
8License: GPLv3+
9URL: http://www.greenwoodsoftware.com/less/
10
11Source: http://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
12Source1: lesspipe.sh
13Source2: less.sh
14Source3: less.csh
15Patch1: less-443-Foption.patch
16Patch4: less-394-time.patch
17Patch5: less-418-fsync.patch
18Patch6: less-436-manpage-add-old-bot-option.patch
19Patch8: less-436-help.patch
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: ncurses-devel
23BuildRequires: pcre-devel
24BuildRequires: autoconf automake libtool
25Requires(post): alternatives
26Requires(preun): alternatives
27Requires: gzip, bzip2
28Requires: file >= 3.33
29Provides: pager
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke
34
35%description
36The less utility is a text file browser that resembles more, but has
37more capabilities.  Less allows you to move backwards in the file as
38well as forwards.  Since less doesn't have to read the entire input file
39before it starts, less starts up more quickly than text editors (for
40example, vi).
41
42You should install less because it is a basic utility for viewing text
43files, and you'll use it frequently.
44
45%description -l ja
46less は more よりも高機能な日本語対応ページャです.less は起動時にテキスト
47ファイルを完全に読み込む必要がないので,vi などの テキストエディタに比べて
48高速に起動することができます.
49
50環境変数 LESSOPEN を "|lesspipe.sh %s" に設定することによって, gzip や
51compress で圧縮されたファイルを自動的に展開して表示することもできます.
52
53less はテキストファイルを表示するためによく使用する基本的なツールなので,
54インストールしておくべきでしょう.
55
56%prep
57%setup -q
58%patch1 -p1 -b .Foption
59%patch4 -p1 -b .time
60%patch5 -p1 -b .fsync
61%patch6 -p1 -b .manpage-add-old-bot-option
62%patch8 -p1 -b .help
63
64autoreconf
65
66chmod -R a+w *
67chmod 644 lessecho.c lesskey.c version.c LICENSE
68
69
70%build
71%configure --with-regex=pcre
72make CC="gcc $RPM_OPT_FLAGS -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 `pcre-config --cflags`" datadir=%{_docdir}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77%makeinstall
78strip -R .comment $RPM_BUILD_ROOT/%{_bindir}/less
79mkdir -p $RPM_BUILD_ROOT/etc/profile.d
80install -p -c -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}
81install -p -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/profile.d
82install -p -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
83ls -la $RPM_BUILD_ROOT/etc/profile.d
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89/sbin/update-alternatives --install %{_bindir}/pager pager %{_bindir}/less 50
90
91# fix broken symlink if it's there
92if [ ! -f %{_bindir}/pager ] ; then
93    /sbin/update-alternatives --auto pager
94fi
95
96%preun
97if [ $1 -eq 0 ]; then
98    /sbin/update-alternatives --remove pager %{_bindir}/less
99    /sbin/update-alternatives --auto pager
100fi
101
102%files
103%defattr(-,root,root)
104%doc COPYING LICENSE NEWS README
105%config %{_sysconfdir}/profile.d/*
106%{_bindir}/less
107%{_bindir}/lesskey
108%{_bindir}/lessecho
109%{_bindir}/lesspipe.sh
110%{_mandir}/man1/less.1*
111%{_mandir}/man1/lesskey.1*
112%{_mandir}/man1/lessecho.1*
113
114%changelog
115* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 451-1
116- update to 451
117- build with pcre-8.31
118
119* Sun Oct 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 444-1
120- update to 444
121
122* Sat Mar 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 436-3
123- split Requires(post,preun)
124
125* Sun Sep 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 436-2
126- updated japanese summary and description
127
128* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 436-1
129- updated to 436
130
131* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 382-1vl5
132- applied new versioning policy, spec in utf-8
133
134* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl6
135- add Provides: pager
136- add Requires(post,preun): alternatives
137
138* Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl5
139- add update-alternatives: pager in %%post, %%preun scriptlet
140
141* Thu Nov 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl4
142- revert to 382-iso259 ([VineSeed:12552])
143
144* Wed Nov 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl3
145- update jless patch to 382-iso262
146- update description (iso254 to iso262)
147
148* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl2
149- change log was missing in 382-0vl1
150
151* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl1
152- new upstream release
153- update jless patch to 382-iso258
154
155* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 358-0vl10
156- set _FILE_OFFSET_BITS 64
157
158* Sat May 17 2003 KAZUKI SHIMURA <rito@pos.to> 358-0vl9
159- rebuild with new toolchain
160- fix description (iso242 to iso254)
161
162* Thu Apr 25 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp>
163- 358-0vl8: temporary fix: consistency of the nls-patch and (J)LESSCHARSET
164
165* Sun Mar 31 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
166- 358-0vl7: fix lesspipe.sh for file names with spaces
167
168* Wed Aug 22 2001 Toru Sagami <sagami@vinelinux.org>
169- 358-0vl6: rebuild on ncurses-5.2 (as asked to do so)
170
171* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
172- 358-0vl5: added more documents (COPYING, LICENSE)
173- fix lesspipe.sh again and tweak lesspipe.csh a bit with %%config marked
174
175* Wed Jun 27 2001 Jun Nishii <jun@vinelinux.org> 358-0vl4
176- fix lesspipe.sh
177- do not REset LESSOPEN in profile.d/less.sh
178
179* Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
180- 358-0vl3
181- fixed lesspipe.sh
182
183* Fri Jan 12 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
184- 358-0vl2
185- added bzip2/lha support to lesspipe.sh
186- minor spec fixes
187
188* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
189- 358-0vl1
190- more fix of lesspipe.sh
191- requires file >= 3.33
192- more macros in spec
193
194* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
195- 354-0vl5
196- modify lesspipe.sh to adapt to file-3.33 and to view gzipped nroff file
197
198* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 354-0vl3
199- some fixes to handle man pages correctly
200
201* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 354-0vl2
202- build on gcc-2.95.3
203- partially used rpmmacros
204
205* Wed Jul  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
206- added Sagam's patch to fix parse ctrl code for Japanese. Very thanks Sagami-san.
207
208* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
209- less-354-0vl1
210
211* Mon Jan 17 2000 Yasuyuki Furukawa  <furukawa@vinelinux.org>
212- updated ja_nls patch for memory leaks.
213
214* Mon Jan 10 2000 Jun Nishii <jun@vinelinux.org>
215- rel.7 (5vl2 makes harm for update from Vine-1.1)
216
217* Fri Jan  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
218- rel 5vl2
219- added ja_nls and bzip2 patches
220- added Requires for bzip2 and gzip.
221
222* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
223- rel.6
224- change group
225
226* Sun Sep 6 1999 Jun NISHII <jun@flatout.org>
227- rel.5
228- remove LESS=-r to avoid somed troubles
229
230* Sat Aug 21 1999 Jun NISHII <jun@flatout.org>
231- rel.4
232- change groff path in lesspipe.sh to adapt groff-1.11
233- added /etc/profile.d/less{.,.csh}
234
235* Thu Jun 24 1999 Norihito Ohmori <ohmori@flatout.org>
236- rebuild for glibc-2.1
237
238* Mon Feb 15 1999 Jun NISHII <jun@flatout.org>
239- rel.2
240- added preprocess for bzip2ed file
241- added Japanese summary
242
243* Wed Dec 2 1998 Jun NISHII <jun@flatout.org>
244- rename from less-332iso242-4 to less-332_jp-1
245- strip bins
246
247* Tue Oct 8 1998 Jun NISHII <jun@flatout.org>
248- release 4
249- modify header of spec file
250
251* Sat Sep 26 1998 Jun NISHII <jun@flatout.org>
252- release 3
253- added lesspipe.sh
Note: See TracBrowser for help on using the repository browser.