source: projects/specs/trunk/l/less/less-vl.spec @ 1889

Revision 1889, 7.1 KB checked in by inagaki, 14 years ago (diff)

updated: less, man

Line 
1Summary: A text file browser similar to more, but better
2Summary(ja): more よりも高機能な日本語対応ページャ
3Name: less
4Version: 436
5Release: 2%{?_dist_release}
6
7Group: Applications/Text
8License: GPLv3+
9URL: http://www.greenwoodsoftware.com/less/
10
11Source: http://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
12Source1: lesspipe.sh
13Source2: less.sh
14Source3: less.csh
15#Source3: less-354-hlp-ja.tgz
16Patch1: less-406-Foption.patch
17Patch4: less-394-time.patch
18Patch5: less-418-fsync.patch
19Patch6: less-436-manpage.patch
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: ncurses-devel
23BuildRequires: pcre-devel
24BuildRequires: autoconf automake libtool
25Requires(post,preun): alternatives
26Requires: gzip, bzip2
27Requires: file >= 3.33
28Provides: pager
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The less utility is a text file browser that resembles more, but has
35more capabilities.  Less allows you to move backwards in the file as
36well as forwards.  Since less doesn't have to read the entire input file
37before it starts, less starts up more quickly than text editors (for
38example, vi).
39
40You should install less because it is a basic utility for viewing text
41files, and you'll use it frequently.
42
43%description -l ja
44less は more よりも高機能な日本語対応ページャです.less は起動時にテキスト
45ファイルを完全に読み込む必要がないので,vi などの テキストエディタに比べて
46高速に起動することができます.
47
48環境変数 LESSOPEN を "|lesspipe.sh %s" に設定することによって, gzip や
49compress で圧縮されたファイルを自動的に展開して表示することもできます.
50
51less はテキストファイルを表示するためによく使用する基本的なツールなので,
52インストールしておくべきでしょう.
53
54%prep
55%setup -q
56%patch1 -p1 -b .Foption
57%patch4 -p1 -b .time
58%patch5 -p1 -b .fsync
59%patch6 -p1 -b .manpage
60
61autoreconf
62
63chmod -R a+w *
64chmod 644 lessecho.c lesskey.c version.c LICENSE
65
66
67%build
68%configure --with-regex=pcre
69make CC="gcc $RPM_OPT_FLAGS -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 `pcre-config --cflags`" datadir=%{_docdir}
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%makeinstall
75strip -R .comment $RPM_BUILD_ROOT/%{_bindir}/less
76mkdir -p $RPM_BUILD_ROOT/etc/profile.d
77install -p -c -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}
78install -p -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/profile.d
79install -p -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
80ls -la $RPM_BUILD_ROOT/etc/profile.d
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86/sbin/update-alternatives --install %{_bindir}/pager pager %{_bindir}/less 50
87
88# fix broken symlink if it's there
89if [ ! -f %{_bindir}/pager ] ; then
90    /sbin/update-alternatives --auto pager
91fi
92
93%preun
94if [ $1 -eq 0 ]; then
95    /sbin/update-alternatives --remove pager %{_bindir}/less
96    /sbin/update-alternatives --auto pager
97fi
98
99%files
100%defattr(-,root,root)
101%doc COPYING LICENSE NEWS README
102%config %{_sysconfdir}/profile.d/*
103%{_bindir}/less
104%{_bindir}/lesskey
105%{_bindir}/lessecho
106%{_bindir}/lesspipe.sh
107%{_mandir}/man1/less.1*
108%{_mandir}/man1/lesskey.1*
109%{_mandir}/man1/lessecho.1*
110
111%changelog
112* Sun Sep 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 436-2
113- updated japanese summary and description
114
115* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 436-1
116- updated to 436
117
118* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 382-1vl5
119- applied new versioning policy, spec in utf-8
120
121* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl6
122- add Provides: pager
123- add Requires(post,preun): alternatives
124
125* Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl5
126- add update-alternatives: pager in %%post, %%preun scriptlet
127
128* Thu Nov 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl4
129- revert to 382-iso259 ([VineSeed:12552])
130
131* Wed Nov 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl3
132- update jless patch to 382-iso262
133- update description (iso254 to iso262)
134
135* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl2
136- change log was missing in 382-0vl1
137
138* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl1
139- new upstream release
140- update jless patch to 382-iso258
141
142* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 358-0vl10
143- set _FILE_OFFSET_BITS 64
144
145* Sat May 17 2003 KAZUKI SHIMURA <rito@pos.to> 358-0vl9
146- rebuild with new toolchain
147- fix description (iso242 to iso254)
148
149* Thu Apr 25 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp>
150- 358-0vl8: temporary fix: consistency of the nls-patch and (J)LESSCHARSET
151
152* Sun Mar 31 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
153- 358-0vl7: fix lesspipe.sh for file names with spaces
154
155* Wed Aug 22 2001 Toru Sagami <sagami@vinelinux.org>
156- 358-0vl6: rebuild on ncurses-5.2 (as asked to do so)
157
158* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
159- 358-0vl5: added more documents (COPYING, LICENSE)
160- fix lesspipe.sh again and tweak lesspipe.csh a bit with %%config marked
161
162* Wed Jun 27 2001 Jun Nishii <jun@vinelinux.org> 358-0vl4
163- fix lesspipe.sh
164- do not REset LESSOPEN in profile.d/less.sh
165
166* Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
167- 358-0vl3
168- fixed lesspipe.sh
169
170* Fri Jan 12 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
171- 358-0vl2
172- added bzip2/lha support to lesspipe.sh
173- minor spec fixes
174
175* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
176- 358-0vl1
177- more fix of lesspipe.sh
178- requires file >= 3.33
179- more macros in spec
180
181* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
182- 354-0vl5
183- modify lesspipe.sh to adapt to file-3.33 and to view gzipped nroff file
184
185* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 354-0vl3
186- some fixes to handle man pages correctly
187
188* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 354-0vl2
189- build on gcc-2.95.3
190- partially used rpmmacros
191
192* Wed Jul  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
193- added Sagam's patch to fix parse ctrl code for Japanese. Very thanks Sagami-san.
194
195* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
196- less-354-0vl1
197
198* Mon Jan 17 2000 Yasuyuki Furukawa  <furukawa@vinelinux.org>
199- updated ja_nls patch for memory leaks.
200
201* Mon Jan 10 2000 Jun Nishii <jun@vinelinux.org>
202- rel.7 (5vl2 makes harm for update from Vine-1.1)
203
204* Fri Jan  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
205- rel 5vl2
206- added ja_nls and bzip2 patches
207- added Requires for bzip2 and gzip.
208
209* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
210- rel.6
211- change group
212
213* Sun Sep 6 1999 Jun NISHII <jun@flatout.org>
214- rel.5
215- remove LESS=-r to avoid somed troubles
216
217* Sat Aug 21 1999 Jun NISHII <jun@flatout.org>
218- rel.4
219- change groff path in lesspipe.sh to adapt groff-1.11
220- added /etc/profile.d/less{.,.csh}
221
222* Thu Jun 24 1999 Norihito Ohmori <ohmori@flatout.org>
223- rebuild for glibc-2.1
224
225* Mon Feb 15 1999 Jun NISHII <jun@flatout.org>
226- rel.2
227- added preprocess for bzip2ed file
228- added Japanese summary
229
230* Wed Dec 2 1998 Jun NISHII <jun@flatout.org>
231- rename from less-332iso242-4 to less-332_jp-1
232- strip bins
233
234* Tue Oct 8 1998 Jun NISHII <jun@flatout.org>
235- release 4
236- modify header of spec file
237
238* Sat Sep 26 1998 Jun NISHII <jun@flatout.org>
239- release 3
240- added lesspipe.sh
Note: See TracBrowser for help on using the repository browser.