source: projects/specs/trunk/l/less/less-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 382
2%define release 1%{?_dist_release}
3
4Summary: less (opposite of more) + ISO patch
5Summary(ja): 日本語対応高機能ページャ
6Name: less
7Version: %{version}
8Release: %{release}
9Group: Applications/Text
10License: distributable
11URL: http://www25.big.jp/~jam/less/
12Source: less-%{version}.tar.bz2
13Source1: less-profile.tar.gz
14Source2: lesspipe.sh
15Source3: less-354-hlp-ja.tgz
16
17# jless
18Patch0: http://www25.big.jp/~jam/less/less-382-iso258.patch.gz
19Patch1: http://www25.big.jp/~jam/less/less-382-iso258-259.patch.gz
20Patch2: http://www25.big.jp/~jam/less/less-382-iso259-260.patch.gz
21Patch3: http://www25.big.jp/~jam/less/less-382-iso260-261.patch.gz
22Patch4: http://www25.big.jp/~jam/less/less-382-iso261-262.patch.gz
23
24# some patches for Vine
25# include help in ftp://sakura.sfc.wide.ad.jp/pub/unix/tool/less/less-354-hlp-ja.tgz
26#Patch2: less-354-ja_nls.patch
27#Patch3: less-354-ja_nls-modify.patch
28
29Provides: pager
30Requires(post,preun): alternatives
31Requires: gzip, bzip2
32Requires: file >= 3.33
33Buildroot: %{_tmppath}/%{name}-root
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39This is a more advanced more command with Japanese support by iso259. 
40patch.
41
42EUC/JIS/Shift-JIS are automatically distinguished.  The can set the
43Kanji code with the environment variable JLESSCHARSET. Also you can
44automatically open gzip or compress files and show them with less.
45
46%description -l ja
47more よりも高機能なページャ less を iso259 パッチで日本語対応にしたも
48のです. EUC/JIS/Shift-JIS を自動的に判別し, 環境変数JLESSCHARSET で指
49定された任意の漢字コードで表示します.
50
51環境変数 LESSOPEN を "|lesspipe.sh %s" に設定することによって, gzip や
52compress で圧縮されたファイルを自動的に展開して表示することもできます.
53
54%prep
55%setup -q -a 1
56
57# jless
58%patch0 -p1
59%patch1 -p1
60#%patch2 -p1
61#%patch3 -p1
62#%patch4 -p1
63
64touch configure
65
66%build
67CFLAGS=-D_FILE_OFFSET_BITS=64
68%configure --enable-nls
69make
70
71%install
72rm -rf %{buildroot}
73%makeinstall
74install -p -m 755 %{_sourcedir}/lesspipe.sh %{buildroot}%{_bindir}
75mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
76install -p -m 755 less-profile/less* %{buildroot}%{_sysconfdir}/profile.d/
77
78%clean
79rm -rf %{buildroot}
80
81%post
82%{_syssbindir}/update-alternatives --install %{_bindir}/pager pager %{_bindir}/less 50
83
84%preun
85if [ "$1" = "0" ]; then
86  %{_syssbindir}/update-alternatives --remove pager %{_bindir}/less
87fi
88
89%files
90%defattr(-,root,root)
91%doc COPYING LICENSE NEWS README README.iso README.iso.jp
92%config %{_sysconfdir}/profile.d/*
93%{_bindir}/less
94%{_bindir}/lesskey
95%{_bindir}/lessecho
96%{_bindir}/lesspipe.sh
97%{_mandir}/man1/less.1*
98%{_mandir}/man1/lesskey.1*
99
100
101%changelog
102* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 382-1vl5
103- applied new versioning policy, spec in utf-8
104
105* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl6
106- add Provides: pager
107- add Requires(post,preun): alternatives
108
109* Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 382-0vl5
110- add update-alternatives: pager in %%post, %%preun scriptlet
111
112* Thu Nov 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl4
113- revert to 382-iso259 ([VineSeed:12552])
114
115* Wed Nov 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 382-0vl3
116- update jless patch to 382-iso262
117- update description (iso254 to iso262)
118
119* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl2
120- change log was missing in 382-0vl1
121
122* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 382-0vl1
123- new upstream release
124- update jless patch to 382-iso258
125
126* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 358-0vl10
127- set _FILE_OFFSET_BITS 64
128
129* Sat May 17 2003 KAZUKI SHIMURA <rito@pos.to> 358-0vl9
130- rebuild with new toolchain
131- fix description (iso242 to iso254)
132
133* Thu Apr 25 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp>
134- 358-0vl8: temporary fix: consistency of the nls-patch and (J)LESSCHARSET
135
136* Sun Mar 31 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
137- 358-0vl7: fix lesspipe.sh for file names with spaces
138
139* Wed Aug 22 2001 Toru Sagami <sagami@vinelinux.org>
140- 358-0vl6: rebuild on ncurses-5.2 (as asked to do so)
141
142* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
143- 358-0vl5: added more documents (COPYING, LICENSE)
144- fix lesspipe.sh again and tweak lesspipe.csh a bit with %%config marked
145
146* Wed Jun 27 2001 Jun Nishii <jun@vinelinux.org> 358-0vl4
147- fix lesspipe.sh
148- do not REset LESSOPEN in profile.d/less.sh
149
150* Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
151- 358-0vl3
152- fixed lesspipe.sh
153
154* Fri Jan 12 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
155- 358-0vl2
156- added bzip2/lha support to lesspipe.sh
157- minor spec fixes
158
159* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
160- 358-0vl1
161- more fix of lesspipe.sh
162- requires file >= 3.33
163- more macros in spec
164
165* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
166- 354-0vl5
167- modify lesspipe.sh to adapt to file-3.33 and to view gzipped nroff file
168
169* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 354-0vl3
170- some fixes to handle man pages correctly
171
172* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 354-0vl2
173- build on gcc-2.95.3
174- partially used rpmmacros
175
176* Wed Jul  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
177- added Sagam's patch to fix parse ctrl code for Japanese. Very thanks Sagami-san.
178
179* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
180- less-354-0vl1
181
182* Mon Jan 17 2000 Yasuyuki Furukawa  <furukawa@vinelinux.org>
183- updated ja_nls patch for memory leaks.
184
185* Mon Jan 10 2000 Jun Nishii <jun@vinelinux.org>
186- rel.7 (5vl2 makes harm for update from Vine-1.1)
187
188* Fri Jan  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
189- rel 5vl2
190- added ja_nls and bzip2 patches
191- added Requires for bzip2 and gzip.
192
193* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
194- rel.6
195- change group
196
197* Sun Sep 6 1999 Jun NISHII <jun@flatout.org>
198- rel.5
199- remove LESS=-r to avoid somed troubles
200
201* Sat Aug 21 1999 Jun NISHII <jun@flatout.org>
202- rel.4
203- change groff path in lesspipe.sh to adapt groff-1.11
204- added /etc/profile.d/less{.,.csh}
205
206* Thu Jun 24 1999 Norihito Ohmori <ohmori@flatout.org>
207- rebuild for glibc-2.1
208
209* Mon Feb 15 1999 Jun NISHII <jun@flatout.org>
210- rel.2
211- added preprocess for bzip2ed file
212- added Japanese summary
213
214* Wed Dec 2 1998 Jun NISHII <jun@flatout.org>
215- rename from less-332iso242-4 to less-332_jp-1
216- strip bins
217
218* Tue Oct 8 1998 Jun NISHII <jun@flatout.org>
219- release 4
220- modify header of spec file
221
222* Sat Sep 26 1998 Jun NISHII <jun@flatout.org>
223- release 3
224- added lesspipe.sh
Note: See TracBrowser for help on using the repository browser.