source: projects/specs/trunk/l/lensfun/lensfun-vl.spec @ 4708

Revision 4708, 4.5 KB checked in by iwaim, 13 years ago (diff)

new: lensfun-0.2.5-1

Line 
1
2# Fedora pkg-review: http://bugzilla.redhat.com/466764
3
4Name: lensfun
5Version: 0.2.5
6Summary: Library to rectify defects introduced by photographic lenses
7Release: 1%{?_dist_release}
8License: LGPLv3 and CC-BY-SA
9Group: System Environment/Libraries
10URL: http://lensfun.berlios.de/
11Source0: http://download.berlios.de/lensfun/lensfun-%{version}.tar.bz2
12Patch0: lensfun-0.2.5-cpuid.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires: doxygen
16BuildRequires: glib2-devel
17BuildRequires: libpng-devel
18BuildRequires: pkgconfig
19BuildRequires: python
20BuildRequires: zlib-devel
21
22Distribution: Vine Linux
23Vendor: Project Vine
24Packager: iwaim
25
26%description
27The lensfun library provides an open source database of photographic lenses and
28their characteristics. It not only provides a way to read and search the
29database, but also provides a set of algorithms for correcting images based on
30detailed knowledge of lens properties. Right now lensfun is designed to correct
31distortion, transversal (also known as lateral) chromatic aberrations,
32vignetting and color contribution of a lens.
33
34%package devel
35Summary: Development toolkit for %{name}
36Group:   Development/Libraries
37License: LGPLv3
38Requires: %{name} = %{version}-%{release}
39Requires: pkgconfig
40
41%description devel
42This package contains library and header files needed to build applications
43using lensfun.
44
45%prep
46%setup -q
47%patch0 -p1 -b .cpuid
48
49
50%build
51# We can't use macro configure
52./configure \
53  --cflags="${CFLAGS:-%optflags}" \
54  --cxxflags="${CXXFLAGS:-%optflags}" \
55  --prefix=%{_prefix} \
56  --bindir=%{_bindir} \
57  --sysconfdir=%{_sysconfdir} \
58  --datadir=%{_datadir}/lensfun \
59  --libdir=%{_libdir} \
60  --includedir=%{_includedir} \
61  --libexecdir=%{_libexecdir} \
62%ifnarch %{ix86} x86_64
63  --vectorization \
64%endif
65  --target=..generic
66
67# set GCC.LDFLAGS to avoid stripping and useless -debuginfo
68make AUTODEP=0 %{?_smp_mflags} lensfun manual \
69  V=1 \
70  GCC.LDFLAGS.release=""
71
72
73%install
74rm -rf %{buildroot}
75make AUTODEP=0 INSTALL_PREFIX=%{buildroot} install
76
77
78%clean
79rm -rf %{buildroot}
80
81
82%post -p /sbin/ldconfig
83
84%postun -p /sbin/ldconfig
85
86
87%files
88%defattr(-,root,root,-)
89%dir %{_docdir}/%{name}-%{version}/
90%doc %{_docdir}/%{name}-%{version}/README
91%doc %{_docdir}/%{name}-%{version}/*.txt
92# currently, nothing is covered by GPLv3 (no apps in the package), no need to
93# confuse people:
94%exclude %{_docdir}/%{name}-%{version}/gpl-3.0.txt
95%{_datadir}/lensfun/
96%{_libdir}/liblensfun.so.0*
97
98%files devel
99%defattr(-,root,root,-)
100%doc %{_docdir}/%{name}-%{version}/manual/
101%{_includedir}/lensfun.h
102%{_libdir}/liblensfun.so
103%{_libdir}/pkgconfig/lensfun.pc
104
105
106%changelog
107* Sun Sep  4 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.5-1
108- build for Vine Linux: based Fedora 0.2.5-5
109
110* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.5-5
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
112
113* Wed Sep 29 2010 jkeating - 0.2.5-4
114- Rebuilt for gcc bug 634757
115
116* Mon Sep 20 2010 Nils Philippsen <nils@redhat.com> 0.2.5-3
117- backport cpuid fixes (#631674)
118
119* Mon Jul 26 2010 Dan Horák <dan[at]danny.cz> 0.2.5-2
120- disable SSE vectorization on non x86 arches
121
122* Mon Jun 07 2010 Nils Philippsen <nils@redhat.com> 0.2.5-1
123- lensfun-0.2.5
124- add CC-BY-SA to main package license tag for lens data
125- don't ship GPLv3 text as nothing is licensed under it currently
126- mark documentation files as such
127- shorten summaries, expand package descriptions
128
129* Sun Oct 18 2009 Rex Dieter <rdieter@fedoraproject.orG> 0.2.4-1
130- lensfun-0.2.4 (#529506)
131
132* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-5
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
134
135* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-4
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
137
138* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-3
139- rebuild for pkgconfig deps
140
141* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-2
142- -devel: Requires: pkgconfig
143
144* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-1
145- lensfun-0.2.3
146- fix SOURCE Url
147- configure --target=..generic
148
149* Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-3
150- BR: doxygen
151
152* Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-2
153- fix subpkg deps
154
155* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-1
156- adapt for fedora
157
158* Tue Jun 24 2008 Helio Chissini de Castro <helio@mandriva.com> 0.2.2b-1mdv2009.0
159+ Revision: 228769
160- Added missing buildrequires
161- import lensfun
Note: See TracBrowser for help on using the repository browser.