source: projects/specs/trunk/l/lensfun/lensfun-vl.spec @ 9323

Revision 9323, 4.9 KB checked in by inagaki, 9 years ago (diff)

2015-02-02 Ryoichi INAGAKI <ryo1@…>

  • lensfun, libbsd: updated
  • util-linux: added compat32


Line 
1%global sse  -DBUILD_FOR_SSE:BOOL=OFF
2%global sse2 -DBUILD_FOR_SSE2:BOOL=OFF
3%ifarch x86_64
4%global sse  -DBUILD_FOR_SSE:BOOL=ON
5%global sse2 -DBUILD_FOR_SSE2:BOOL=ON
6%endif
7
8Name: lensfun
9Version: 0.3.0
10Release: 1%{?_dist_release}
11Summary: Library to rectify defects introduced by photographic lenses
12
13License: LGPLv3 and CC-BY-SA
14Group: System Environment/Libraries
15URL: http://lensfun.sourceforge.net/
16
17Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
18
19## upstreamable patches
20# install manpages only when INSTALL_HELPER_SCRIPTS=ON
21Patch1: lensfun-0.3.0-INSTALL_HELPER_SCRIPTS.patch
22# install manpages in the correct place
23Patch2: lensfun-0.3.0-mandir.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: cmake >= 2.8
27BuildRequires: doxygen
28BuildRequires: glib2-devel
29BuildRequires: libpng-devel
30BuildRequires: pkgconfig
31BuildRequires: python-docutils
32BuildRequires: zlib-devel
33
34Distribution: Vine Linux
35Vendor: Project Vine
36Packager: iwaim
37
38%description
39The lensfun library provides an open source database of photographic lenses and
40their characteristics. It not only provides a way to read and search the
41database, but also provides a set of algorithms for correcting images based on
42detailed knowledge of lens properties. Right now lensfun is designed to correct
43distortion, transversal (also known as lateral) chromatic aberrations,
44vignetting and color contribution of a lens.
45
46%package devel
47Summary: Development toolkit for %{name}
48Group:   Development/Libraries
49License: LGPLv3
50Requires: %{name} = %{version}-%{release}
51Requires: pkgconfig
52
53%description devel
54This package contains library and header files needed to build applications
55using lensfun.
56
57%prep
58%setup -q
59%patch1 -p1 -b .INSTALL_HELPER_SCRIPTS
60%patch2 -p1 -b .mandir
61
62
63%build
64mkdir -p %{_target_platform}
65pushd %{_target_platform}
66%cmake \
67    -DBUILD_DOC:BOOL=ON \
68    -DBUILD_TESTS:BOOL=OFF \
69    -DCMAKE_BUILD_TYPE:STRING=Release \
70    %{?sse} %{?sse2} \
71    ..
72popd
73
74make %{?_smp_mflags} -C %{_target_platform}
75make doc -C %{_target_platform}
76
77%install
78rm -rf %{buildroot}
79make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
80
81## unpackaged files
82# omit cmake-installed doxygen docs, we handle that manually
83rm -rfv %{buildroot}%{_docdir}/%{name}-%{version}*
84# omit g-lensfun-update-data because it needs gksudo which we don't ship
85rm -fv %{buildroot}%{_bindir}/g-lensfun-update-data \
86    %{buildroot}%{_mandir}/man1/g-lensfun-update-data.*
87
88%clean
89rm -rf %{buildroot}
90
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96
97%files
98%defattr(-,root,root,-)
99%doc README
100%doc docs/cc-by-sa-3.0.txt docs/lgpl-3.0.txt
101%doc docs/adobe-lens-profile.txt
102%{_bindir}/*
103%{_libdir}/liblensfun.so.0*
104%{_datadir}/lensfun/
105%{_mandir}/man1/*
106
107%files devel
108%defattr(-,root,root,-)
109%doc %{_target_platform}/doc_doxygen/*
110%{_includedir}/lensfun/
111%{_libdir}/liblensfun.so
112%{_libdir}/pkgconfig/lensfun.pc
113
114
115%changelog
116* Sun Feb  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.0-1
117- new upstream release
118- added BR: cmake
119
120* Sun Sep  4 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.5-1
121- build for Vine Linux: based Fedora 0.2.5-5
122
123* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.5-5
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
125
126* Wed Sep 29 2010 jkeating - 0.2.5-4
127- Rebuilt for gcc bug 634757
128
129* Mon Sep 20 2010 Nils Philippsen <nils@redhat.com> 0.2.5-3
130- backport cpuid fixes (#631674)
131
132* Mon Jul 26 2010 Dan Horák <dan[at]danny.cz> 0.2.5-2
133- disable SSE vectorization on non x86 arches
134
135* Mon Jun 07 2010 Nils Philippsen <nils@redhat.com> 0.2.5-1
136- lensfun-0.2.5
137- add CC-BY-SA to main package license tag for lens data
138- don't ship GPLv3 text as nothing is licensed under it currently
139- mark documentation files as such
140- shorten summaries, expand package descriptions
141
142* Sun Oct 18 2009 Rex Dieter <rdieter@fedoraproject.orG> 0.2.4-1
143- lensfun-0.2.4 (#529506)
144
145* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-5
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
147
148* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-4
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
150
151* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-3
152- rebuild for pkgconfig deps
153
154* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-2
155- -devel: Requires: pkgconfig
156
157* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-1
158- lensfun-0.2.3
159- fix SOURCE Url
160- configure --target=..generic
161
162* Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-3
163- BR: doxygen
164
165* Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-2
166- fix subpkg deps
167
168* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-1
169- adapt for fedora
170
171* Tue Jun 24 2008 Helio Chissini de Castro <helio@mandriva.com> 0.2.2b-1mdv2009.0
172+ Revision: 228769
173- Added missing buildrequires
174- import lensfun
Note: See TracBrowser for help on using the repository browser.