source: projects/specs/trunk/l/lbreakout/lbreakout-vl.spec @ 10764

Revision 10764, 2.4 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1## -*- coding: utf-8-unix -*-
2Summary:        LBreakout is a breakout-style arcade game in the manner of Arkanoid
3Summary(ja):    ブロックくずしのアーケードゲーム
4Name:           lbreakout
5Version:        010315
6Release:        4%{?_dist_release}
7Source0:        %{name}-%{version}.tar.gz
8License:        GNU General Public License
9Group:          Applications/Games
10URL:            http://lgames.sourceforge.net/
11
12Requires:       SDL SDL_mixer
13BuildRequires:  SDL-devel SDL_mixer-devel
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Packager:       munepi
18
19%description
20LBreakout is a classical Breakout game, improved with the powers of
21the SDL library. Its features include: sound, highscore, a menu with
22mouse support, mouse or keyboard can be used for playing, controls can
23be redefined, your starting level can be chosen, a difficulty can be
24selected (easy, medium, hard), various backgrounds, a lot of
25collectable extras, nice graphics, cool effects and own levels can be
26created. Give it a try!
27
28%prep
29%__rm -rf ${RPM_BUILD_ROOT}
30
31%setup -q
32
33%build
34%configure --prefix=%{_prefix}
35%__make
36
37%install
38%__mkdir -p ${RPM_BUILD_ROOT}%{_var}/lib/games
39%__make DESTDIR=${RPM_BUILD_ROOT} install
40
41%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
42%__cat > ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop <<EOF
43[Desktop Entry]
44Name=LBreakout
45Comment=LBreakout is a breakout-style arcade game in the manner of Arkanoid.
46TryExec=lbreakout
47Exec=/usr/bin/lbreakout
48Icon=
49Terminal=0
50Type=Application
51Categories=GNOME;Application;Game
52EOF
53
54%clean
55%__rm -rf ${RPM_BUILD_ROOT}
56
57
58%files
59%defattr(-,root,root)
60%doc AUTHORS COPYING ChangeLog INSTALL README TODO
61%{_bindir}/lbreakout
62%{_datadir}/games/lbreakout
63%{_datadir}/applications/%{name}.desktop
64%ghost %{_var}/lib/games/lbreakout.hscr
65
66
67%changelog
68* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 010315-4
69- rebuild with gcc-5.4.0
70
71* Tue Jan 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 010315-3
72- rebuild
73
74* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 010315-2
75- fixed spec file
76- added %%doc in %%files sesion
77- added %%ghost for %%{_var}/lib/games/lbreakout.hscr
78
79* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 010315-1vl5
80- applied new versioning policy, spec in utf-8
81
82* Sun Jun 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 010315-0vl2
83- rebuild for VineSeed
84
85* Tue Mar 9 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 010315-0vl1
86- initial build for Vine Linux
87
88# end of file
Note: See TracBrowser for help on using the repository browser.