source: projects/specs/trunk/l/latexml/latexml-vl.spec @ 7779

Revision 7779, 2.4 KB checked in by munepi, 11 years ago (diff)

supported TeX Live 2013

Line 
1%define pkgname LaTeXML
2
3Name:           latexml
4Version:        0.7.0
5Release:        4%{?_dist_release}
6Summary:        LaTeX to XML Converter
7
8Group:          Development/Libraries
9License:        public domain
10Url:            http://dlmf.nist.gov/LaTeXML/
11Source0:        http://dlmf.nist.gov/LaTeXML/releases/%{pkgname}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildArch:      noarch
14
15BuildRequires:  texlive-vtlpkg >= 2013
16BuildRequires:  perl(Parse::RecDescent)
17BuildRequires:  perl(Image::Magick)
18BuildRequires:  perl(XML::LibXML) >= 1.70
19BuildRequires:  perl(XML::LibXSLT) >= 1.70
20BuildRequires:  perl(DB_File)
21BuildRequires:  perl(Test::Simple)
22
23Distribution:   Vine
24Vendor:         Project Vine
25Packager:       munepi
26
27%description
28latexml is a program, written in Perl, that attempts to faithfully mimic TeX's behaviour, but produces XML instead of dvi. The document model of the target XML makes explicit the model implied by LaTeX. The processing and model are both extensible; you can define the mapping between TeX constructs and the XML fragments to be created. A postprocessor, latexmlpost converts this XML into other formats such as HTML or XHTML, with options to convert the math into MathML (currently only presentation) or images.
29#'
30
31%prep
32%setup -q -n %{pkgname}-%{version}
33
34%build
35export CFLAGS="$RPM_OPT_FLAGS"
36%__perl Makefile.PL TEXMF=%{_tl_texmfvine} INSTALLDIRS=vendor
37%__make
38
39%install
40%__rm -rf $RPM_BUILD_ROOT
41%__make pure_install DESTDIR=$RPM_BUILD_ROOT
42
43find $RPM_BUILD_ROOT -type f -name .packlist | xargs %__rm -f
44
45%check
46%__make test ||:
47
48%post
49%_tl_touch_run texhash
50exit 0
51
52%postun
53if [ "$1" = 0 ]; then
54   %_tl_touch_run texhash
55fi
56exit 0
57
58%posttrans
59%{_tl_exec_texhash}
60exit 0
61
62
63%files
64%defattr(-,root,root)
65%{_bindir}/latexml
66%{_bindir}/latexmlfind
67%{_bindir}/latexmlmath
68%{_bindir}/latexmlpost
69%{_tl_texmfvine}/tex/latex/latexml/latexml.sty
70%dir %{_tl_texmfvine}/tex/latex/latexml
71%{_mandir}/man*/*.*
72%{perl_vendorlib}/LaTeXML.pm
73%{perl_vendorlib}/LaTeXML/*
74%dir %{perl_vendorlib}/LaTeXML
75
76%changelog
77* Thu Aug 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-4
78- added BuildRequires: texlive-vtlpkg >= 2013
79- added some scriptlets to run mktexlsr
80
81* Tue Jun 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-3
82- rebuilt on i386
83
84* Tue May 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-2
85- rebuilt with perl-5.12.3
86
87* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-1
88- initial build
Note: See TracBrowser for help on using the repository browser.